Bug 71560 - Other: Enhancement - Selecting entire row(s) or column(s)
Summary: Other: Enhancement - Selecting entire row(s) or column(s)
Status: RESOLVED DUPLICATE of bug 48571
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-11-13 06:39 UTC by Óvári
Modified: 2013-11-13 09:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Óvári 2013-11-13 06:39:43 UTC
Problem description: 
When typed into a cell, would D:D or $D:$D select the entire D column.
Likewise, would 4:4 or $4:$4 select the entire 4th row.

For example
=VLOOKUP(Sheet2.$D$3,Sheet4.$D1:$D1048576,1)
=VLOOKUP(Sheet2.$D$3,Sheet4.$D:$D,1)

These ranges can be used in other functions too.

This would be helpful as if rows are deleted, or the number of rows are increased in future versions of Calc, the end range will not need to be changed.

Thanks in advance.

Steps to reproduce:
1. =VLOOKUP(Sheet2.$D$3,Sheet4.$D:$D,1)
2. #NAME?

Current behavior:
#NAME?

Expected behavior:
Correct value returned, given by
=VLOOKUP(Sheet2.$D$3,Sheet4.$D1:$D1048576,1)
Operating System: Windows 7
Version: 4.1.3.2 release
Comment 1 m.a.riosv 2013-11-13 09:15:48 UTC

*** This bug has been marked as a duplicate of bug 48571 ***