Bug Hunting Session
Bug 48601 - FILEOPEN: Open Visio's file with bitmap's blocks
Summary: FILEOPEN: Open Visio's file with bitmap's blocks
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All Windows (All)
: medium normal
Assignee: Fridrich Strba
URL:
Whiteboard: target:3.7.0 target:3.5.5 target:3.6....
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-12 05:40 UTC by ape
Modified: 2013-11-13 10:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Visio-2000's file with bitmap blocks (177.50 KB, application/vnd.visio)
2012-04-12 05:40 UTC, ape
Details
Another file LO cannot open and crashes (75.00 KB, application/vnd.visio)
2012-05-24 00:30 UTC, martinstingl
Details
bt + console msgs on master for sitplan (12.77 KB, text/plain)
2012-06-16 05:50 UTC, Julien Nabet
Details
bt + console msgs on master (12.71 KB, text/plain)
2012-06-16 05:54 UTC, Julien Nabet
Details
odg I get from first attachment (sitplan) (42.68 KB, application/vnd.oasis.opendocument.graphics)
2012-06-16 09:38 UTC, Julien Nabet
Details
2nd attachement opened in Microsoft Visio (37.55 KB, image/png)
2012-12-03 07:54 UTC, martinstingl
Details
2nd attachement opened in Draw (42.05 KB, image/png)
2012-12-03 07:54 UTC, martinstingl
Details
visio_2002sp1 (31.46 KB, image/png)
2012-12-04 04:10 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2012-04-12 05:40:18 UTC
Created attachment 59854 [details]
Visio-2000's file with bitmap blocks

My Windows_OS has an additional register files Microsoft Visio, which allows me to open them by clicking the mouse:
--
[HKEY_CLASSES_ROOT\.vsd]
@="LOdevDraw35.Document.2"

[HKEY_CLASSES_ROOT\.vsd\OpenWithProgIDs]
"LOdevDraw35.Document.2"=" "

[HKEY_CLASSES_ROOT\.vst]
@="LOdevDraw35.Template.2"

[HKEY_CLASSES_ROOT\.vst\OpenWithProgIDs]
"LOdevDraw35.Template.2"=" "


[HKEY_CLASSES_ROOT\LOdevDraw35.Document.2]
@="Document Microsoft Visio"

[HKEY_CLASSES_ROOT\LOdevDraw35.Document.2\DefaultIcon]
@="C:\\Program Files (x86)\\LO-dev\\program\\loicons.dll,22"

[HKEY_CLASSES_ROOT\LOdevDraw35.Document.2\shell]
@="open"

[HKEY_CLASSES_ROOT\LOdevDraw35.Document.2\shell\open]

[HKEY_CLASSES_ROOT\LOdevDraw35.Document.2\shell\open\command]
@="\"C:\\Program Files (x86)\\LO-dev\\program\\sdraw.exe\" -o \"%1\""


[HKEY_CLASSES_ROOT\LOdevDraw35.Template.2]
@="Template Microsoft Visio"

[HKEY_CLASSES_ROOT\LOdevDraw35.Template.2\DefaultIcon]
@="C:\\Program Files (x86)\\LO-dev\\program\\loicons.dll,23"

[HKEY_CLASSES_ROOT\LOdevDraw35.Template.2\shell]
@="open"

[HKEY_CLASSES_ROOT\LOdevDraw35.Template.2\shell\open]

[HKEY_CLASSES_ROOT\LOdevDraw35.Template.2\shell\open\command]
@="\"C:\\Program Files (x86)\\LO-dev\\program\\sdraw.exe\" -o \"%1\""
--
 But this Visio's file with bitmap's blocks (see attachment) can be opened only when Draw is already running.
Comment 1 martinstingl 2012-05-24 00:30:51 UTC
Created attachment 62051 [details]
Another file LO cannot open and crashes
Comment 2 Valek Filippov 2012-05-24 15:00:05 UTC
(In reply to comment #1)
> Created attachment 62051 [details]
> Another file LO cannot open and crashes

LO 3.6.0alpha0+ (Build ID: 27cf5f8) -- opens it w/o any issue.
Comment 3 Valek Filippov 2012-05-24 15:03:32 UTC
> --
>  But this Visio's file with bitmap's blocks (see attachment) can be opened only
> when Draw is already running.

Opens from writer (runs draw) on linux w/o problem.
Cyrillic text is not converted properly, but it's currently expected behaviour for VSD v6 files. That part would be improved later.
Comment 4 ape 2012-05-24 19:13:10 UTC
(In reply to comment #3)
> > --
> >  But this Visio's file with bitmap's blocks (see attachment) can be opened only
> > when Draw is already running.
> 
> Opens from writer (runs draw) on linux w/o problem.
> Cyrillic text is not converted properly, but it's currently expected behaviour
> for VSD v6 files. That part would be improved later.

See https://bugs.freedesktop.org/show_bug.cgi?id=48602
Comment 5 ape 2012-05-24 23:12:22 UTC
(In reply to comment #3)
> Opens from writer (runs draw) on linux w/o problem.
--
This is the Windows's problem only.
Comment 6 Julien Nabet 2012-06-16 05:50:48 UTC
Created attachment 63107 [details]
bt + console msgs on master for sitplan

On pc Debian x86-64, with master updated today, I had a crash.
Comment 7 Julien Nabet 2012-06-16 05:54:07 UTC
Created attachment 63108 [details]
bt + console msgs on master

On the same context than my previous comment, I had a crash too with the other file.
You'll notice that console msgs and bt are different.
Comment 8 Not Assigned 2012-06-16 06:08:38 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=74b5e0d5e5b57755553fde6c77712a87025f1667

Related: fdo#48601 FILEOPEN: Open Visio's file with bitmap's blocks
Comment 9 Julien Nabet 2012-06-16 09:38:57 UTC
Created attachment 63115 [details]
odg I get from first attachment (sitplan)

I pushed a fix on master for the crash of the first file.
But there's a problem with characters so I attached the odg to show.
Comment 10 ape 2012-06-16 10:11:01 UTC
(In reply to comment #9)
> But there's a problem with characters so I attached the odg to show.
--
You must use the extension DrawCyr-0.1.1 (for LibreOffice-3.5.x).
See https://bugs.freedesktop.org/show_bug.cgi?id=48602
Comment 11 Fridrich Strba 2012-06-17 12:37:20 UTC
I would strongly discourage using ad-hoc extensions. It should be not a mountain to fix in libvisio if one has some time.
Comment 12 Not Assigned 2012-06-18 01:23:05 UTC
Fridrich Štrba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1d1c70d8114a28a0d37315d408fdc3ef25cf44df

Trying to solve out of bonds in fdo#48601
Comment 13 Not Assigned 2012-06-18 01:31:12 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84464c91aec92fec6eda49629ac8eb11507dd42a&g=libreoffice-3-5

Related: fdo#48601 FILEOPEN: Open Visio's file with bitmap's blocks


It will be available in LibreOffice 3.5.6.
Comment 14 Not Assigned 2012-06-18 01:31:38 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=575583f0531818321216efbf55f880b15edd3dbd&g=libreoffice-3-6

Related: fdo#48601 FILEOPEN: Open Visio's file with bitmap's blocks


It will be available in LibreOffice 3.6.
Comment 15 Not Assigned 2012-06-18 01:32:06 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6677c27574523a75477103ebb35c4c81876633e3&g=libreoffice-3-6

Trying to solve out of bonds in fdo#48601


It will be available in LibreOffice 3.6.
Comment 16 Not Assigned 2012-06-18 03:26:36 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1969514f20cde8728a1d732e0cc3f566ca1400e1&g=libreoffice-3-5

Trying to solve out of bonds in fdo#48601


It will be available in LibreOffice 3.5.6.
Comment 17 Not Assigned 2012-06-18 09:10:31 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7c639ba95ddf2b66401f9ce6943e7c40fa925f2&g=libreoffice-3-5-5

Related: fdo#48601 FILEOPEN: Open Visio's file with bitmap's blocks


It will be available already in LibreOffice 3.5.5.
Comment 18 Not Assigned 2012-06-18 09:11:00 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4dc81a8c3a3ca1054c2c62cc96e75eec4c896409&g=libreoffice-3-5-5

Trying to solve out of bonds in fdo#48601


It will be available already in LibreOffice 3.5.5.
Comment 19 Julien Nabet 2012-06-21 13:31:05 UTC
Fridrich: your patch fixes the crash of the file https://bugs.freedesktop.org/attachment.cgi?id=62051 but do you know why m_colours.size could be < to  colourIndexBG or colourIndexFG ? Is it Visio bug or is it a quick patch to avoid the crash before finding the real cause ? (perhaps something else ? :-))
Comment 20 Julien Nabet 2012-06-21 14:38:02 UTC
Ok, I haven't seen these comments :
- https://bugs.freedesktop.org/show_bug.cgi?id=48602#c5
- https://bugs.freedesktop.org/show_bug.cgi?id=48602#c6.
Comment 21 Fridrich Strba 2012-06-22 03:49:01 UTC
(In reply to comment #19)
> Fridrich: your patch fixes the crash of the file
> https://bugs.freedesktop.org/attachment.cgi?id=62051 but do you know why
> m_colours.size could be < to  colourIndexBG or colourIndexFG ? Is it Visio bug
> or is it a quick patch to avoid the crash before finding the real cause ?
> (perhaps something else ? :-))

First I suspected some uninitialized memory issue. I run the conversion in valgrind and the venerable tool did not find any. So I decided to simply patch the crash itself, since I cannot reproduce the crash and introspection of the file does not help me to advance either.
Comment 22 Valek Filippov 2012-07-08 09:55:57 UTC
Am I right that this one is fixed now and can be closed?
Comment 23 martinstingl 2012-12-03 07:54:18 UTC
Created attachment 70951 [details]
2nd attachement opened in Microsoft Visio
Comment 24 martinstingl 2012-12-03 07:54:40 UTC
Created attachment 70952 [details]
2nd attachement opened in Draw
Comment 25 martinstingl 2012-12-03 07:57:47 UTC
When I open the 2nd attachement (bug.vsd) in LibreOffice Draw Version 3.6.3.2 (Build ID: 58f22d5) (Windows), the result has wrong colours compared to the file opened in Visio. See the latest two attachments for screenshots.
Comment 26 Fridrich Strba 2012-12-03 08:00:46 UTC
(In reply to comment #25)
> When I open the 2nd attachement (bug.vsd) in LibreOffice Draw Version
> 3.6.3.2 (Build ID: 58f22d5) (Windows), the result has wrong colours compared
> to the file opened in Visio. See the latest two attachments for screenshots.

Sorry, when you upload PNG files, don't flag them as text/plain, because it is hard to open them after.
Comment 27 Not Assigned 2012-12-03 09:06:07 UTC
Fridrich Å trba committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ac4d26e3fc2728ee80f33a485540d50b48927ddc

Upload libvisio-0.0.23, fixing regression fdo#48601



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 28 ape 2012-12-04 04:10:29 UTC
Created attachment 70981 [details]
visio_2002sp1

Valek! Which version are you using? Visio 2002 does not open the file (bug.vsd).
Comment 29 Valek Filippov 2012-12-04 04:20:45 UTC
(In reply to comment #28)
> Created attachment 70981 [details]
> visio_2002sp1
> 
> Valek! Which version are you using? Visio 2002 does not open the file
> (bug.vsd).

I don't see any reference of using Visio by myself for files attached to this bug.
Anyway if I used it, it would be version 2010.
Comment 30 ape 2012-12-04 04:38:14 UTC
(In reply to comment #29)
> (In reply to comment #28)
> > Created attachment 70981 [details]
> > visio_2002sp1
> > 
> > Valek! Which version are you using? Visio 2002 does not open the file
> > (bug.vsd).
> 
> I don't see any reference of using Visio by myself for files attached to
> this bug.
> Anyway if I used it, it would be version 2010.

Valek, sorry. This question is not for You. Your comment only contained a link to the message:
martinstingl@gmail.com  2012-05-24 00:30:51 UTC 
Created attachment 62051 [details]
Comment 31 martinstingl 2012-12-21 07:50:04 UTC
The file "bug.vsd" can be opened in Visio Professional 2010 (Version 14.0.6106.5005) without problems.
Comment 32 ape 2012-12-21 09:42:57 UTC
(In reply to comment #31)
> The file "bug.vsd" can be opened in Visio Professional 2010 (Version
> 14.0.6106.5005) without problems.

Thanks. Visio 2007 can be opened this file also.