Bug Hunting Session
Bug 48632 - FILESAVE/FILEOPEN SVG export: wrong black rectangle covering all page (looks similar to page background) added
Summary: FILESAVE/FILEOPEN SVG export: wrong black rectangle covering all page (looks ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: filter:svgExport
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2012-04-12 22:24 UTC by Rainer Bielefeld Retired
Modified: 2015-12-17 05:49 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (7.25 KB, application/x-zip-compressed)
2012-04-12 22:24 UTC, Rainer Bielefeld Retired
Details
NEW Test Kit (148.86 KB, application/x-7z-compressed)
2012-09-17 04:50 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-04-12 22:24:29 UTC
Created attachment 59890 [details]
Test Kit

Steps how to reproduce with "LibreOffice 3.5.2.2 German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) 

1. Open "sourcecreatedwith352.odg" from test kit
2. Menu 'File -> Export -> "sourcecreatedwith352exportedfrom352.svg"'
3. close document
4. for comparison redo from 1. using LibO 3.4.5,  export to 
   "sourcecreatedwith352exportedfrom345.svg"
5. Close
6. Open both svg documents with Seamonkey Browser (or some similar program 
   except LibO)
   Both documents look similar, blue rectangle on white background
7. close
8. Redo 6. with LibO 3.5.2
    Expected: similar view to 6.
    Actual: "sourcecreatedwith352exportedfrom352.svg" shows black background for
             all page size, background visible in all LibO Versions I tested

So it seems here we have a combined problem, LibO 3.5 exports wrongly, but problem only visible with LibO?
Comment 1 Hashem Masoud 2012-09-16 20:28:18 UTC
(In reply to comment #0)
I don't get a black page, I get a black border for the rectangle. The background page is still white.

Did you mean the border?
Comment 2 Rainer Bielefeld Retired 2012-09-17 04:50:13 UTC
Created attachment 67266 [details]
NEW Test Kit

No, looks like page background as I wrote please see test kit in new . But indeed, it is not a page background. Examination of sample370newopenresult.odg shows that a black rectangle filling all the page has been created. It's not a page background what would respect page margins and behave completely different to the black.

Still [Reproducible] with parallel installation of Master "LOdev  3.7.0.0.alpha0+   -  ENGLISH UI / German Locale  [Build ID: b45834b]"  {tinderbox: @6, pull time 2012-09-13 00:10:35} on German WIN7 Home Premium (64bit).

Also reproducible with LibO 3.5.2.2 on Ubuntu 12.04 64Bit (VirtualBox), so NEW

@Hashem Masoud:
Please always contribute complete information with what LibO version you did what test. Without that your results do not help very much.
Comment 3 Rainer Bielefeld Retired 2012-09-17 05:05:16 UTC
It's a combined FILESAVE / FILEOPEN problem.

- SVG exported from 3.4.5 always look fine opened with LibO 3.4.5 or 3.7.0 
  or Browser, what indicates a FILESAVE problem for 3.5 and later
- LibO 3.7.0 opens fine SVG export from 3.4.5, but with black pseude background form later versions, what seems to indicate a  FILESAVE problem for 3.5 and later

- Seamonkey, FF, IE open the exports from later versions fine what seems to 
  indicate a FILEOPEN problem for 3.5 annd later

Regression: Worked with 3.4


@Radek:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 4 Joel Madero 2014-06-09 04:38:41 UTC
Not bibisectable - removing whiteboard status
Comment 5 V Stuart Foote 2015-06-01 12:25:08 UTC
Testing some older SVG issues with recent master builds

Version: 5.0.0.0.alpha1+ (x64)
Build ID: 9d0c51daea67104349cac26de9839afa8baeb099
TinderBox: Win-x86_64@42, Branch:master, Time: 2015-05-15_23:59:35
Locale: en-US (en_US)

.svg black background when exported from ODG with round trip opening/insert is resolved
Comment 6 Robinson Tryon (qubit) 2015-12-17 05:49:02 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]