Bug 48704 - Deleting TABLE column with merged cells deletes all columns with that merged cell
Summary: Deleting TABLE column with merged cells deletes all columns with that merged ...
Status: RESOLVED DUPLICATE of bug 46733
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: x86 (IA32) All
: lowest enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-14 17:23 UTC by Christopher M. Penalver
Modified: 2012-09-24 07:26 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher M. Penalver 2012-04-14 17:23:01 UTC
Downstream report may be found at:
https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564

1) lsb_release -rd
Description: Ubuntu precise (development branch)
Release: 12.04

2) apt-cache policy libreoffice-writer
libreoffice-writer:
  Installed: 1:3.5.2-2ubuntu1
  Candidate: 1:3.5.2-2ubuntu1
  Version table:
 *** 1:3.5.2-2ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main i386 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen in LibreOffice Writer via the Terminal:

cd ~/Desktop && wget https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894856/+files/test.odt && lowriter -nologo test.odt

is when one highlights the second column of the table -> secondary clicks -> Column -> Delete is only that column is deleted. Please see movie for more details: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/462564/+attachment/894864/+files/out.ogv

4) What happens instead is the whole table is deleted.

WORKAROUND: Split the table then delete the column.
Comment 1 Rainer Bielefeld Retired 2012-04-14 18:00:45 UTC
[Reproducible] with "LibreOffice 3.5.2.2" German UI/Locale [Build-ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f] on German WIN7 Home Premium (64bit) 

Splitting first cell heals the problem

This one might be more an enhancement request than a bug

@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 2 vanyasmart 2012-09-24 07:26:01 UTC

*** This bug has been marked as a duplicate of bug 46733 ***