Bug Hunting Session
Bug 48800 - FORMATTING: Impossibility of snapping to increments devalues the usefulness of the ruler
Summary: FORMATTING: Impossibility of snapping to increments devalues the usefulness o...
Status: RESOLVED DUPLICATE of bug 38144
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-16 23:16 UTC by Michael Kamensky
Modified: 2012-04-16 23:25 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Kamensky 2012-04-16 23:16:25 UTC
Problem description: 
The ruler as it's currently implemented in LibO is only useful for looking up the current formatting, not for formatting as such. Moving the markers on the ruler with the mouse is highly imprecise and does not allow to set precise formatting (such as, e.g., 2cm exactly). While Styles may be used to work around this problem (and that is encouraged, as far as I can tell), the ruler is still much less useful than it might be and than it is in many other similar office applications (e.g. AbiWord), which steepens the learning curve for people migrating from other applications and complicates quick formatting of individual sentences and paragraphs.

Steps to reproduce:
1. Type some sentences.
2. Try to format them by moving the ruler markers with your mouse. Try to get the ruler to align exactly to 1.50 cm or 2.00 cm, not to 1.51 or 1.49 or 2.02. 
3. Give up.

Current behavior:
The ruler markers are only useful for telling the current formatting. Using them for some quick formatting, as in other applications, is nearly impossible.

Expected behavior:
Currently LibreOffice functions as it was originally designed, so it's not a bug but a feature extension request. In many other office applications, including AbiWord and Microsoft Office, it's possible to snap to ruler increments and that makes the ruler useful for formatting. In LibreOffice, the typical usage scenario is to use styles-oriented formatting and potentially to hide the ruler altogether because it can't be used precisely anyway.

Platform (if different from the browser): 
Windows Vista
              
Browser: Mozilla/5.0 (Windows NT 6.0; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 vitriol 2012-04-16 23:25:21 UTC

*** This bug has been marked as a duplicate of bug 38144 ***