Download it now!
Bug 48875 - FORMATTING: ISO 8601 date detection overrides locale's date order if '-' is the date separator
Summary: FORMATTING: ISO 8601 date detection overrides locale's date order if '-' is t...
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium major
Assignee: Eike Rathke
URL:
Whiteboard: target:3.6.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-18 06:45 UTC by Cor Nouws
Modified: 2012-05-01 05:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2012-04-18 06:45:51 UTC
- Format Cell
  Date, Formatting 31-12-99 (dd-mm-yy)
- insert 10-03-12 (10 March 2012)
 > cell content changes to 12-03-10
- Date, Formatting 31-12-9999 (dd-mm-yyyy)
 > cell content changes to 12-03-2010

Check Tools > Options > Language … Locale is Dutch
Check Language in Cell formatting … is Dutch
Comment 1 Cor Nouws 2012-04-18 06:48:34 UTC
found in LOdev 36daily120326 3.6.0alpha0+ 
Build ID: a04fee7-4d74905-6299bf6-879ce36-4c023a
and http://dev-builds.libreoffice.org/daily/Linux-x86_10-Release_Configuration/master/current/master~2012-04-17_13.43.52_LibO-Dev_3.6.0alpha0_Linux_x86_install-deb_en-US.tar.gz
Comment 2 Eike Rathke 2012-04-18 07:45:51 UTC
This seems to be an interference of ISO 8601 date with the new date recognition.
Comment 3 Not Assigned 2012-04-18 10:03:07 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9e1862b21684f650ebc1d8d0e5bbdd877b886945

resolved fdo#48875 do not let ISO 8601 detection override locale's date order
Comment 4 Cor Nouws 2012-04-18 11:30:00 UTC
thanks :-)
Comment 5 Cor Nouws 2012-05-01 05:31:22 UTC
thanks!
verified in version 3.6.0alpha0+ Build ID: 87897ea