Download it now!
Bug 48882 - TABLE: Custom title and automatic alignment table properties lost when saving as a .DOC (steps in Comment 6)
Summary: TABLE: Custom title and automatic alignment table properties lost when saving...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc
Depends on:
Blocks: DOC-Tables
  Show dependency treegraph
 
Reported: 2012-04-18 08:18 UTC by Robert Rioja
Modified: 2020-09-17 08:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Zip containing two test files. (8.14 KB, application/x-zip-compressed)
2013-05-30 12:08 UTC, Robert Rioja
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Rioja 2012-04-18 08:18:51 UTC
Problem description: 
Some table properties lost when saving as a .DOC file

Steps to reproduce:
1. Start a new Writer document
2. Insert a table
3. Name it "Header"
4. Set Alignment to Automatic.
5. Save file as a DOC file.

Current behavior:
When file is opened, the table name and alignment are set to default values.

Expected behavior:
Table name and alignment should be whatever I had set them to.

Platform (if different from the browser):
Windows-XP SP3. 
              
Browser: Mozilla/5.0 (Windows NT 5.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 Jaime Navarro 2012-04-19 01:21:43 UTC
[Reproduced] with "LibreOffice 3.5.2 - Debian 6.0.4 i386 English UI"
Comment 2 Joel Madero 2012-09-11 20:56:47 UTC
I don't see this issue. Where are you setting alignment to automatic? Marking as NEEDINFO. Also please provide a test document so that our developers don't have to. Lastly, once you provide a bit more information and the attachment, please reopen as UNCONFIRMED and I'll try to confirm it.
Comment 3 Joel Madero 2012-09-11 20:57:32 UTC
Also, does this look like the same issue that you are reporting?

https://bugs.freedesktop.org/show_bug.cgi?id=48848
Comment 4 QA Administrators 2013-05-29 14:00:11 UTC Comment hidden (obsolete)
Comment 5 Robert Rioja 2013-05-30 12:08:49 UTC
Created attachment 80035 [details]
Zip containing two test files.
Comment 6 Robert Rioja 2013-05-30 12:13:33 UTC
Attached is a zip file with two Writer files that show the bug.  This is how I created the files:
1.  In Writer, start a new document.
2. Click Table, Insert, Table.  In the dialog, click Insert.
3. Open the Table Properties dialog.
4. Change the name to Header, and make sure that the Alignment is set to Automatic.  Then click OK
5. Save As TableTest.odt
6. Save As TableTest.doc
7. Close and reopen Writer.
8. Open the files and check the table properties.
9. The table in the odt file is named Header, but the one in the doc file is named Table1.  Also, the Alignments will not be the same.
Comment 7 ign_christian 2013-06-01 02:23:18 UTC
I can confirm same behavior using LO 4.0.4.1 (Win7 32bit). DOC file not properly save Table properties, though it's invisible to the eyes because default alignment for automatic is left.

Seems similar with Bug 48848, but need to investigate further with that bug.
Comment 8 Jorendc 2013-11-20 18:19:37 UTC
I can confirm this behavior, tested using Mac OSX 10.9 with LibreOffice Version: 4.2.0.0.alpha1+ Build ID: 9c45345a680f7444df251f9403c7d56572380f21
TinderBox: MacOSX-x86@49-TDF, Branch:master, Time: 2013-11-18_12:43:03

Also reproducible using the .docx file format.

Kind regards,
Joren
Comment 9 Murz 2013-11-20 18:29:03 UTC Comment hidden (obsolete)
Comment 10 QA Administrators 2015-04-19 03:21:55 UTC Comment hidden (obsolete)
Comment 11 Murz 2015-04-19 19:14:52 UTC Comment hidden (obsolete)
Comment 12 QA Administrators 2016-09-20 09:32:01 UTC Comment hidden (obsolete)
Comment 13 Telesto 2016-11-29 17:14:01 UTC
Confirming with:
Version: 5.4.0.0.alpha0+ (x64)
Build ID: 7aa2b5a041df8e71a435cccbc79ee13799ec9138
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; Layout Engine: new; 
TinderBox: Win-x86_64@62-TDF, Branch:MASTER, Time: 2016-11-24_11:40:27
Locale: nl-NL (nl_NL); Calc: CL
Comment 14 Murz 2016-11-30 06:52:35 UTC
I also confirm this issue on Version: 5.2.3.2 Build ID: 1:5.2.3~rc2-0ubuntu1~trusty1 in Ubuntu 14.04.
Please fix it.
Comment 15 Xisco Faulí 2017-07-13 10:33:58 UTC Comment hidden (no-value)
Comment 16 Timur 2017-08-29 08:25:54 UTC
Question here is: does DOC support custom title and automatic alignment table properties?
In MSO 2010 title field is greyed out and I see no automatic alignment, just left, center, right. So I guess automatic is converted to left. 
So this may be NotOurBug for .DOC format.
Comment 17 QA Administrators 2018-10-02 02:56:14 UTC Comment hidden (obsolete)
Comment 18 Timur 2020-09-17 08:21:16 UTC
This bug is open for a long time without explanation to Comment 16. 
From what I see, MSO doesn't support Automatic and DOC doesn't support Title. 
When Alt Text is added in MSO and saved as DOC, there's a warning that DOC doesn't support it. 
Not sure, but looks like NotOurBug. I'll close, but if someone has a better explanation, please write. 

DOCX is different. I guess Title from ODT should be saved as Alt Text. 
I'll open a separate bug for that in table, we have some for image and chart.