Bug Hunting Session
Bug 48929 - Presentation mode with video closes the software
Summary: Presentation mode with video closes the software
Status: RESOLVED DUPLICATE of bug 45081
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-19 13:04 UTC by Eliane Domingos de Sousa
Modified: 2012-05-22 03:51 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Presentation used for test (73.67 KB, application/vnd.oasis.opendocument.presentation)
2012-04-19 13:04 UTC, Eliane Domingos de Sousa
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Eliane Domingos de Sousa 2012-04-19 13:04:34 UTC
Created attachment 60337 [details]
Presentation used for test

The software is closed when you insert a video and executes the presentation mode.
Comment 1 Johnny 2012-04-20 18:45:40 UTC
I'm seeing a black box with a big question mark with the presentation. Are you sure the video is embedded within that test presentation?
Comment 2 Eliane Domingos de Sousa 2012-04-21 05:46:38 UTC
Maybe when I inserted the video the link option was selected by default. I made a new presentation file, but the situation is different now. The software don't crash, but don't play the video. 

When the video is not embedded and you try to see the file in the presentation mode, the software is closed. When you embedded the video, the software don't crash and don't play the video.

Link for the files: https://docs.google.com/open?id=0Bzmb-ZecnWluZlh5dVJobUltWDg
Comment 3 Jean-Baptiste Faure 2012-04-21 15:05:19 UTC
(In reply to comment #2)
> [...]
> Link for the files:
> https://docs.google.com/open?id=0Bzmb-ZecnWluZlh5dVJobUltWDg

No crash for me with LO 3.5.4rc0+ (LibreOffice 3.5.4rc0+ Version ID : 299387d-a73d29c-6845e52-f269e46-cd57e28) under Ubuntu 11.10 x86_64 and gnome-shell. The video of Copacabana automatically starts when entered in slideshow mode.

Best regards. JBF
Comment 4 Eliane Domingos de Sousa 2012-04-21 15:33:35 UTC
Hi Jean,

My history (presentation mode):
* Libo 3.5.2 Release (Ubuntu 11.10 64 bits), video linked - don't play the video
* Libo 3.5.2 Release (Ubuntu 11.10 64 bits), video embedded - don't play the video
* Libo 3.5.2 Release (Kubuntu 11.10 64 bits), video embedded - works fine
* Libo 3.5.2 Release (Windows XP 32 bits), video linked - crash
* Libo 3.5.2 Release (Windows XP 32 bits), video embedded - don't play the video
* Libo 3.5.2 Release (Windows 7 64 bits), video linked - crash
* Libo 3.5.2 Release (Windows 7 64 bits), video embedded - don't play the video
Comment 5 Johnny 2012-04-21 18:43:21 UTC
sorry, I am having trouble reproducing this issue (not that I won't be able to). I am on Windows 64 bit using LibO 3.5.2.2 Build ID: 281b639-6baa1d3-ef66a77-d866f25-f36d45f. Even with the .odp with the embedded video I got from your link, the presentation still shows up as a blackbox with a big question mark. When I delete that blackbox and try to Insert -> Movie and Sound from the standalone mp4 file, it complains that "The format of the selected file is not supported". I'm not trying to turn this bugzilla page into a forum. But do you have any ideas about the error?
Comment 6 Jean-Baptiste Faure 2012-04-21 22:37:49 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > [...]
> > Link for the files:
> > https://docs.google.com/open?id=0Bzmb-ZecnWluZlh5dVJobUltWDg
> 
> No crash for me with LO 3.5.4rc0+ (LibreOffice 3.5.4rc0+ Version ID :
> 299387d-a73d29c-6845e52-f269e46-cd57e28) under Ubuntu 11.10 x86_64 and
> gnome-shell. 

works fine too with LO 3.5.2.

Eliane: did you install LO 3.5.2 from TDF or from Ubuntu/Kubuntu repositories/PPA ?

Johnny, to be sure: are you able to play the mp4 video on your PC if you download it (standalone, not in the odp)?

Best regards. JBF
Comment 7 Eliane Domingos de Sousa 2012-04-22 04:44:30 UTC
Hi Jean,

The installations were made from TDF. The hardware with kubuntu is not the same the others systems. I'll do the test with the third computer that I have here. 

More information: this situation is happening with my client in Brazil. The problem is happening in many computers with different periphericals, different OS (Ubuntu, Windows Xp and 7) and LIBO 3.5.2. When they reported the problem for me, I made the tests and the problem occured with me too.

I have no idea what is happening. The only thing that I know is that I made a test with LIBO 3.4.6 and it is working well. To contain the problem in the client, I suggested the installation of LIBO 3.4.6.

Thanks.

Eliane
Comment 8 Johnny 2012-04-22 10:10:21 UTC
JBF: Yes I am able to play the .mp4 on my own PC outside of LibO
Comment 9 Julien Nabet 2012-05-16 15:40:28 UTC
On pc Debian x86-64, with 3.5 branch updated today, here the tests I did :
- downloaded the video 12112011004.mp4 on the same directory as the odp file
- Opened the odp file and clicked F5 nothing

- Inserted the video in the odp file and clicked F5, the video was played ok


Could you try with 3.5.3 and if possible with a brand new LO profile ? (see http://wiki.documentfoundation.org/UserProfile).

On Ubuntu, do you have console logs ?
If still crashes on Ubuntu, could you retrieve an useful backtrace by following this link http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29 ?

On Windows, there's also a way to retrieve the backtrace by following this great video : http://www.youtube.com/watch?v=fppBTs215yc
Comment 10 Petr Mladek 2012-05-22 03:05:38 UTC
Eliane, one more question. Are you able to play the video by any other software on the give system? An often problem are missing codecs.

I am not able to reproduce the problem on SLED11-SP1. It seems to work for other as well. It must be somehow specific for your systems => it can't block the next bugfix release => lowering the severity a bit.
Comment 11 Michael Meeks 2012-05-22 03:51:49 UTC
Surely this is a duplicate of fixed in 3.5.4 - be good to update to that and/or test the rc1. Thanks !

*** This bug has been marked as a duplicate of bug 45081 ***