Download it now!
Bug 48969 - FILEOPEN: Opening powerpoint ODF presentation results very small text
Summary: FILEOPEN: Opening powerpoint ODF presentation results very small text
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard: BSA odf target:3.6.0 target:3.5.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-20 06:50 UTC by Bart Hanssens
Modified: 2012-05-19 09:22 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Hanssens 2012-04-20 06:50:46 UTC
Problem description: 

Steps to reproduce:

1. Download presentation from http://plugfest.opendocsociety.org/lib/exe/fetch.php?media=plugfests:201204_brussels:20120419-jimthatcher-8thodfplugfest-welcome.odp

2. Open it in LibreOffice 3.5.2 (Windows 7)


Current behavior:

Text is mingled or displayed in a very small font.
This isn't the case in Oracle OpenOffice 3.3 or MS-Powerpoint 2010.

Expected behavior:

- Make the text the correct font size

Platform (if different from the browser): 

- LibreOffice 3.5.2.2 on Windows 7 (64 bit)

Comment from Fridrich: the font-size parser waits for points, here the font-size is in inches, will fix
Comment 1 Not Assigned 2012-04-20 11:56:42 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=84aeb737c7c013c8d98d8c40abfca44f6f70cee8

fdo#48969: switch units in Converter::convertDouble
Comment 2 Not Assigned 2012-04-20 11:57:07 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=62a0b2405798a3be6a4e38652f1da7a685c84bfc

fdo#48969: GetConversionFactor: add inch as source unit
Comment 3 Not Assigned 2012-04-20 11:57:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ee376102becc16c0c44d23e5eb2a322aadc45197

fdo#48969: add unit test for Converter::convertDouble
Comment 4 Michael Stahl (allotropia) 2012-04-20 12:16:30 UTC
this is a funny regression in 3.5, the unit parameters to the
unit conversion function were switched, so it went in the wrong direction.

the buggy conversion function sax::Converter::convertDouble was buggy
since it was added many years ago, but it was also unused, until
i cleaned up some code duplication and removed its duplicate
(which did it correctly) with commit 3ca2bef76886450058d1667703aeafe4c2e456c3

to prevent future calamities of that nature i've added a unit test.
Comment 5 Not Assigned 2012-04-20 13:25:19 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=014738b17e07a25a156dd3b459442678d0de3d03&g=libreoffice-3-5

fdo#48969: switch units in Converter::convertDouble


It will be available in LibreOffice 3.5.4.
Comment 6 Not Assigned 2012-04-20 13:25:43 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=124881b16fee79be683507928c06ce54a5a2543e&g=libreoffice-3-5

fdo#48969: GetConversionFactor: add inch as source unit


It will be available in LibreOffice 3.5.4.
Comment 7 Not Assigned 2012-04-20 13:26:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3186b307260cf4e633c252022b803dcf6f31273c&g=libreoffice-3-5

fdo#48969: add unit test for Converter::convertDouble


It will be available in LibreOffice 3.5.4.
Comment 8 Not Assigned 2012-04-22 22:36:04 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=691325d67ef395ec9a758e5f8acc46767455ac98&g=libreoffice-3-5-3

fdo#48969: switch units in Converter::convertDouble


It will be available already in LibreOffice 3.5.3.
Comment 9 Not Assigned 2012-04-22 22:36:32 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf12c5e164575935a30ce626e3b4ea59183980db&g=libreoffice-3-5-3

fdo#48969: GetConversionFactor: add inch as source unit


It will be available already in LibreOffice 3.5.3.
Comment 10 Not Assigned 2012-04-22 22:36:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-3-5-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=30878ae72d0881e9e3990bc6911a7e5ee4b64cd6&g=libreoffice-3-5-3

fdo#48969: add unit test for Converter::convertDouble


It will be available already in LibreOffice 3.5.3.
Comment 11 s-joyemusequna 2012-05-19 09:22:17 UTC
Verified with LOdev 3.6 (master - 18-May-2012 02h44 x86@6-fast; Build ID: 8b1d29b) under Windows Vista 64.