Download it now!
Bug 49043 - "Inserting External Data in Table" problem
Summary: "Inserting External Data in Table" problem
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-04-21 10:30 UTC by Nicola Ricciarelli
Modified: 2015-12-15 22:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example dialog screenshots showing working query. (225.84 KB, application/zip)
2013-05-25 04:37 UTC, Owen Genat (retired)
Details
screenshot (172.09 KB, image/jpeg)
2013-05-26 14:09 UTC, Nicola Ricciarelli
Details
screenshots (278.00 KB, application/x-rar-compressed)
2013-05-26 14:39 UTC, Nicola Ricciarelli
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Ricciarelli 2012-04-21 10:30:58 UTC
Problem description: 
If I try to insert an external data, after inserting the link the "Import Option" window not appears. I've done some tests and the just released Libreoffice 3.5.3RC1 still have that problem, while using Libreoffice 3.4.6 it imports perfectly.
 
Steps to reproduce:
1. open new spreadsheet, click 'A1'
2. Menu 'Insert > Link to External Data'
3. Insert "http://www.milanofinanza.it/quotazioni/dettaglio_quotazioni.asp?StockCodeRt=43dd&codiceStrumento=d23d&selettore=&refresh_cens" into the URL panel
   
Current behavior: nothing happens

Expected behavior: the Import Option windows should appear and than something should be shown in "Available tables/ranges"

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.0; rv:14.0) Gecko/20120420 Firefox/14.0a1
Comment 1 Jean-Baptiste Faure 2012-04-21 23:18:53 UTC
Whatever version I use but 3.3.4, nothing happens.
The link you gave want to define several cookies: did you try with a website which does not that?

Best regards. JBF
Comment 2 Nicola Ricciarelli 2012-04-22 00:23:15 UTC
(In reply to comment #1)
> Whatever version I use but 3.3.4, nothing happens.
> The link you gave want to define several cookies: did you try with a website
> which does not that?
> 
> Best regards. JBF


Other links works good, but query links are more "simple". If you try that link with Libreoffice 3.4.6 using Windows or Linux, in both cases it works perfectly: appears the Import Option window, than the list of available tables to choose and the infos are correctly imported. Libreoffrice 3.5.2 and 3.5.3RC1 instead surely have problems with that link. If it's a cookies problem, it's a "restriction" introduced with the new 3.5.x versions. (As 3.5.0 and 3.5.1 versions are nomore available, I've not been able to test if that versions had that problem too or if it's a more recent "problem"). I've indicated that link because that's my primary source for such datas and if I try to insert a new external link source, passing from working perfectly to nothing working .. that means something happened in the meanwhile).

Nicola
Comment 3 Nicola Ricciarelli 2012-04-26 12:21:42 UTC
I've just installed the new Libreoffice 3.5.3RC2 and the problem is solved.
Thx! 

Nicola
Comment 4 Nicola Ricciarelli 2012-05-18 23:28:32 UTC
I've just tested the new libreoffice 3.5.4RC1 and the problem is back again.
Comment 5 fabien.michel 2012-10-11 09:49:57 UTC
I think i've the same probleme on Version 3.6.2.2 (Build ID: da8c1e6)
Step to reproduce :
1. Create simple calc document with random data; save on desktop
2. Create another calc document.
3. Menu Insert > Link to external data
4. In first field, browse to select the first calc document
5. Then nothing happen. No sheet to be selected in the list, Ok button grayed.

On MacOS 10.7
Comment 6 Nicola Ricciarelli 2012-10-13 08:46:46 UTC
(In reply to comment #5)
> I think i've the same probleme on Version 3.6.2.2 (Build ID: da8c1e6)
> Step to reproduce :
> 1. Create simple calc document with random data; save on desktop
> 2. Create another calc document.
> 3. Menu Insert > Link to external data
> 4. In first field, browse to select the first calc document
> 5. Then nothing happen. No sheet to be selected in the list, Ok button
> grayed.
> 
> On MacOS 10.7


To do that you can use: "Insert --> Sheet From File" (it's a clone of "Insert --> Sheet": they have the same choice window appearing, the unique difference is that it's marked "From file" instead of "New Sheet").
I've tested that solution on Windows and Linux versions, it works good, you'll see it works on MacOS too. Let me know.

Effectively the "Link to External Data" writing, "Enter the URL to the source document in the local file system or Internet here.", is not properly correct as using local hard disk documents it not works. It'd be better to write: "Enter the Internet URL to the source document here."

Nicola
Comment 7 Owen Genat (retired) 2013-05-25 04:37:56 UTC
Created attachment 79780 [details]
Example dialog screenshots showing working query.

Nicola, I just tried the query provided in the description here under GNU/Linux with v4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539) without issue. I have attached some screenshots of the dialogs showing the data. I have no idea if what I am seeing is correct in terms of the data, but the process appears to work for me.
Comment 8 Nicola Ricciarelli 2013-05-25 10:17:11 UTC
(In reply to comment #7)
> Created attachment 79780 [details]
> Example dialog screenshots showing working query.
> 
> Nicola, I just tried the query provided in the description here under
> GNU/Linux with v4.0.3.3 (Build ID: 0eaa50a932c8f2199a615e1eb30f7ac74279539)
> without issue. I have attached some screenshots of the dialogs showing the
> data. I have no idea if what I am seeing is correct in terms of the data,
> but the process appears to work for me.

Hi Owen, thanks for screenshots. 
That problem nomore affect all recent stable v4.* versions. 
It happened that 3.* rc versions had that problem while the stable versions had no problems (so unusual). 
For Libreoffice v4.* I've not checked if rc versions still continue to have that problem, I just checked stable released ones .. but I'll test next rc to check that error presence.

Nicola
Comment 9 retired 2013-05-26 09:31:36 UTC
Hi Nicola,

LO 4.1.0.0 beta is out. Could you give that a try?

http://www.libreoffice.org/download/pre-releases/
Comment 10 Nicola Ricciarelli 2013-05-26 14:09:37 UTC
Created attachment 79801 [details]
screenshot
Comment 11 Nicola Ricciarelli 2013-05-26 14:14:36 UTC
Hi James, I noticed the new 4.1.0.0 beta and immediately downloaded and installed it to test. I tried to add this link     http://www.milanofinanza.it/quotazioni/dettaglio_quotazioni.asp?StockCodeRt=0ac5&selettore=&codiceStrumento=d23e&refresh_cens

As you can see from the screenshot, Libreoffice remains locked, "Not answering". unique solution: brutally kill the application. 

Nicola
Comment 12 Nicola Ricciarelli 2013-05-26 14:39:43 UTC
Created attachment 79804 [details]
screenshots

.. instead, as you can see from attached screenshots, that same link works perfectly using Libreoffice 4.0.3
Comment 13 Owen Genat (retired) 2013-08-17 08:12:05 UTC
Has the site / links provided in the original description and comment 11 been altered or changed recently? I mean the source site and not the links in this bug. I ask because when I look at the returned HTML code now, the data is no longer enclosed by a <table> element. There is one all-inclusive <table> element (tablehome) that covers the entire body of the page, but the data (the smaller table of statistics) is instead encapsulated by <div> elements. I suppose it is possible that this may cause a problem in this instance, as I indicate in my comment here: https://bugs.freedesktop.org/show_bug.cgi?id=54533#c2

An example of a link that returns a series of HTML <table> elements enclosing data (e.g., Asset Allocation) can be found in bug #63407: 

http://portfolios.morningstar.com/fund/summary?t=VTI

This link does take a while to respond for me, but eventually returns under v3.5.7.2 with a list of tables that are subsequently inserted as expected. Under v4.1.0.4 however the initial External Data dialog does not respond with a list of tables. 

Exactly what all this means for this particular bug I am uncertain. Is the HTML returned by the links in the description and comment 11 less-than-ideal? Does the data need to be (more) directly enclosed in a <table> element? Could Nicola or others confirm if my assessment of the links is correct? Nicola, could you also confirm that the returned HTML is what you would expect?
Comment 14 Nicola Ricciarelli 2013-08-18 15:20:30 UTC
Hi Owen, I've to check if I still have an old saved copy of the page indicated in Comment11 .. I'll check it and let you know. Anyway, I've done some "homeworks": I don't think the structure of the page creates problems. I've just tried to import datas from link in Comment11, I've done a copy/paste of that link, and it worked perfectly using LO-4.0.4 (tested windows and linux versions) and LO-4.0.5.1 (tested windows and linux versions). The problems are if I pass to use the stable LO4.1.0 and the newer LO-4.1.1.1 (for both versions I've checked just the windows version).
For past versions as you can read from messages, the same link worked perfectly with stable versions but not with rc versions (and that not worried me really a lot as rc versions are development versions). Now I see that stable LO-4.1.0 has that problem too ..

I check if I've an old copy of that webpage to see if they changed something and let you know.

PS: now I'm using LO-4.1.1.1 and I've read your answers to bug #54533. If I try to import datas, as you suggested in Comment 2, .. nothing happens: the table structure remains empty. Following your test I tried to cut parts of my problematic link .. just bad news.
Comment 15 Nicola Ricciarelli 2013-10-26 20:18:24 UTC
with Libreoffice 4.1.3.1 it worked good. I've just tested Libreoffice 4.1.3.2 and .. the same problem is back.
Comment 16 Owen Genat (retired) 2013-10-28 23:06:18 UTC
I have been corresponding with Nicola (reporter) about this problem and after testing thoroughly versions 4.1.2.2, 4.1.2.3, 4.1.3.1, and 4.1.3.2 under Crunchbang 11 linux DEB x86_64 build (by me) and the Windows build (by Nicola) it would appear the problem is resolved. We both managed to get the occasional erroneous result without any consistency in session or LO version e.g., no response or the "Text Import" dialog instead of the usual "Import Options" dialog. Therefore it is not clear whether these occasional problems are protocol, website, server, or LO related. All the above testing was done using the link provided in the description and comment #11.

I have now re-tested v4.1.2.2 and v4.1.3.2 (under both Ubuntu v10.04 x86_64 and Crunchbang 11 x86_64) using the link in comment #13 and in both instances it responds as expected i.e., data is inserted OK.

I think this bug can be RESOLVED as either FIXED or WORKSFORME. I will leave it for Nicola or QA/developer to perform this action.
Comment 17 Nicola Ricciarelli 2013-10-29 01:32:57 UTC
As Owen reported, looking at recent versions of LO, this bug can be considered as fixed.
Comment 18 Jean-Baptiste Faure 2013-10-29 05:24:54 UTC
In this case WorksForMe seems a more accurate choice.
Thank you very much for all the tests done.

Best regards. JBF
Comment 19 Owen Genat (retired) 2014-08-23 04:47:30 UTC
(In reply to comment #13)
> http://portfolios.morningstar.com/fund/summary?t=VTI

Using the indicated link it appears there is a regression in handling under v4.3.0.4.

(In reply to comment #16)
> I have been corresponding with Nicola (reporter) about this problem and
> after testing thoroughly versions 4.1.2.2, 4.1.2.3, 4.1.3.1, and 4.1.3.2
> under Crunchbang 11 linux DEB x86_64 build 

Under GNU/Linux using these versions the link works as expected:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.2 Build ID: 185f2ce4dcc34af9bd97dec29e6d42c39557298f
- v4.4.0.0.alpha0+ Build ID: e379401618268ed7f7f5885a36b90e1f4f6cd4af TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-08-18_05:51:03

... but using v4.3.0.4 Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0 the link does not return with the expected confirmation or list of HTML tables. Status set to REOPENED. "Regression" keyword added to Whiteboard.
Comment 20 Jean-Baptiste Faure 2014-08-23 18:57:15 UTC
For me it works in LO 4.3.2.0.0+ (Build ID: c8964193051a9ef543a50c7d87c78da99f253fbd)
and in master. 
Note: it works if, after having pasted the url into the url field, I hit the Enter key. Only pasting the url does nothing.

Best regards. JBF
Comment 21 Owen Genat (retired) 2014-09-06 05:49:29 UTC
(In reply to comment #20)
> Note: it works if, after having pasted the url into the url field, I hit the
> Enter key. Only pasting the url does nothing.

Yes, I have been pressing ENTER after pasting the link. It appears to have been a minor regression as now under GNU/Linux using:

- v4.3.1.2 Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
- v4.4.0.0.alpha0+ Build ID: 652b807658a54cd2ccd04ebc6900d2cf1ce85015 TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-05_01:32:46

... it is working again. Reading back over this bug this facility seems to often break early in each series and then get fixed at a later point. Status set back to RESOLVED as WORKSFORME. I think this is likely the same problem described in bug 57675. Thanks JBF for the v4.3.2 test.
Comment 22 Robinson Tryon (qubit) 2015-12-15 22:17:42 UTC
Migrating Whiteboard tags to Keywords: (Regression)
[NinjaEdit]