Bug 49104 - FILEOPEN: LibreOffice - Microsoft Word Documents improper formatting cases‏ (Table Cell Contents & Margins).
Summary: FILEOPEN: LibreOffice - Microsoft Word Documents improper formatting cases‏ (...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-24 03:51 UTC by abm_v
Modified: 2016-04-07 10:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Attached are the test documents and screenshot jpg files with explnation of what goes wrong in LibO 3.5.2.2 (1.21 MB, application/x-zip-compressed)
2012-04-24 03:51 UTC, abm_v
Details

Note You need to log in before you can comment on or make changes to this bug.
Description abm_v 2012-04-24 03:51:40 UTC
Created attachment 60520 [details]
Attached are the test documents and screenshot jpg files with explnation of what goes wrong in LibO 3.5.2.2

Problem description: Provided are four documents created in Microsoft Word 2010 that have visible,noticeable formatting 
problems with text content displayed in cells when opened
in LibreOffice. 

Steps to reproduce:
1. Open the documents in Microsoft Office Word  2010 or check jpg screenshots of rendering in Microsoft Office Word 2010 and comments in red.
 
2. Open the same in LibO 3.5.2.2 and check rendering of contents in table cells.

Current behavior: Text in table cells not appearing or
aligning properly. 

Expected behavior: The text should appear properly 
as in Microsoft Office Word 2010 Rendering.

This may have to do with some logic in table content
rendering where some extra logic should be added
to bridge the gaps

Platform (if different from the browser): Windows 7 32 BIT SP1
              
Browser: Mozilla/5.0 (Windows NT 6.1; rv:11.0) Gecko/20100101 Firefox/11.0
Comment 1 bfoman (inactive) 2012-04-26 03:03:31 UTC
Checked with:
LOdev 3.5.3rc1+ 
Build ID: 51648779-22e3d74-d554af7
Windows 7 Professional SP1 64 bit
Word 2010 SP1

c1 - confirmed
c2 - confirmed - pictures are present in LO
c3 - confirmed - picture in different color than in Word
c4 - I can't see pictures in Word - both are present in LO
Comment 2 bfoman (inactive) 2012-10-12 17:39:14 UTC
NEW per comment 1.
Comment 3 QA Administrators 2015-01-05 17:51:30 UTC Comment hidden (obsolete)
Comment 4 abm_v 2015-01-06 17:31:26 UTC
Dear QA Guy,

I have tested it with

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5

and this it to confirm that from the attachments

c1_issue.png
c1.doc

the case of c1.doc is still not handled after so many years,as no one really cares about it.(sigh!)

c4.docx
c3_issue.png

also exists.

Please have a discussion with the young bloods on how you
can solve this, may be a complete rewrite of that section
of code.Hoping the next release scheduled of 2018 will
solve this issue.

With found regards.

The guy who tested
Comment 5 A (Andy) 2015-12-27 19:11:25 UTC
Reproducible with LO 5.1.0.1, Win 8.1

c1: After the title a page inserted

c2: Improved, but text in the header and footer is black instead of grey

c3: After the title a page inserted, footer is wrong

c4: Improved, but text in the header and footer is black instead of grey
Comment 6 Timur 2016-04-07 10:36:32 UTC
It's highly unlikely that any bugs of type "multiple problems/bad rendering", will be fixed, so this bug shouldn't have been confirmed at all.
Each issue (section break, paragraph break, text box, picture...) should be reported separately, after a search for already reported bugs. 
FILEOPEN problems are different from FILESAVE, and DOC is different filter from DOCX.
Only if bugs don't exist, they should be reported separately, even if they happen with the same file.

Issues may preferably be checked before with master LO version from http://dev-builds.libreoffice.org/daily/master/ or using Separate Install GUI tool http://tdf.io/siguiexe in Windows. It downloads and extracts different LO versions, without installing, so you may test different versions. It only needs MS Visual C++ Runtime installed. 


For c1 and c3 (which is doc, not docx), it's likely Bug 86468, so I add reporter there. There are multiple section break bugs already reported. Yes, very annoying that it was never solved. 
For c2 and c4, LO 5.1 has missing images, and LO 5.2 restores their color. Text in the header and footer is black and PDF export looks the same from MSO and LO. It only appears grey in MSO until clicked in. 

I'll close this one as Invalid.