Bug Hunting Session
Bug 86468 - FILEOPEN: DOC import splits the page into two - Section break problem
Summary: FILEOPEN: DOC import splits the page into two - Section break problem
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.1 rc
Hardware: All All
: highest normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:doc, regression
: 73738 87608 88694 100673 118951 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-11-19 16:33 UTC by Timur
Modified: 2018-10-04 09:11 UTC (History)
12 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case - frigit doc, 1st paragraph only (46.00 KB, application/vnd.ms-word)
2015-02-06 09:29 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2014-11-19 16:33:24 UTC
Problem description: opening specific DOC file in Writer splits the page into two

Steps to reproduce:
1. Download doc file at http://www.cgedd.fr/prix-immobilier-friggit.doc
2. Open the file with LO 4.3.0.3 - it has 7 pages as it should
3. Open same file with LO 4.3.1.1 or newer - it has 8 pages because the 1st page is split into 2 (after the first line)
              
Tested in Windows and confirmed in Ubuntu.
Comment 1 Timur 2014-11-19 17:04:58 UTC
There are multiple problems with this file:
1. crash on PDF export, original report in bug 80508, confirmed in Linux Mint but not always reproducible
2. accidental crash on scrolling down (with mouse on vertical scroll) to the end and up - tested in Windows 7 x64 with LO 4.3.2 and LO 4.3.3 but cannot be (easily?) reproduced with 4.3.4
3. 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both in Windows and Linux, reported as Bug 86468
4. PDF export incomplete, there are items missing in WMF or EMF (legend, caption) - not reported yet or duplicate
5. WMF images in DOC file not rendered correctly in Linux - Bug 80503
Comment 2 tommy27 2014-11-20 03:21:03 UTC
I confirm bug with 4.3.3.2 and 4.4.0.0 alpha2 under Win7x64
bug not present in 4.3.0.4.

status NEW. regression, needs bibisecting.
Comment 3 Xisco Faulí 2014-11-20 14:39:52 UTC
Regression introduced in range: 43a37822dc82abd16e0d99b5bbe21ac469c04ddd..ecbc20d0c7d58c3c6cd0e1c517848157107120a0
Comment 4 Xisco Faulí 2014-11-20 15:14:16 UTC
it looks like this issue was introduced by c5ed52b1cd6f22787c94bec035ceecf9e1da3271.
Add Lubos as CC
Comment 5 Timur 2014-12-24 17:53:00 UTC
Bug reproducible in LO 4.4.0
Comment 6 Timur 2015-02-06 09:29:02 UTC
Created attachment 113172 [details]
Test case - frigit doc, 1st paragraph only
Comment 7 Timur 2015-02-13 12:43:39 UTC
Added Bug 85728 and Bug 64372 to See Also, because it's also a problem with Section break. 
I didn't mark as duplicate because that started in 3.6.0.4 for DOCX and this in 4.3.1.1 for DOC.
Comment 8 Timur 2015-02-13 12:45:11 UTC
*** Bug 87608 has been marked as a duplicate of this bug. ***
Comment 9 Joel Madero 2015-02-16 17:20:45 UTC
@Timur - in the future please do not put bugs that you report on the MAB list. It's really quite impossible for people to be unbiased with their own bug reports. I am not going to remove the bug but I don't see why it should be on the MAB list (we have a single test). 

Also for MAB please ensure that the priority is set to highest
Comment 10 Timur 2015-02-17 09:14:43 UTC
ok. I added it only after I found a duplicate, so we may say I'm also adding somebody else's bug. Thank you for not removing it.
Comment 11 Robinson Tryon (qubit) 2015-03-05 14:28:14 UTC Comment hidden (obsolete)
Comment 12 Timur 2015-04-03 17:42:09 UTC
Bug reproducible in libo-master~2015-04-02_23.41.35_LibreOfficeDev_4.5.0.0.alpha0_Win_x86
Comment 13 Timur 2015-08-28 15:02:36 UTC
*** Bug 73738 has been marked as a duplicate of this bug. ***
Comment 14 Timur 2015-09-11 16:05:34 UTC
Any chance to have this fixed for 4.4.6? Thank you.
Comment 15 Joel Madero 2015-09-11 18:10:09 UTC
Probably not. It'll require a volunteer taking interest in the issue. We don't get ETA's - if it's a serious issue for you then the options are always the same:

1) Fix yourself;
2) Find someone else to fix it;
3) Pay for a fix;
4) Wait patiently for a volunteer.

We try to discourage pinging the bug just to ask for ETA's and "will this be fixed by." No offense of course, just doesn't add anything to the bug report
Comment 16 Timur 2015-10-06 12:09:06 UTC
*** Bug 88694 has been marked as a duplicate of this bug. ***
Comment 17 Timur 2015-10-06 12:15:27 UTC
Similar problem with attachment 112646 [details] from Bug 88694.

@Xisco: thank you for bibisecting, please add all, I copy here from Matthew's: 
The behaviour changed as of the below commit.
commit c5ed52b1cd6f22787c94bec035ceecf9e1da3271
Author: Luboš Luňák <l.lunak@collabora.com>
Date:   Mon Jul 21 10:56:52 2014 +0200

    ww8import create a pagedesc if continuous section changes margins (bnc#875383)
    
    This is similar to what writerfilter does. MSWord can have one page with several different margins, which are saved using continuous sections, which causes all kinds of trouble, because either we treat them as Writer sections, which means we lose some of the data, or we treat them as Writer page styles, which causes spurious page breaks if in the wrong place. Either option has its problems, but here it seems slightly better to go for keeping the data and hoping the page break will be in a place where a break will be anyway.
    Change-Id: I8f52aa820750da6788ea04180a15ac334f6bf87b

@Joel: Lubos doesn't seem to respond to his regressions, does wait patiently apply here, or someone else should be added to CC?
I'm aware I push this, but when bug has multiple duplicates, and it's bisected regression, I guess it's justified.
Comment 18 Timur 2015-10-06 14:26:28 UTC
CC'd bug 87764: same version, same commit.
Comment 19 Robinson Tryon (qubit) 2015-12-14 00:49:28 UTC Comment hidden (obsolete)
Comment 20 Timur 2016-04-07 10:39:03 UTC
Similar problems with DOC attachments c1 and c3 from Bug 49104.
Comment 21 Justin L 2016-09-08 10:58:19 UTC
Marking as WontFix.

As indicated in comment #17, Word acts totally differently than Writer when dealing with sections, and so it simply will never be able to handle every case. I agree with Luboš that margin changes ought to result in a new page style (and thus a page break).

This is something that COULD easily be fixed by the document author if cross-compatibility is required.  Just remove unused header/footer definitions, and keep the page size/layout/margins the same between the various sections.
Comment 22 Justin L 2018-07-26 13:05:54 UTC
*** Bug 118951 has been marked as a duplicate of this bug. ***
Comment 23 Timur 2018-10-04 09:11:07 UTC
*** Bug 100673 has been marked as a duplicate of this bug. ***