Bug Hunting Session
Bug 80508 - PDF: exporting document to pdf crashes LibO [Warning: Difficult to repro]
Summary: PDF: exporting document to pdf crashes LibO [Warning: Difficult to repro]
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: haveBacktrace, regression
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2014-06-25 03:05 UTC by Yousuf Philips (jay) (retired)
Modified: 2017-10-22 01:24 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
crash backtrace from 4.2.5 (32.44 KB, text/plain)
2014-06-25 03:05 UTC, Yousuf Philips (jay) (retired)
Details
Crash backtrace from 4.3.2 - scroll (46.78 KB, text/plain)
2014-10-20 18:01 UTC, Timur
Details
crash backtrace from master_dbg~2014-11-14_00.26.35_LibreOfficeDev_4.4.0.0.alpha2 (4.41 KB, text/plain)
2014-11-21 22:06 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-06-25 03:05:00 UTC
Created attachment 101714 [details]
crash backtrace from 4.2.5

When testing bug 80503, i attempted to pdf export < http://www.cgedd.fr/prix-immobilier-friggit.doc > in 4.2.5 and 4.3.0 on Linux Mint and it crashes. This doesnt happen in 4.0.6 or 4.1.6.
Comment 1 tommy27 2014-06-25 05:00:48 UTC
I can export that doc to pdf using 4.2.0.4 and 4.3.0.1.0+ * 
export is very slow (few minutes) but doesn't crash

I change platform to Linux since it's has not been confirmed on Windows ans MacOS

* Build ID: 52613b9b632721ebb5167a4d9529c242a0b907da
TinderBox: Win-x86@42, Branch:libreoffice-4-3, Time: 2014-06-23_07:41:56
Comment 2 Yousuf Philips (jay) (retired) 2014-06-25 05:54:40 UTC
Confirmed this doesnt happen in Windows.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-25 06:11:24 UTC
It didnt crash on Ubuntu 14.04. Tested clearing my user profile on Linux Mint, but crash still happened.
Comment 4 Yousuf Philips (jay) (retired) 2014-06-25 06:16:37 UTC
jmadero suggested i CC bjoern about this as it will likely effect ubuntu 12.04 users. backtrace is included. :)
Comment 5 Kevin Suo 2014-06-25 07:38:19 UTC
Tested in windows XP SP3, LibreOffice freezes for 5 minutes and then finally exported a pdf file.
With the option "PDF/1A" selected, the exported pdf file is 13,883KB.
And the first image is showing black backround in the pdf.
Comment 6 Kevin Suo 2014-06-25 07:38:57 UTC
(In reply to comment #5)
Version: 4.3.0.1.
Comment 7 Robinson Tryon (qubit) 2014-07-27 04:01:05 UTC
(In reply to comment #3)
> It didnt crash on Ubuntu 14.04. Tested clearing my user profile on Linux
> Mint, but crash still happened.

TESTING on Ubuntu 12.04.4 + LO 4.3.0.3
PDF export does not crash; it takes under 4 minutes

HOWEVER: Trying to scroll-down in the document to see pages beyond page 1 freezes up LibreOffice for an extended period of time.

I'll had this over to Immanuel, who has Linux Mint installed.
Comment 8 immanuelg 2014-07-27 04:14:11 UTC
(In reply to comment #7)
> (In reply to comment #3)
> > It didnt crash on Ubuntu 14.04. Tested clearing my user profile on Linux
> > Mint, but crash still happened.
> 
> TESTING on Ubuntu 12.04.4 + LO 4.3.0.3
> PDF export does not crash; it takes under 4 minutes
> 

TESTING on LinuxMint 17 + LO 4.3.0.4
PDF export does not crash; it takes under 4 minutes

> HOWEVER: Trying to scroll-down in the document to see pages beyond page 1
> freezes up LibreOffice for an extended period of time.
> 

did not crash when scrolling in LO Writer, was sluggish
Comment 9 Yousuf Philips (jay) (retired) 2014-07-27 15:38:22 UTC
Returning this to unconfirmed as i had already confirmed it doesnt effect Ubuntu 14.04 (Linux Mint 17 equivalent). It would be great if someone familiar with backtraces could look into the backtrace to see what is happening.
Comment 10 Robinson Tryon (qubit) 2014-07-27 15:57:16 UTC
(In reply to comment #9)
> Returning this to unconfirmed as i had already confirmed it doesnt effect
> Ubuntu 14.04 (Linux Mint 17 equivalent).

What system is demonstrating this problem? Can you reproduce it?

AFAIK here are the testing results so far:
- Linux Mint (v??) -> Crash
- Linux __ -> Pass
- Windows __ -> Pass
- Ubuntu 14.04 -> Pass
- WinXP -> Pass
- Ubuntu 12.04 -> Pass
- Linux Mint -> Pass  (No repro of initial crash)

With this set of repro steps, we just haven't been able to find this bug.

> It would be great if someone
> familiar with backtraces could look into the backtrace to see what is
> happening.

Can you only reproduce the problem on the single system? It would be great to get confirmation that it's not just something specific to a machine.
Comment 11 Yousuf Philips (jay) (retired) 2014-07-27 17:07:54 UTC
(In reply to comment #10)
> What system is demonstrating this problem? Can you reproduce it?

Linux Mint 13, which can be equivalent to Ubuntu 12.04.

> Can you only reproduce the problem on the single system? It would be great
> to get confirmation that it's not just something specific to a machine.

As i only have linux mint 13 installed on one machine (my desktop), i have only been able to confirm it on one. As no one else is able to confirm it, the backtrace should be able to explain what the problem is.

Retested just now and 4.3.1 and 4.4.0 crashes for me:

Version: 4.3.1.0.0+
Build ID: b2e0120140db580b30ae78914b5f5d80ca9b1f6c
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-07-16_20:36:42

Version: 4.4.0.0.alpha0+
Build ID: b9dca968c6fd0ab5ca140c65b0e54d153cd34986
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-07-19_00:10:17
Comment 12 penttila 2014-08-05 12:34:26 UTC
exporting http://www.cgedd.fr/prix-immobilier-friggit.doc to .pdf works fine on LinuxMint 17 Cinnamon with LO 4.2.4.2. It doesn't crash.
Comment 13 Timur 2014-10-20 18:01:56 UTC
Created attachment 108127 [details]
Crash backtrace from 4.3.2 - scroll

Opening friggit.doc in LO 4.3.2 and scrolling down to the end and back up results in crash. Tested in Windows 7 x64.
While .doc has 7 pages, I get 8 in LO 4.3.2, because picture from the first page goes to the second.
Export in LO 4.2.6 and 4.3.2 works, if done without scrolling/crashing, but PDF is incomplete, there are items missing (legend, caption).
I think that title should be updated, in order to contain "WMF, EMF" because that's what I see in .doc file.
Comment 14 Timur 2014-11-19 17:03:50 UTC
There are multiple problems with this file:
1. crash on PDF export, original report in bug 80508, confirmed by in Linux but not always reproducible
2. accidental crash on scrolling down (with mouse on vertical scroll) to the end and up - tested in Windows 7 x64 with LO 4.3.2 but cannot be reproduced now with 4.3.4
3. 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both in Windows and Linux, reported as Bug 86468
4. PDF export incomplete, there are items missing in WMF or EMF (legend, caption) - not reported yet or duplicate
5. WMF images in DOC file not rendered correctly in Linux - Bug 80503
Comment 15 tommy27 2014-11-19 17:12:37 UTC
why don't we split this bug in multiple reports about the residual issues with current LibO 4.3.x and 4.4.x branches?
Comment 16 Robinson Tryon (qubit) 2014-11-21 20:33:08 UTC
(In reply to tommy27 from comment #15)
> why don't we split this bug in multiple reports about the residual issues
> with current LibO 4.3.x and 4.4.x branches?

It sounds like we have decent bug coverage right now:

(In reply to Timur from comment #14)
> There are multiple problems with this file:
> 1. crash on PDF export, original report in bug 80508, confirmed by in Linux
> but not always reproducible
> ..
> 3. 8 pages in document instead of 7 on open, reproducible from 4.3.1.1 both
> in Windows and Linux, reported as Bug 86468
> ...
> 5. WMF images in DOC file not rendered correctly in Linux - Bug 80503

Okay, those are all covered by bug reports.

> 2. accidental crash on scrolling down (with mouse on vertical scroll) to the
> end and up - tested in Windows 7 x64 with LO 4.3.2 but cannot be reproduced
> now with 4.3.4

That sounds like a WORKSFORME.

> 4. PDF export incomplete, there are items missing in WMF or EMF (legend,
> caption) - not reported yet or duplicate

Unless there's an obvious dupe, let's file bug(s) for those.
Comment 17 Norbert X 2014-11-21 20:40:20 UTC
Can't reproduce bug on 
1. Version: 4.3.3.2
Build ID: 430m0(Build:2)
2. Version: 4.4.0.0.beta1
Build ID: 9af3d21234aa89dac653c0bd76648188cdeb683e
Locale: en_US
Comment 18 Yousuf Philips (jay) (retired) 2014-11-21 22:06:40 UTC
Created attachment 109819 [details]
crash backtrace from master_dbg~2014-11-14_00.26.35_LibreOfficeDev_4.4.0.0.alpha2
Comment 19 Yousuf Philips (jay) (retired) 2014-11-21 22:08:43 UTC
Here is the console output.

warn:sfx.control:15246:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:legacy.osl:15246:1:sfx2/source/sidebar/ResourceManager.cxx:444: context name not recognized
warn:sfx.control:15246:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:legacy.tools:15246:1:vcl/inc/svdata.hxx:387: object deleted while in use !
warn:vcl.control:15246:1:vcl/source/control/button.cxx:2248: No new-style group set on radiobutton <> using old-style digging around
warn:sfx.control:15246:1:sfx2/source/control/dispatch.cxx:1354: Childwindow slot missing: 10365
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:914: SfxBindings::Register while status-updating
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1254: CreateSet_Impl with dirty MessageServer
warn:legacy.tools:15246:1:sfx2/source/control/bindings.cxx:1544: Reschedule in StateChanged => buff
warn:legacy.tools:15246:27:linguistic/source/gciterator.cxx:165: lcl_SkipWhiteSpaces: illegal arguments
warn:legacy.tools:15246:27:linguistic/source/gciterator.cxx:165: lcl_SkipWhiteSpaces: illegal arguments
warn:legacy.tools:15246:27:linguistic/source/gciterator.cxx:165: lcl_SkipWhiteSpaces: illegal arguments
warn:legacy.tools:15246:27:linguistic/source/gciterator.cxx:165: lcl_SkipWhiteSpaces: illegal arguments
warn:legacy.osl:15246:1:sw/source/core/layout/calcmove.cxx:1926: Only a warning for task 108824:/n<SwCntntFrm::_WouldFit(..) - follow not valid!
warn:legacy.osl:15246:1:sw/source/core/layout/calcmove.cxx:1926: Only a warning for task 108824:/n<SwCntntFrm::_WouldFit(..) - follow not valid!
Comment 20 Timur 2014-11-27 16:01:29 UTC
(In reply to Robinson Tryon (qubit) from comment #16)
> > 4. PDF export incomplete, there are items missing in WMF or EMF (legend,
> > caption) - not reported yet or duplicate
> 
> Unless there's an obvious dupe, let's file bug(s) for those.

I'm suspecting to Bug 80389 so I noted it: https://bugs.freedesktop.org/show_bug.cgi?id=80389#c6
Comment 21 Rostislav 'R.Yu.' Okulov 2014-12-19 08:32:53 UTC
Cant reproduce with bibisect-43all latest and oldest under Kubuntu 14.10
Comment 22 Yousuf Philips (jay) (retired) 2014-12-20 07:58:41 UTC
Returning back to UNCONFIRMED as NEEDINFO is used when not enough information is supplied by the reporter.
Comment 23 Robinson Tryon (qubit) 2014-12-27 05:58:42 UTC
(In reply to Jay Philips from comment #22)
> Returning back to UNCONFIRMED as NEEDINFO is used when not enough
> information is supplied by the reporter.

Whatever we decide to do with this bug, I don't want this bug to distract new QA folks. It's only been reproduced under Mint 13, so I suggest that we either
1) Try hard to get someone to repro it
2) Change the summary to 'Dig for answers to crash', and assign to Jay so we can focus on that work

I'll go see if #mint exists on freenode.
Comment 24 Yousuf Philips (jay) (retired) 2014-12-27 10:22:53 UTC
As stated in comment 9, what is needed is not someone else to confirm it but a dev to look at the backtrace and see what is wrong. I have had similar bug reports that no one other than me can reproduce because they dont have the exact same packages on their system (bug 85006).
Comment 25 Robinson Tryon (qubit) 2014-12-27 13:51:32 UTC
(In reply to Jay Philips from comment #24)
> As stated in comment 9, what is needed is not someone else to confirm it

The status 'UNCONFIRMED' is for bugs that are waiting to be confirmed. If we're not actively seeking confirmation of this bug report, then this doesn't seem like the right status...

>  but a dev to look at the backtrace and see what is wrong.

Devs are free to do what they want, but without independent confirmation, I think they're much less likely to spend their time here.
Comment 26 Yousuf Philips (jay) (retired) 2014-12-27 16:35:06 UTC
(In reply to Robinson Tryon (qubit) from comment #25)
> The status 'UNCONFIRMED' is for bugs that are waiting to be confirmed. If
> we're not actively seeking confirmation of this bug report, then this
> doesn't seem like the right status...

Yes there likely should be another status for such a bug, but it seems we have a whiteboard keyword for it (needAdvice). :D

> Devs are free to do what they want, but without independent confirmation, I
> think they're much less likely to spend their time here.

I believe that providing a backtrace is as good as a confirmation, because we do have bug reports of user environments that no QA user has and could confirm and we have always asked them to send in backtraces and we then ask a dev to look at it.
Comment 27 Björn Michaelsen 2014-12-30 14:11:40 UTC
This bug seems to happen only on specific operating systems (see comment 10) does not happen with TDF builds. In addition, the stacktrace suggests there is likely something going wrong with memory management in libcairo. Assuming the cause of this crash (and the reproduction problems) to be a bug in the version of libcairo shipped on Mint, closing this as NOTOURBUG for now (aka needs to be fixed by shipping a fixed version of cairo on mint).

Please reopen only if there is evidence of this being a bug in code maintained by the LibreOffice project.
Comment 28 Yousuf Philips (jay) (retired) 2014-12-30 23:31:31 UTC
(In reply to Björn Michaelsen from comment #27)
> This bug seems to happen only on specific operating systems (see comment 10)
> does not happen with TDF builds.

I was using TDF builds. :D But thanks for looking at the backtrace.
Comment 29 Robinson Tryon (qubit) 2015-12-17 08:24:25 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest, needAdvice)
[NinjaEdit]