Download it now!
Bug 118951 - Fileopen DOC: additional empty page after page break
Summary: Fileopen DOC: additional empty page after page break
Status: RESOLVED DUPLICATE of bug 86468
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.1.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2018-07-26 12:25 UTC by Timur
Modified: 2020-03-22 21:04 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Example DOC with 4 pages (48.00 KB, application/vnd.ms-word)
2018-07-26 12:25 UTC, Timur
Details
2nd example DOC with 1 page (43.50 KB, application/vnd.ms-word)
2018-07-26 12:41 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Timur 2018-07-26 12:25:34 UTC
Created attachment 143783 [details]
Example DOC with 4 pages

Attached is DOC from bug 93977 (with faux TOC that's not relevant here).
It's 4 pages in MSO and was also 4 pages in LO up to 4.3.0.3. 
Then in 4.3.1 it miraculously got an empty page after page 2 so it's 5 pages now up to 6.2+.  

No issue now with same document saved in MSO as DOCX but problem was similar with 4.3. I see it fixed in 5.3.0. 

It would be nice to both find a regression, if it's a regression, and where it was fixed for DOCX. I wouldn't surprised if JL did that, he had many fixes. 
Anyway, we should always test both DOC and DOCX in cases like these.
Comment 1 Timur 2018-07-26 12:41:39 UTC
Created attachment 143784 [details]
2nd example DOC with 1 page

Not sure if the same issue but here is 2nd example DOC with 1 page that I created in MSO from attachment 64325 [details] from regression bug 52208 that was fixed for DOCX but not for DOC.
Comment 2 Telesto 2018-07-26 12:51:15 UTC
Maybe bug 116872 (or more in general meta bug 118920)
Comment 3 Justin L 2018-07-26 12:53:49 UTC
bibisect-44max pinpoints the 5 pages starting with commit c5ed52b1cd6f22787c94bec035ceecf9e1da3271
    Author: Lubo\u0161 Lu\u0148ák
    CommitDate: Mon Jul 21 11:02:04 2014 +0200
ww8import create a pagedesc if continuous section changes margins (bnc#875383)
    
This is similar to what writerfilter does. MSWord can have one page with several
different margins, which are saved using continuous sections, which causes all
kinds of trouble, because either we treat them as Writer sections, which means
we lose some of the data, or we treat them as Writer page styles, which causes
spurious page breaks if in the wrong place. Either option has its problems, but
here it seems slightly better to go for keeping the data and hoping the page
break will be in a place where a break will be anyway.
Comment 4 Justin L 2018-07-26 13:05:54 UTC

*** This bug has been marked as a duplicate of bug 86468 ***
Comment 5 Justin L 2018-07-26 13:13:56 UTC
In this case (of continuous breaks) it might be good to have one format do it one way, and the other format do it another way.  At least one of the two ways should work for whoever wants to share with non-ODT users.

This is an area where LO works completely differently from MS, so it is impossible to match (unless Writer is re-written).
Comment 6 Justin L 2018-07-26 13:36:40 UTC
confirmed that the .docx fix was from bug 64372. Doc and Docx/RTF are very different code in terms of importing, so rarely will lessons learned in one transfer over to the other. (Exporting shares a lot of code though.)
Comment 7 Timur 2020-03-22 21:04:31 UTC
attachment 143783 [details] is 4 pages from LO 6.4 - OK
attachment 143784 [details] is still 2 pages - NOK