Bug 116872 - 6-page DOCX shows 10 pages in Writer
Summary: 6-page DOCX shows 10 pages in Writer
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 113326 117538 (view as bug list)
Depends on:
Blocks: VCL-Scheduler DOCX-Opening Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2018-04-08 00:59 UTC by Aron Budea
Modified: 2018-09-03 17:48 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (172.34 KB, image/png)
2018-04-08 08:24 UTC, Xavier Van Wijmeersch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Aron Budea 2018-04-08 00:59:54 UTC
Open attachment 141181 [details] (bug 116854).

=> Document is 10 pages long instead of 6 (last few are empty).

Observed with LO 6.0.3.2 & 6.0.0.3 / Windows 7.
Shows 6 pages with LO 5.4.0.3.
=> regression

The regression was introduced in two steps.

1. Document opened showing 10 pages, but scrolling down caused repagination, and it ended up correctly as a 6-page document.

Bibisecting with bibisect-win32-6.0 pointed to the following commit. Adding Cc: to  Jan-Marek Glogowski, please take a look sometimes.

author		Jan-Marek Glogowski <glogow@fbihome.de>	2017-01-25 15:53:15 +0100
committer	Jan-Marek Glogowski <glogow@fbihome.de>	2017-07-13 12:10:23 +0200

"Round-robin invoked tasks"

https://cgit.freedesktop.org/libreoffice/core/commit/?id=917be98e3f277960635ac66bcea510c2454c80d6


2. Document opens showing 10 pages, and stays that way.

This one didn't go smoothly, first pointed to a commit from 2017-09-05, then one from 2017-11-02, but it just seems the behavior isn't stable at this point.
Comment 1 Aron Budea 2018-04-08 01:02:06 UTC
I left the bibisectRequest keyword for the 2nd point, maybe it can be bibisected in Linux or something (if the bug occurs there at all).
Comment 2 Xavier Van Wijmeersch 2018-04-08 08:24:50 UTC
Created attachment 141205 [details]
screenshot

When opening the attachment the pages jump from 10 to 6 pages, so i have 6 pages but on the first page something is weird, see screenshot.

Version: 6.0.4.0.0+
Build ID: 49c0d98cb2bec7d171f9847b1335874c05042187
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group

Version: 6.1.0.0.alpha0+
Build ID: d39a8e791618a40328c0f90bece3cc246dcf57f7
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2018-04-06_00:09:14
Locale: nl-BE (en_US.UTF-8); Calc: group
Comment 3 Eyal Rozenberg 2018-04-08 08:44:38 UTC
1. Note reporter's separate bug regarding the layout of the first page: bug 116854.
2. Reporter, please post the relevant document as an attachment here as well. 
3. Confirming with LO 6.0.3.2 on GNU/Linux Mint 18.3) - I first see 10 pages, of them 4 are empty, but on repagination it's 6.

It might still be a dupe of something though, I haven't checked.
Comment 4 Justin L 2018-07-25 18:48:47 UTC
*** Bug 117538 has been marked as a duplicate of this bug. ***
Comment 5 Justin L 2018-07-25 19:13:17 UTC
(In reply to Aron Budea from comment #1)
> I left the bibisectRequest keyword for the 2nd point, maybe it can be
> bibisected in Linux or something (if the bug occurs there at all).

Used Ubuntu 18.04 and bibisect-linux-6.0 which clearly bibisected to author	Jan-Marek Glogowski 2017-07-20 10:27:19 +0200
commit d7a2fd3e8262b8897ad06f01f25f46330e050e0c
tdf#109123 Change SwDocIdle base class to Idle
Comment 6 BogdanB 2018-08-28 18:16:19 UTC
bibisect on 6.0 on linux

a3b10f1ac4201a60e922a6c234c5bf6d3252337d is the first bad commit
commit a3b10f1ac4201a60e922a6c234c5bf6d3252337d
Author: Jenkins Build User <tdf@pollux.tdf>
Date:   Thu Jul 20 15:06:58 2017 +0200

    source sha:d7a2fd3e8262b8897ad06f01f25f46330e050e0c
    
    source sha:d7a2fd3e8262b8897ad06f01f25f46330e050e0c

:040000 040000 b2638089e454bb48035d628d1b5bb65fc80da6c1 0edd1ab48f7919ffd256e00e23a022015f39df0e M	instdir
Comment 7 Timur 2018-08-29 08:22:13 UTC
Other examples:  attachment 59581 [details] from bug 48378 and  attachment 142009 [details] from Bug 117538.
Comment 8 Jan-Marek Glogowski 2018-08-29 08:37:50 UTC
(In reply to Justin L from comment #5)
> (In reply to Aron Budea from comment #1)
> > I left the bibisectRequest keyword for the 2nd point, maybe it can be
> > bibisected in Linux or something (if the bug occurs there at all).
> 
> Used Ubuntu 18.04 and bibisect-linux-6.0 which clearly bibisected to author
> Jan-Marek Glogowski 2017-07-20 10:27:19 +0200
> commit d7a2fd3e8262b8897ad06f01f25f46330e050e0c
> tdf#109123 Change SwDocIdle base class to Idle

Can you retest with latest master. Some of the "Additional-Blank-Pages" bugs are probably also fixed by the patches to bug 119458.
Comment 9 BogdanB 2018-08-29 08:55:48 UTC
Tested with
Version: 6.2.0.0.alpha0+
Build ID: 22f2d8c41aa0a0a4cfa215c07ec06ae38cde7da8
CPU threads: 4; OS: Windows 10.0; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-29_04:32:58
Locale: ro-RO (ro_RO); Calc: threaded

It is loading 10 pages but quickly it is making 6 pages.
I supose it is ok now.
Comment 10 Timur 2018-08-30 13:33:09 UTC
All 3 files are fine now. 
Tested with libo-master~2018-08-29_04.32.58_LibreOfficeDev_6.2.0.0.alpha0_Win_x86
I guess it's fixed then since we know the commit.
I's rather not call this one a duplicate of "Spell checker".
Comment 11 Timur 2018-08-30 13:35:55 UTC
Since those started in 6.0 and fix is so far in 6.1, question remains for 6.0.7 backport.
Comment 12 Timur 2018-08-30 14:12:50 UTC
*** Bug 113326 has been marked as a duplicate of this bug. ***
Comment 13 Xisco Faulí 2018-09-03 17:48:53 UTC
(In reply to Timur from comment #10)
> All 3 files are fine now. 
> Tested with
> libo-master~2018-08-29_04.32.58_LibreOfficeDev_6.2.0.0.alpha0_Win_x86
> I guess it's fixed then since we know the commit.
> I's rather not call this one a duplicate of "Spell checker".

Setting to VERIFIED!