Bug 116479 - Blank pages added randomly throughout and at the end of 388-pages .odt with 327 footnotes
Summary: Blank pages added randomly throughout and at the end of 388-pages .odt with 3...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.2.1 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2018-03-18 20:48 UTC by mango wodzak
Modified: 2018-08-30 14:06 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
this book should be just 388 pages.. suddenly it got extra space added.. (517.50 KB, application/vnd.oasis.opendocument.text)
2018-03-18 20:51 UTC, mango wodzak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mango wodzak 2018-03-18 20:48:42 UTC
Description:
I have several documents I'm working on with writer, I am frequently getting random blank pages added throughout them, sometimes halfway through a paragraph on a page, the paragraph is continued on the next page..

Steps to Reproduce:
difficult to say exactl when and how this occurs.. seems to be when my documents start getting bigger and perhaps connected with my extensive usage of frames throughout..

Actual Results:  
i keep getting my document messed up with pages no longer matching the table of contents

Expected Results:
i expect the blank pages to not be inserted..


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
i intend to attach a .odt file as an example.. 


User-Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0
Comment 1 mango wodzak 2018-03-18 20:51:12 UTC
Created attachment 140698 [details]
this book should be just 388 pages.. suddenly it got extra space added..

This bug seems to be always present when using frames..
Comment 2 Julien Nabet 2018-03-19 09:00:50 UTC
Just wonder if it could be related with tdf#100477 put in see also.
Comment 3 Telesto 2018-03-24 08:10:04 UTC
STR
1. Open the attached file
2. Move the first frame on pag. 13 a little
3. Save the file
4. File - Reload. -> Extra page added
Comment 4 Telesto 2018-03-24 08:41:32 UTC
Hmm. is quite confusing.

Version: 5.4.0.3 -> 389 pages all with text. Probably because of a different layout. Is starts with wrong frame on page. 267

Version: 6.1.0.0.alpha0+
* regular loading: opening file and with 389 pages with 1 empty last page
* Keep scroll down to the bottom while the footnotes are still loading -> 388 pages
Comment 5 mango wodzak 2018-03-24 21:02:07 UTC
I think this illustrates several bugs present.. If you try moving any frame up the page by clicking on it, and then using the up cursor, when it reaches the top paragraph the frame jumps to the previous page, and frequently this causes blank space to be inserted..

if you try and move the frame back down again, onto the page it came from using the arrow keys, it won't go back, just stays in the footer of the page.. very frustrating behaviour..
Comment 6 Xisco Faulí 2018-03-26 20:45:41 UTC
I'm worndering if the empty pages are because of page breaks... Moving a frame moves everything after the frame until the end. If there's a page break in between, it might cause an empty page, which is the correct behaviour...
Comment 7 mango wodzak 2018-03-26 21:00:04 UTC
Xisco, the blank pages are added in places where there are no page breaks.. this is clearly a bug and not normal behaviour..
Comment 8 Xisco Faulí 2018-03-26 21:02:46 UTC
Ok, it would be nice to have a simplify document where the problem can be easily reproduced...
Comment 9 mango wodzak 2018-03-26 21:16:23 UTC
I'd love to be able to upload a simplified document that illustrates the bug, but alas I've not yet seen it happen on any smaller less complex docs.. :(
Comment 10 Telesto 2018-05-11 19:32:42 UTC
Adding bug 117538 to see also.
Comment 11 Telesto 2018-07-05 09:12:11 UTC
This is likely a dupe of bug 100477. See bug 100477 comment 14 (which explains the difference between 5.4 and 6.0) and comment 23
Comment 12 Timur 2018-08-30 14:06:13 UTC
I tried this one with libo-master~2018-08-29_04.32.58_LibreOfficeDev_6.2.0.0.alpha0_Win_x86 and I'd say it's WFM. Guess improved with Bug 119458 as Bug 116872. In that case it's 6.2+ and 6.1 so far. 

Bug is not clear enough to test but:
- it's 388 pages
- there's no blank page at the end
- moving frame as in Commnet 13 and saving still keeps 388 pages

What I notice is slow buildup of footnotes. File is 375 on fileopen and then footnotes appear to 388 pages. 

I'll close. I ask reporter to test master from https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/. You can uninstall it later.