Bug 119458 - Spell checker doesn't start automatically on file open. Needs user interaction
Summary: Spell checker doesn't start automatically on file open. Needs user interaction
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.2.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0 target:6.1.1 target:6.0.7
Keywords:
Depends on:
Blocks: Spell-Checking
  Show dependency treegraph
 
Reported: 2018-08-23 16:28 UTC by Telesto
Modified: 2018-10-03 13:49 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file (13.91 KB, application/vnd.oasis.opendocument.text)
2018-08-23 16:28 UTC, Telesto
Details
page settings (41.68 KB, image/png)
2018-08-31 09:58 UTC, Karsten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Telesto 2018-08-23 16:28:07 UTC
Description:
Spell checker doesn't start automatically. Needs user interaction 

Steps to Reproduce:
1. Open Writer with English dictionary installed
2. Open the attached file
3. No spell checking
4. Press backspace somewhere -> Spell checking starts

Actual Results:
No spell check underlining


Expected Results:
Spellcheck


Reproducible: Always


User Profile Reset: No



Additional Info:
Found in
Version: 6.2.0.0.alpha0+
Build ID: 414ef6cb187dd3bbcc917dbedf3c0c1cc8668f60
CPU threads: 4; OS: Windows 6.3; UI render: GL; 
TinderBox: Win-x86@42, Branch:master, Time: 2018-08-20_22:43:18
Locale: nl-NL (nl_NL); Calc: CL

but not in
0f34e96a5ce68a3039f65cd0f896b33f2d20af5f
Comment 1 Telesto 2018-08-23 16:28:21 UTC
Created attachment 144399 [details]
Example file
Comment 2 Commit Notification 2018-08-24 08:19:33 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ce68889678bca3b51c258452f7bfdd21982e4a0d

tdf#119458 always start the SwDocIdle

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 3 Dieter Praas 2018-08-24 10:39:29 UTC
(In reply to Commit Notification from comment #2)
> Jan-Marek Glogowski committed a patch related to this issue.

Status is still UNCONFIRMED. I think it should be changed.
Comment 4 Telesto 2018-08-24 10:42:29 UTC
Setting to NEW for now (or should it be assigned).
Anyway; thanks for the quick fix :-)
Comment 5 Dieter Praas 2018-08-24 13:33:51 UTC
cc: Jan-Marek Glogowski
Comment 6 Jan-Marek Glogowski 2018-08-25 01:46:14 UTC
The committed fix actually re-introduces bug 116370 :-(

Didn't realize and just tested independently.

Both bugs should be finally fixed with: https://gerrit.libreoffice.org/#/c/59586/

This turned out to be more tricky then expected, so we need to re-test both after the merge or with a cherry-pick, on all platforms.
Comment 7 Telesto 2018-08-25 07:31:53 UTC
(In reply to Jan-Marek Glogowski from comment #6)
> The committed fix actually re-introduces bug 116370 :-(
> 
> Didn't realize and just tested independently.

Out of curiosity; what made you test for bug 116370 again? Eine Eingebung? Or a procedural check?
Comment 8 Jan-Marek Glogowski 2018-08-25 10:10:03 UTC
(In reply to Telesto from comment #7)
> (In reply to Jan-Marek Glogowski from comment #6)
> > The committed fix actually re-introduces bug 116370 :-(
> > 
> > Didn't realize and just tested independently.
> 
> Out of curiosity; what made you test for bug 116370 again? Eine Eingebung?
> Or a procedural check?

No. If it had been, I wouldn't have pushed the broken fix ;-)

The whole SwDoc idle formatting has always been fragile, because the idle document state is very distributed. This results in either no jobs run or busy loops, like the one in the printing problem. This is just a constant problem, if you touch code related to the Scheduler / system event loop integration.

I'll recheck, if I can change Windows to behave like the other backends, which just run timers via the main loop and not via an extra thread. Windows has SetTimer for this, but for whatever reason, this function has a minimum timeout > 0, which results in other problems. Abstracting the platform behaviour to be consistent in this regard is the main problem.

And I always check some source to see, if a LO uses a whole CPU core. With todays HW you often doesn't realise this, as everything still runs smooth. Since the original Scheduler work started for 5.0 we had a lot of bugs, where Idles starved lower priority events, which also resulted in busy loops. Just see my current painting fix for the floating, dockable toolbars.
Comment 9 Telesto 2018-08-26 10:24:00 UTC
I did notice that timer are a delicate matter. And changes with the potential for nasty side-effect. So deep respect for touching the timer code; especially with the fallout potential and the clean-up work afterwards.

Btw, a small sidenote. Seeing Noels comments at https://gerrit.libreoffice.org/#/c/59586/
This bug report started with some trouble with the spellchecker on MacOS. No spell checking in some cases (when pasting content into a new document). I switched to Windows to check (where I found this bug)

However, MacOS pre-dates the changes here. The spell checker stopped working out of the blue for new documents (similar to this report).  And will be functioning again a while later (with in the same session, if I remember correctly).

Did happen once or twice. I didn't observe it again. It might be that change are likelier plenty of documents open (16 or something like that; relative small document; don't have that at the moment) 

And not sure if there is some relation with MacOS sleep or the fact that I'm running LibreOffice for multiple days.. 

So pure speculation. might be no correlation..
 
Version: 6.2.0.0.alpha0+
Build ID: c958f52b813d34baa9b5236bb34a08a04e6b0aba
CPU threads: 4; OS: Mac OS X 10.12.6; UI render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-08-10_05:06:44
Locale: nl-NL (nl_NL.UTF-8); Calc: threaded
Comment 10 Commit Notification 2018-08-27 18:31:25 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=107f0e6dba57a5b27366a35a5cdb184079546df0

tdf#119458 fix sw background Idle state handling

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2018-08-28 11:14:23 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=771544544ee13ec98961f93b5313a7d2e29429cd

tdf#119458 fix sw background Idle unblocking

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2018-08-29 08:10:57 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3bd8316718fdfed454c01a9c4ae6af6beb34437d

tdf#119458 just wakeup Scheduler on active Idle

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2018-08-29 14:46:39 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=20e46a6ca5b62f7177f799eae9e0f26e659fd03b&h=libreoffice-6-1

tdf#119458 reorganize sw background Idle handling

It will be available in 6.1.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Karsten 2018-08-31 09:58:46 UTC Comment hidden (off-topic)
Comment 15 Karsten 2018-08-31 10:00:53 UTC Comment hidden (off-topic)
Comment 16 Timur 2018-09-04 10:07:07 UTC
Jan-Marek, is the work over? If so, can you mark se Fixed?
Since there are also other bugs in See Also fixed with this, please comment on backport to 6.0.
Comment 17 Xisco Faulí 2018-09-04 11:23:30 UTC
(In reply to Timur from comment #16)
> Jan-Marek, is the work over? If so, can you mark se Fixed?
> Since there are also other bugs in See Also fixed with this, please comment
> on backport to 6.0.

jmux> x1sc0: tdf#116370 is a 6.0 bug. The patch results in tdf#119458. So for 6.0 we need both patches. I'm waiting for https://gerrit.libreoffice.org/#/c/59769/, so I can backport both.
Comment 18 Xisco Faulí 2018-09-10 15:37:59 UTC
Verified in

Version: 6.2.0.0.alpha0+
Build ID: 433fce6571d4b9121374047324a7d2d2722ac3e4
CPU threads: 16; OS: Windows 6.3; UI render: default; 
Locale: en-GB (en_GB); Calc: threaded

@Jan-Marek Glogowski, Should it be closed as RESOLVED FIXED ?
Comment 19 Commit Notification 2018-09-10 15:41:02 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-1-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3abec366a3fdb8657d69e24b69b4338121f80b22&h=libreoffice-6-1-1

tdf#119458 reorganize sw background Idle handling

It will be available in 6.1.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 20 Xisco Faulí 2018-09-10 15:43:28 UTC
Setting to VERIFIED. @Jan-Marek Glogowski, Thanks for fixing this!

> jmux> x1sc0: tdf#116370 is a 6.0 bug. The patch results in tdf#119458. So
> for 6.0 we need both patches. I'm waiting for
> https://gerrit.libreoffice.org/#/c/59769/, so I can backport both.

Do no forget to backport it to 6.0 when you have a moment...
Comment 21 Commit Notification 2018-10-03 13:49:17 UTC
Jan-Marek Glogowski committed a patch related to this issue.
It has been pushed to "libreoffice-6-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36556f2f2c30c10f34d5495a7f7cc735b9b9417a&h=libreoffice-6-0

tdf#119458 reorganize sw background Idle handling

It will be available in 6.0.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.