Bug 119584 - Blank pages are inserted when opening a writer document on another PC
Summary: Blank pages are inserted when opening a writer document on another PC
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
6.0.6.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-08-29 12:29 UTC by Karsten
Modified: 2018-09-18 10:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
print settings (199.45 KB, application/zip)
2018-08-30 08:18 UTC, Karsten
Details
print border (41.68 KB, image/png)
2018-08-31 10:01 UTC, Karsten
Details
test document (19.42 KB, application/vnd.oasis.opendocument.text)
2018-09-01 10:32 UTC, Karsten
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Karsten 2018-08-29 12:29:04 UTC
Description:
When i want to print an document on an other PC with other local printers i often find a new empty pages in it.

The empty page is somewhere in the document and of course this is fatal when you are numbering the pages automatically.

Version: 6.0.6.2
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 4; BS: Linux 3.16; UI-Render: Standard; VCL: kde4; 
Gebietsschema: de-DE (de_DE.UTF-8); Calc: CL

Steps to Reproduce:
Just take an multipage document, let's say about 6 pages and more.
Open this document on another PC.



Actual Results:
Often you will find a new blank page in the document.

Expected Results:
Documents should be the same on every PC.


Reproducible: Sometimes


User Profile Reset: No



Additional Info:
Comment 1 Oliver Brinzing 2018-08-29 16:45:51 UTC
can you provide an example file?

can you please check:

Menu "Tools / Options / LibreOffice Writer / Compatibility
[?] Use printer metrics for document formating

Menu "Tools / Options / LibreOffice Writer / Print
[?] Print automatically inserted blank pages 

Menu "Tools / Options / Load/Save / General"
[?] Load printer setting with the document
Comment 2 Karsten 2018-08-30 08:18:22 UTC
Created attachment 144547 [details]
print settings

The long documents contain sensitive data - sorry.

But here are screenshots from the settings.
I disabled now to take over the printer settings when loading.

Sorry to say this, but for what are all this settings good for?
It is comfortable when it is possible to make so much settings,
but it is a problem when the functionality is not clear for the user.
Specially when the behaviour is changing in a new version and there
are new settings that must be changed to get the old behaviour.
Comment 3 Timur 2018-08-30 18:35:39 UTC
I understand this is about FILEOPEN not PRINT. 
Looks like just reolsved Bug 119458.
Karsten please test master 6.2+ from https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ and report back.
Comment 5 Karsten 2018-08-31 09:04:48 UTC
The blank pages can be seen when you open the document.
Then they are printed of course too.

The printing space/edge is minimum 20mm around the page, so there should be no difference what printer or settings are used.
Comment 6 Karsten 2018-08-31 10:01:57 UTC
Created attachment 144573 [details]
print border

Just now i have this case in a similar situation.

An letter with only one page.
When i open the document on the PC i have written, i see only 1 page.
When i open it on another PC it has 2 pages!
The last line is on the second page.

Why?

Everything is the same: Debian 8, same Libreoffice, same Font is installed, only a different printer is installed, but the margins are so big that it can't make a difference.

There should be no difference when i open a document on another PC!
I MUST use PDF to get identical results on different PC's.
Comment 7 Timur 2018-08-31 16:03:51 UTC
Karsten, this bug makes no sense and cannot be confirmed without test document. Please anonymize and attach.
You didn't confirm you tested with master as I asked.
Comment 8 Karsten 2018-09-01 10:32:03 UTC
Created attachment 144592 [details]
test document

I have taken an document with one page where the last line is broken to a second page on the second PC.
But after editing and saving the effect is lost.

The original document is strictly private and can't be send or published - sorry.
Comment 9 Karsten 2018-09-01 10:35:08 UTC
I can only say this effect is present since the last updates i have made since the original distribution version.
Of course the conditions are complicated, but this bugs are really annoying!
From my point of view the complexity and problems are going out of control ...


It seems that there is a reason why Debian is still using Version 5.2.7 of Libreoffice!
I think it is a good idea to go back to this version too.

So i am sorry to say this, but Libreoffice is going the same way like Microsoft - from version to version are inserted new features that are not needed, instead of fixing bugs that the office can be really used in a stable way.

I don't want to be ungrateful - i am a really convinced user of Libreoffice and i want to thank you for your great work!
But now i see that by upgrading from version to version the problems increase instead of being reduced and even bug reports don't help to resolve them.
Comment 10 Timur 2018-09-03 11:49:14 UTC
What you wrote is very important and I agree with you. 

But for this bug we must have reproducible steps and example document. 
Attachment 144592 [details] is not that? Why did you attach? If yes, please write repro steps. 
Please attach anonymized document.
https://wiki.documentfoundation.org/QA/BugReport
https://wiki.documentfoundation.org/QA/Bugzilla/Sanitizing_Files_Before_Submission

And for the third time, did you test with master? Which exact version?
Comment 11 Karsten 2018-09-05 11:19:30 UTC
I understand that you must reproduce an bug to analyze it.
But it seems that there must be some conditions to be fullfilled that it occur.

Before some minutes i was trying to send a fax direct from LO 6.0.6.2
It has only one page and the last line was an picture of the signature.
For 2 times the document switches to 2 pages immediately it was transmitted to the printer driver, which is https://www.tabos.org/
Reopening the document shows again one page.

Now i opened it with the LO-writer of the distribution Version: 4.3.3.2
Build-ID: 430m0(Build:2) and i could fax it without any problems as one page!

I think i will take the distribution version for all my work in the future, because i don't need the additional features and stress.
Comment 12 Karsten 2018-09-05 11:30:52 UTC
Crazy - and now i printed another document with 2 pages in the old LO on an laser printer.
The document is printed correct as 2 pages, but after the print it has 3 pages with the last line on the 3rd page.
Reopening the document shows again 2 pages.

This is really scary - i cannot imagine how such things can happen ...

Can you tell me how i can analyze the bug here on my PC?
Comment 13 Timur 2018-09-18 10:19:34 UTC
In this bug you are not responging to questions and we are not approaching to defining an issue so I'll close.

Karsten, I see you submitted 15 bugs. They are mostly duplicates or invalid, WFM. 
That means you are not following rules when submitting bugs to first search. 
https://wiki.documentfoundation.org/QA/BugReport