Download it now!
Bug 113326 - FILEOPEN: Blank pages appear in the end of RTF document
Summary: FILEOPEN: Blank pages appear in the end of RTF document
Status: RESOLVED DUPLICATE of bug 116872
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
6.0.0.0.alpha0+
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, filter:rtf, regression
Depends on:
Blocks: RTF Additional-Blank-Pages
  Show dependency treegraph
 
Reported: 2017-10-21 15:36 UTC by Alexandr
Modified: 2018-08-30 14:12 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexandr 2017-10-21 15:36:53 UTC
Description:
Attachment 93065 [details] from bug 74233 is a 4 page rtf document. In LibreOffice 6.0.0.0.alpha1 on Debian Jessie it has 6 pages: 2 blank pages appear at the end.
The bug is not presented in LibreOffice 5.2.7.


Steps to Reproduce:
1. Open attachment 93065 [details]

Actual Results:  
The document has 6 pages

Expected Results:
The document has 4 pages


Reproducible: Always

User Profile Reset: No

Additional Info:


User-Agent: Mozilla/5.0 (X11; Linux i686; rv:38.0) Gecko/20100101 Firefox/38.0
Comment 1 Alexandr 2017-10-21 18:24:18 UTC
Similar problem is with attachment 86496 [details] from bug 69782
Comment 2 Jacques Guilleron 2017-10-22 10:27:48 UTC
Hi Alexandr,
I reproduce (6 pages) with
LO  6.0.0.0.alpha0+ Build ID: e0aed1459513be5e08fab9de06848df5dc9d0b5f
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-09-20_06:45:25
Locale: fr-FR (fr_FR); Calc: CL
and with
LO 5.4.0.0.alpha0+ Build ID: 3a36cf434fb4a967c9ea767cb7ac5f4da0502a0d
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-04-28_06:33:58
Locale: fr-FR (fr_FR); Calc: CL
but not with
LO 5.4.0.0.alpha0+ Build ID: a5c947579253a7f4e784004e18929af5ab22fa28
CPU threads: 2; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@39, Branch:master, Time: 2017-03-02_01:57:01
Locale: fr-FR (fr_FR); Calc: CL
Comment 3 raal 2017-10-23 15:06:32 UTC
This seems to have begun at the below commit.
Adding Cc: to Jan-Marek Glogowski ; Could you possibly take a look at this one?
Thanks

9ffe1fcf76b3a3dbe517c589a19fd5a47b403d17 is the first bad commit
commit 9ffe1fcf76b3a3dbe517c589a19fd5a47b403d17
Author: Norbert Thiebaud <nthiebaud@gmail.com>
Date:   Sat Jul 29 12:46:47 2017 -0700

    source sha:7a1c1699a61a77d0228417da9922812c9b893b9d

author    Jan-Marek Glogowski <glogow@fbihome.de>    2016-09-14 13:33:54 (GMT)
committer    Jan-Marek Glogowski <glogow@fbihome.de>    2017-07-13 10:10:23 (GMT)
commit    7a1c1699a61a77d0228417da9922812c9b893b9d (patch)
tree    9ded7bd1fe28e211df290090a8b49690696fcc63
parent    503eba23c9a199583eddee9e169a4fddbecf416f (diff)
Run Idle tasks immediatly
Comment 4 Jan-Marek Glogowski 2018-07-03 14:08:21 UTC
This is quite probably the same bug as 100477 and even 116872.

And 100477 is actually old. It was confirmed against 5.0.0.2 and never fixed, just look in the history.

Now what is actually happening in all cases: there are "really empty" pages at the end of the document due to whatever reason.

If you open this document with 5.4, you can see, that the initial document has also 6 pages, but these get reduced to 4, because the last two pages are "really empty". At least I can see this, when opening the document in a remote LO via SSH X forwarding. Reducing also happens for 116872, if you scroll with the cursor.

Really empty means you can't click into them via cursor,
Comment 5 Timur 2018-08-30 14:12:50 UTC
I tried this one with libo-master~2018-08-29_04.32.58_LibreOfficeDev_6.2.0.0.alpha0_Win_x86 and it's 4 pages. 
Seems solved with Bug 119458 as Bug 116872 so I'll mark duplicate. 
Reporter may test master from https://dev-builds.libreoffice.org/daily/master/Win-x86@42/current/ or wait 6.1.2. You can uninstall it later.

*** This bug has been marked as a duplicate of bug 116872 ***