Bug 49257 - FILESAVE as .pptx: Text boxes lose FORMATTING
Summary: FILESAVE as .pptx: Text boxes lose FORMATTING
Status: RESOLVED DUPLICATE of bug 71961
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.3.3 release
Hardware: Other Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-28 11:42 UTC by Wagner
Modified: 2014-02-15 19:26 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Slide with a text box after saving the presentation as PPTX and file reopened (23.52 KB, image/jpeg)
2012-04-28 11:42 UTC, Wagner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Wagner 2012-04-28 11:42:35 UTC
Created attachment 60744 [details]
Slide with a text box after saving the presentation as PPTX and file reopened

Problem description:
I had a presentation with some text boxes formatted to fit the slide and configured with the language 'English'. When a saved the presentation as PPTX (MSOffice 2010) format and reopened the file, all text boxes lost their formats (language was a different one and texts were no longer limited to the size of the text boxes).

Steps to reproduce:
1. Create a presentation file in the ODP format.
2. Add some text boxes and put some big texts inside it, in a way to have the text in multiple lines.
3. Save the presentation.
4. Save the presentation with the PPTX (MSOffice 2010) format.
5. Close LibreOffice and open the PPTX file.
6. Texts will not be limited to the text boxes anymore.

Current behavior:
Text boxes lose their formats when the presentation is saved as PPTX (MSOffice).

Expected behavior:
Text boxes should keep their formats when the presentation is saved as PPTX (MSOffice).

Platform (if different from the browser): 
Windows 7 64-Bits
              
Browser:
IE 9
Comment 1 Rainer Bielefeld Retired 2012-04-28 23:41:10 UTC
[Reproducible] with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: c0a4c46]" (tinderbox: Win-x86@6-fast, pull time 2012-04-29 01:16:37).
Character size and wraps are lost after Filesave, problem is also visible with MS PPT Viewer when I open "sample.pptx" from attached test kit.

Same with LibO 3.4.5 and more or less with LibO 3.3.3; .pptx from 3.3.3 only can be opened with LibO (and shows the problem), but can not be opened with MS PPT Viewer (Error message).

Please compare source "sample.odp" and export result "sample.pptx" in test kit.

Thorsten:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 2 Thorsten Behrens (CIB) 2012-05-02 09:55:29 UTC
Muthu, cycles left to quickly look into this one?
Comment 3 Peter Platek 2013-02-25 04:39:15 UTC
Reproduced in Version 4.0.0.3 (Build ID: 53fd80e80f44edd735c18dbc5b6cde811e0a15c)
TinderBox: MacOSX TDF Release, Branch:libreoffice-4-0, Time: 2013-01-31_11:01:36
on Mac OS X 10.6.8
Comment 4 tomi.hasa 2013-12-20 15:23:19 UTC
I have reproduced this in Version: 4.1.3.2 (Build ID: 70feb7d99726f064edab4605a8ab840c50ec57a) using Finnish text. Mac Pro 8-Core (OS X 10.8).
Comment 5 Muthu 2013-12-20 15:30:21 UTC
Can you check this in the latest master (nightly builds), please?

I recently fixed this one.
Comment 6 tommy27 2014-02-15 19:26:29 UTC
I think this is the same issue described here.

Bug 71961 - FILESAVE: text doesn't fit into text boxes after saving as .PPTX

unfortunately no fix seems to have been provided yet since bug is still reproducible in LibO 4.1.4.2 and 4.3.0.0.alpha0+
Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-15_01:01:17

I'm marking this as a DUPLICATE (despite being filed earlier) since Bug 71961 has a very simple and reproducible test case.

*** This bug has been marked as a duplicate of bug 71961 ***