Download it now!
Bug 49279 - VIEWING: All reports fail to open!!!
Summary: VIEWING: All reports fail to open!!!
Status: RESOLVED DUPLICATE of bug 47473
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-04-29 11:56 UTC by Ralph Peters
Modified: 2012-06-06 01:48 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ralph Peters 2012-04-29 11:56:39 UTC
Problem description: 

Steps to reproduce:
1. Make a query
2. Make a report using the query
3. Open report and get "Report Design" not the actual report

Current behavior:
All reports fail including reports made using 3.5.2.2 and all older versions of LO and OO.  These reports all worked fine in 3.4!!!  The fix suggested in the post:

Legacy Base reports won't open in LibreOffice 3.5
    Subject: Re: [libreoffice-users] Legacy Base reports won't open in LibreOffice 3.5
    From: Tom Davies <tomdavies04@yahoo.co.uk>
    Date: Tue, 17 Apr 2012 15:36:51 +0100 (BST)
    To: users@global.libreoffice.org
...........

doesn't work because "Sort" is in the list. (Read the posting!)

Expected behavior:
Old and new reports should produce a report, not a "Report Design" form. 
What are you guys doing?????? I have been using OO/LO for almost 10 years (remember StarOffice?) so I am not a newbie to this software package.  Every once in a while the "wheels come off"!  Why?


Platform (if different from the browser):   
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Ralph Peters 2012-04-29 12:43:29 UTC
I just moved my database to another computer running LO 3.4.4 and all reports work just fine.  So, reports fail in 3.5.2.2 and work in 3.4.4!
Comment 2 Ralph Peters 2012-04-29 21:28:52 UTC
When I first try to open a report, I sometimes see a window (maybe reporting an error?) "flash" up on the screen for a few milliseconds.
Comment 3 frofa 2012-04-30 01:13:46 UTC
I guess you've seen these Bug Reports....
https://bugs.freedesktop.org/show_bug.cgi?id=47325
and also...
https://bugs.freedesktop.org/show_bug.cgi?id=47473
It seems there are two separate problems.
Comment 4 Ralph Peters 2012-04-30 06:06:11 UTC
On Mon, Apr 30, 2012 at 2:13 AM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=49279
>
> --- Comment #3 from fred <frof07@yahoo.com.au> 2012-04-30 01:13:46 PDT ---
> I guess you've seen these Bug Reports....
> https://bugs.freedesktop.org/show_bug.cgi?id=47325
> and also...
>


This one talks about adding *Sort *to old reports.  My reports have *Sort*.
New and Old reports fail!




> https://bugs.freedesktop.org/show_bug.cgi?id=47473
> It seems there are two separate problems.
>
> I hadn't seen this one.   I tried it and it fixed the problem.  I would
like to suggest that you talk to whoever is in charge and fix this *NOW*!
This is a remarakably stupid bug to allow out into a release.

THANKS FOR YOUR HELP AND QUICK RESPONSE!


--
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 5 Julien Nabet 2012-04-30 11:17:38 UTC
Could you try to retrieve a backtrace by following this link ?
http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
Comment 6 Ralph Peters 2012-05-07 18:31:34 UTC
Hi,

I am just back from a trip...

I noticed that if I *don't *ask for any sorting in the wizard that builds
the report, I get a report that "opens".  Report-sort and it doesn't open!

Would you like a sample database that exhibits this behavior, so you can
investigate it yourself?  I stripped down my database so that I can ship
you a copy.
It has 2 reports, one that sorts and one that doesn't.  The "no-sort"
report opens, the "sort" doesn't.

 The stripped down report is still is almost as big as the original???  ~~
24 MB.

Ralph


On Mon, Apr 30, 2012 at 12:17 PM, <bugzilla-daemon@freedesktop.org> wrote:

> https://bugs.freedesktop.org/show_bug.cgi?id=49279
>
> Julien Nabet <serval2412@yahoo.fr> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|UNCONFIRMED                 |NEEDINFO
>                 CC|                            |serval2412@yahoo.fr
>     Ever Confirmed|0                           |1
>
> --- Comment #5 from Julien Nabet <serval2412@yahoo.fr> 2012-04-30
> 11:17:38 PDT ---
> Could you try to retrieve a backtrace by following this link ?
>
> http://wiki.documentfoundation.org/BugReport#How_to_get_backtrace_.28on_Linux.29
>
> --
> Configure bugmail: https://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 7 frofa 2012-05-08 17:12:24 UTC
I made a summary of what I think is happening with some workarounds - see here:
http://nabble.documentfoundation.org/Workarounds-for-multiple-problems-with-the-legacy-Report-Designer-Wizard-under-LO-3-5-td3964175.html
Comment 8 Lionel Elie Mamane 2012-06-06 01:48:24 UTC
This looks to me like a duplicate of bug 47473, which I fixed yesterday (waiting for review to apply to 3.5 branch).

*** This bug has been marked as a duplicate of bug 47473 ***