Bug Hunting Session
Bug 49324 - Does not recognize VBA macro in JAPANESE of LibreOffice 3.5.2
Summary: Does not recognize VBA macro in JAPANESE of LibreOffice 3.5.2
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords:
: 49938 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-04-30 23:25 UTC by hmoi
Modified: 2012-06-10 17:26 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Created with English MS Excel 2003. LO352 recognized VBA Macro normally. (16.50 KB, application/vnd.ms-excel)
2012-04-30 23:25 UTC, hmoi
Details
Created with Japabese MS Excel 2003. LO352 did NOT recognize VBA Macro. (13.50 KB, application/vnd.ms-excel)
2012-04-30 23:27 UTC, hmoi
Details
logs when I open each of both files (1.49 KB, application/x-compressed)
2012-05-01 03:04 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hmoi 2012-04-30 23:25:58 UTC
Created attachment 60821 [details]
Created with English MS Excel 2003.  LO352 recognized VBA Macro normally.
Comment 1 hmoi 2012-04-30 23:27:08 UTC
Created attachment 60822 [details]
Created with Japabese MS Excel 2003.  LO352 did NOT recognize VBA Macro.
Comment 2 hmoi 2012-04-30 23:55:59 UTC
[LibreOffice 3.5.2.2, Windows XP SP3, Japanese ]

When trying to execute a VBA macro in LibreOffice 3.5.2 with VBA Support Option to 1 
(and VBA options checked in LibreOffice preferences), LO 3.5.2 does NOT recognize the VBA macro file which was made with JAPANESE MS Excel 2003.

LO 3.5.2 does recognize VBA macro file which was made with English MS Excel 2003, normally.

And, LO 3.4.6 does recognize VBA macro file which was made with JAPANESE MS Excel 2003, normally.

Steps to reproduce:
1. Open "Book1_enUS_xls2003.xls" with LO3.5.2
2. Click [Enable Macros] on Security Warning dialog
3. Tool -> Macros -> Organize Macros -> LibreOffice Basic
4. Choose Macro from Book1_enUS_xls2003.xls - VBAProject - Modules - Module1
5. Choose Existing in Module1 : test 
6. Click Edit button 

7. Now you confirm the VBA Macro program.
8. Close "Book1_enUS_xls2003.xls" file.

Next,

9. Open "Book1_jaJP_xls2003.xls" with LO3.5.2
  (LO open this file without any warning dialog)
10. Tool -> Macros -> Organize Macros -> LibreOffice Basic
11. Choose Macro from Book1_jaJP_xls2003.xls - VBAProject - Modules - Module1
12. Nothing in Existing in Module1 box, and Edit button is grayed out.

13. you can not confirm the VBA Macro program.
14. Close "Book1_jaJP_xls2003.xls" file.

If,,,,,
15. Open "Book1_jaJP_xls2003.xls" with LO3.4.6
16. Click [Enable Macros] on Security Warning dialog
17. Tool -> Macros -> Organize Macros -> LibreOffice Basic
18. Choose Macro from Book1_jaJP_xls2003.xls - VBAProject - Modules - Module1
19. Choose Existing in Module1 : Macro1 
20. Click Edit button 
21. Now you confirm the VBA Macro program.

Please investigate this matter.
Thanking you for your help and looking forward to your reply.
Comment 3 Julien Nabet 2012-05-01 03:04:32 UTC
Created attachment 60825 [details]
logs when I open each of both files

On pc Debian x86-64, master updated today, I reproduced the problem.
I attached the logs of both files.
I tried to debug and just noticed that nEncoding has 60 for value.
Comment 4 Not Assigned 2012-05-01 09:53:24 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d04fb45caa46db829d21a7f9b96878655ce0f479

Resolves: fdo#49324 (Does not recognize VBA macro in JAPANESE...)
Comment 5 Not Assigned 2012-05-02 04:19:53 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6ad690ea62829fcbb7d4b270ba02c1aaba02bcde&g=libreoffice-3-5

Resolves: fdo#49324 (Does not recognize VBA macro in JAPANESE...)


It will be available in LibreOffice 3.5.4.
Comment 6 hmoi 2012-05-06 20:07:05 UTC
Thank you for your work on this.
I will try a patch when available.
Comment 7 Makoto Takizawa 2012-05-15 17:16:48 UTC
*** Bug 49938 has been marked as a duplicate of this bug. ***
Comment 8 Julien Nabet 2012-06-10 05:49:26 UTC
(In reply to comment #6)
> Thank you for your work on this.
> I will try a patch when available.
You're welcome. BTW, 3.5.4 version has been published, you can give it a try.
Comment 9 hmoi 2012-06-10 17:26:23 UTC
Hi,

Confirming fixed on 3.5.4.
Closing as resolved fixed.
Thank you again very much!

Hirono