Bug 49421 - CONFIGURATION: Too small select lists in Language Settings > Writing Aids
Summary: CONFIGURATION: Too small select lists in Language Settings > Writing Aids
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: All All
: lowest enhancement
Assignee: Ivan Timofeev (retired)
URL:
Whiteboard: BSA target:3.6.0
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-03 03:11 UTC by xeddvok7bd7464n2
Modified: 2012-05-08 06:57 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot - Ubuntu Precise Pangolin (63.28 KB, image/png)
2012-05-03 03:11 UTC, xeddvok7bd7464n2
Details
Screenshot - Mac OS X Lion (78.05 KB, image/png)
2012-05-03 03:12 UTC, xeddvok7bd7464n2
Details
Fixed listboxes - Ubuntu (55.62 KB, image/png)
2012-05-08 06:57 UTC, Ivan Timofeev (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description xeddvok7bd7464n2 2012-05-03 03:11:09 UTC
Created attachment 60955 [details]
Screenshot - Ubuntu Precise Pangolin

PROBLEM DESCRIPTION

The select lists in Language Settings > Writing Aids are too small, especially the first one (Available language modules).

Using Ubuntu Precise Pangolin, first line (Hunspell SpellChecker) below Available language modules is not selectable with up and down arrow keys, but only with the scroll wheel. Furthermore the scroll bar is too much "compressed" and can't be used (except for the down arrow button).

Using Mac OS Lion, the scroll bar below Available language modules can't be used at all (clicking on it and moving the mouse up and down / moving up and down on the trackpad doesn’t move the scroll bar). Scrolling up with the trackpad always shows OpenOffice.org New Thesaurus. Scrolling down also shows the other lines/options, but the the first line can't be viewed at all. Using the up and down keys, all options but the first line can be viewed.

Possible troubleshooting:

* Options window should be made resizable, or
* Larger select lists


PLATFORM

* Ubuntu 12.04 LTS (Precise Panglin), LibreOffice 3.5.2 -> See downstream bug report: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/991059
* Mac OS X 10.7.3 (Lion), LibreOffice 3.5.3
Comment 1 xeddvok7bd7464n2 2012-05-03 03:12:56 UTC
Created attachment 60956 [details]
Screenshot - Mac OS X Lion
Comment 2 xeddvok7bd7464n2 2012-05-03 08:17:45 UTC
I agree that the importance of this bug isn't very high because it doesn't produce data loss or the like. But I don't think that this is a enhancement request given that one option is not selectable at all and thus it is not possible to en-/disable or edit it.
Comment 3 Jean-Baptiste Faure 2012-05-06 09:31:12 UTC
For me it is a regression from LO 3.4.
Comment 4 Christopher M. Penalver 2012-05-06 09:57:02 UTC
Raphael Frey, here is the problem with trying to correctly triage this bug:

1) Your downstream bug is completely different then this upstream one. In the downstream, you are requesting the ability to resize the window (ENHANCEMENT), and noting you are having a UI bug in Linux.

2) Here you include all that, plus a similar but potentially different UI problem on the Mac platform.

3) All totaled, you have at least 1 bug and an ENHANCEMENT.

Please re-file this bug, one for the ENHANCEMENT, one for the problem on Linux, and one for the problem on Mac. Thank you for your understanding in this.
Comment 5 Jean-Baptiste Faure 2012-05-06 10:18:44 UTC
I propose to ask Ivan Timofeev to have a look, indeed he has fixed several bugs in the layout of various dialogs.

Best regards. JBF
Comment 6 Christopher M. Penalver 2012-05-06 10:27:20 UTC
Jean-Baptiste Faure, please do not extend this report any further due to https://bugs.freedesktop.org/show_bug.cgi?id=49421#c4 .
Comment 7 Not Assigned 2012-05-06 11:24:41 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31182ed08494ed6afa3371aa246b155c6b58e8b3

fdo#49421: the "Available language modules" list is too small and unusable
Comment 8 Ivan Timofeev (retired) 2012-05-06 11:41:07 UTC
I don't know what extent of cleanness we have to demand from bug-reports ...
For me this one is clean enough. :) So - hopefully fixed now.

My commit enlarges the "Available language modules" list so that it now
contains *2* entries and is well scrollable. The Mac OS X scrollbar problem
should disappear, but I can't test on Mac OS X.

And... resizable windows will be a feature of the future LibO versions I think... :)
Comment 9 Ivan Timofeev (retired) 2012-05-06 11:59:15 UTC
(In reply to comment #8)
> My commit enlarges the "Available language modules" list so that it now
> contains *2* entries and is well scrollable.

Oh dear! It was well scrollable when the scaling is set to 130%, normally it is not... Sorry, I need to have a look at this problem as well.

haste, haste - mistakes, mistakes...
Comment 10 Not Assigned 2012-05-07 07:23:37 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b07d7d348a728fc54991320ff7bc882f341478af

fdo#49421: do not divide by zero when scrollbar cannot be moved
Comment 11 xeddvok7bd7464n2 2012-05-07 10:17:49 UTC
(In reply to comment #4)
> Raphael Frey, here is the problem with trying to correctly triage this bug:
> 
> 1) Your downstream bug is completely different then this upstream one. In the
> downstream, you are requesting the ability to resize the window (ENHANCEMENT),
> and noting you are having a UI bug in Linux.
> 
> 2) Here you include all that, plus a similar but potentially different UI
> problem on the Mac platform.
> 
> 3) All totaled, you have at least 1 bug and an ENHANCEMENT.
> 
> Please re-file this bug, one for the ENHANCEMENT, one for the problem on Linux,
> and one for the problem on Mac. Thank you for your understanding in this.

Okay, I see the problem and I'm very sorry for causing this confusion ... Let me just explain the situation briefly: I remarked the problem using LibreOffice in Ubuntu and I thought the problem comes from the options window which is not resizable. (There were similar problems with other programmes in Ubuntu in the past, with options/settings windows which were too small and not resizable). Then I noticed the same problem using LibreOffice on my MacBook. As you might know, settings windows on Mac OS X usually aren't resizable. So I thought the problems on my Ubuntu and Lion system were the same and therefore I reported the bug here (only once).

To sum up, this bug report only concerns the bug itself (i.e.: too small select lists in Language Settings > Writing Aids). I don't know how the bug can be solved (resizable options window could be one possible solution, but I think larger select lists may be the better solution). Therefore this bug report is really a bug report and not an enhancement request. I'll adjust the bug title and description on Launchpad (Ubuntu) if possible, because it is misleading and differs from this bug request.
Comment 12 Not Assigned 2012-05-08 06:51:31 UTC
Ivan Timofeev committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4979a3cfd43b9f79005bf76da9e2dbdffc9e91f5

Revert "fdo#49421: the "Available language modules" list is too small and ...
Comment 13 Ivan Timofeev (retired) 2012-05-08 06:57:06 UTC
Created attachment 61229 [details]
Fixed listboxes - Ubuntu

(In reply to comment #3)
> For me it is a regression from LO 3.4.

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6a64e5bbd43e262d87e291dcc411628efac61fde
makes lisboxes look like in 3.3 I think.