Download it now!
Bug 49499 - : Starting new LibreOffice v3.4.5 crashes when starting during their splash screens.
Summary: : Starting new LibreOffice v3.4.5 crashes when starting during their splash s...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
3.4.5 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 08:39 UTC by Ant
Modified: 2012-08-09 13:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ant 2012-05-04 08:39:50 UTC
Problem description: My newly installed/portable LibreOffice v3.4.5 (portable), v3.4.6 (installed), and v3.5.2 (portable) crashes during their startup splash screen.

Steps to reproduce:
1. Install (if not portable)/Run LibreOffice v3.4 or newer.
2. Run a LibreOffice program like Writer.

Current behavior: During its startup splash screen, it crashes. Soffice.bin process vanish very quickly.

Expected behavior: LibreOffice should start up just fine like in old OpenOffice v3.3.0 and LibreOffice v3.3.4.

Platform (if different from the browser): Old, updated Windows XP Pro. SP3 (IE7).
              
Browser: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.19) Gecko/20110420 SeaMonkey/2.0.14

Notes on What I Tried: I tried uninstalling Java v6 u31, but that did not fix the problem. Installing the latest u32 made no differences. I deleted my local LO and OO's profiles, but still crashed.

It seems like the bug started after LO v3.3.4. Does LO have a logging feature for its startup to debug? LO's mailing list is stumped right now on why I am having problems. Tom Davies suggested I report my issue as a bug even though I am the only one with this problem. :(

Thank you in advance. :)
Comment 1 Julien Nabet 2012-05-05 10:13:17 UTC
Have you got Java installed ? 
Which Java version do you have ? (perhaps several versions ? jdk, jre, ...)

In order to not mix everything, could you uninstall all the LO versions you have and :
- remove profile (I saw that you know how but you can check here http://wiki.documentfoundation.org/UserProfile to be sure)
- clean your Windows registry with a free tool (like ccleaner)
- download 3.5.3 non portable version and give it a try
Comment 2 Ant 2012-05-05 10:55:03 UTC
For Java, OO and LO profiles, and other versions including portable ones: Please read my "Notes on What I Tried:" section earlier. And yes, I uninstalled other OO, LO, and Java to narrow down the issues. :)

I did not try CCleaner, so I ran its portable v3.18.1707 to clear out registry and HDD left overs. It found a few OpenOffice references. I reran portable LO v3.4.5 and v3.5.2 and they still crashed. v3.3.4 portable did not crash again. Something changed between v3.3.4 and v3.4.5 to make LO crash for this old Windows XP Pro. SP3 machine. :(
Comment 3 Julien Nabet 2012-05-06 03:30:50 UTC
Ok for Java (and I suppose you've got only 1 version), I had just missed this piece of information in your comment.

Anyway, could you try non portable LO version ? The goal is to know if the problem is in the core Libreoffice or in the portable only version.
Comment 4 Tom 2012-05-06 04:14:56 UTC
Hi :)
Ant's problems started when he installed the proper 3.5.2.  He then tried
1.  Renaming the user profile
2.  Uninstaling and reinstalling the 3.5.2
3.  Uninstalling java 6_30 
4.  Reinstalling java 6_31
5.  Various portable versions
6.  Tried the 3.4.6 full version.  

The thread bounced around the users list quite a bit and Ant has helped other people sort out other problems.  LibreOffice never usually crashes this way so the Users List were at a bit of a loss how to deal with it.  Java or renaming the user-profile usually seems to fix crashes when they happen.  

I didn't know how to describe doing a full scan to check the integrity of the hard-drive and i didn't know how to describe doing an strace or whatever so i just pointed Ant to the wiki-page on how to do a bug-report
http://wiki.documentfoundation.org/BugReport

Another person on the Users List seems to be having the same problem but she is using Debian so it's probably a different reason.

Regards from
Tom :)
Comment 5 Tom 2012-05-06 04:17:57 UTC
Hi :)
Sorry for the double-post but i got the versions of java muddled up and didn't know how to edit comments here.  Ant says he started with java 6_31 and uninstalled, retried LO (still crashed) and then installed java 6_32
Apols and regards from
Tom :)
Comment 6 Ant 2012-05-06 04:57:38 UTC
Yes, Tom's correct. I tried portable, installer, and various versions. :(

Installed OO v3.3.3 and portable LO v3.3.4 had no problems though, so something changed after v3.3.4 to crash on my very old Windows XP Pro. SP3 machine.
Comment 7 Julien Nabet 2012-05-06 13:15:40 UTC
It takes some time but you can try to follow this excellent video to have more information :
http://www.youtube.com/watch?v=fppBTs215yc
Comment 8 Ant 2012-05-06 13:28:21 UTC
(In reply to comment #7)
> It takes some time but you can try to follow this excellent video to have more
> information :
> http://www.youtube.com/watch?v=fppBTs215yc

It looks like I need the source codes, and I am not a programmer/developer/coder. Can someone please kindly send me a soffice debug file with this pause part, so I can attach this process in WinDbg? I tried to do it fast right after running LO, but LO starts and crashes way too fast on this quad core system. Heh! :(
Comment 9 Michael Meeks 2012-05-09 02:17:06 UTC
Hi Ant; you don't need the source code :-) but you do need a debug build - which you can download from:

http://dev-builds.libreoffice.org/win32-debug/libreoffice-3-5/

Check that that still crashes on start, and follow the windbg steps to get a trace :-)

Sorry - we can't reproduce it, which makes fixing it really hard - it'd be wonderful to get a trace, that should pinpoint -exactly- what goes wrong and make the fixing of it really easy.

Failing that - getting some rdesktop access to your system for a developer (perhaps you'd see that as more risky :-) would help.

Thanks for persisting !
Comment 10 Ant 2012-05-09 06:00:33 UTC
Thanks Michael! Is there a portable version (reproducable) so I don't have to keep installing and uninstalling over and over again?
Comment 11 Michael Meeks 2012-05-09 06:09:13 UTC
> Thanks Michael! Is there a portable version (reproducable) so I don't
> have to keep installing and uninstalling over and over again?

Sadly we don't have that except for released versions I think - sorry !
Comment 12 Ant 2012-05-09 06:47:19 UTC
(In reply to comment #9)
> Hi Ant; you don't need the source code :-) but you do need a debug build -
> which you can download from:
> 
> http://dev-builds.libreoffice.org/win32-debug/libreoffice-3-5/
> 
> Check that that still crashes on start, and follow the windbg steps to get a
> trace :-)

OK, I installed LibO-Dev_3.5.3rc1_Win_x86_install_en-US.msi and it still crashes. LO still starts too fast for me to attach to its process. I still need a way to pause before the crash which is I am asking for. :(

Or does LO dump debug files somewhere I missed? Sorry if I am not familiar with this since I am not a coder/programmer/developer. I just step by step help! :)
Comment 13 Michael Meeks 2012-05-09 07:53:37 UTC
So - I guess it needs to be run under the debugger - ie. launch the app inside windbg - I think they call this "Open Excutable": https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg has some more hints.

Failing that enabling Dr Watson - or similar crash-logging infrastructure, should give us a dump with a backtrace (if we're lucky)

http://www.webkit.org/quality/crashlogs.html has some details on turning that on for Windows - hopefully it will dump the data to a magic file as/when it crashes.

I'm just sorry we can't do this bit for you !
Comment 14 Ant 2012-05-09 08:04:30 UTC
I hope I did it right. I opened LO's soffice.exe in WinDbg, and clicked "Go" to run it (saw LO's splash screen and the crash -- also I deleted LO's profile before doing this):


Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: C:\winstuff\LOdev3.5.3rc1\program\soffice.exe
Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
ModLoad: 00400000 00411000   soffice.exe
ModLoad: 7c900000 7c9b2000   ntdll.dll
ModLoad: 7c800000 7c8f6000   C:\WINDOWS\system32\kernel32.dll
ModLoad: 77dd0000 77e6b000   C:\WINDOWS\system32\ADVAPI32.dll
ModLoad: 77e70000 77f03000   C:\WINDOWS\system32\RPCRT4.dll
ModLoad: 77fe0000 77ff1000   C:\WINDOWS\system32\Secur32.dll
ModLoad: 7c9c0000 7d1d7000   C:\WINDOWS\system32\SHELL32.dll
ModLoad: 77f10000 77f59000   C:\WINDOWS\system32\GDI32.dll
ModLoad: 7e410000 7e4a1000   C:\WINDOWS\system32\USER32.dll
ModLoad: 77c10000 77c68000   C:\WINDOWS\system32\msvcrt.dll
ModLoad: 77f60000 77fd6000   C:\WINDOWS\system32\SHLWAPI.dll
ModLoad: 78520000 785c3000   C:\WINDOWS\WinSxS\x86_Microsoft.VC90.CRT_1fc8b3b9a1e18e3b_9.0.30729.6161_x-ww_31a54e43\MSVCR90.dll
(a5c.770): Break instruction exception - code 80000003 (first chance)
eax=00261eb4 ebx=7ffda000 ecx=00000005 edx=00000020 esi=00261f48 edi=00261eb4
eip=7c90120e esp=0013fb20 ebp=0013fc94 iopl=0         nv up ei pl nz na po nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000202
ntdll!DbgBreakPoint:
7c90120e cc              int     3
0:000> g
ModLoad: 5cb70000 5cb96000   C:\WINDOWS\system32\ShimEng.dll
ModLoad: 76390000 763ad000   C:\WINDOWS\system32\IMM32.DLL
ModLoad: 10000000 100b4000   c:\winstuff\outpos~1\wl_hook.dll
ModLoad: 773d0000 774d3000   C:\WINDOWS\WinSxS\x86_Microsoft.Windows.Common-Controls_6595b64144ccf1df_6.0.2600.6028_x-ww_61e65202\comctl32.dll
ModLoad: 5d090000 5d12a000   C:\WINDOWS\system32\comctl32.dll
ModLoad: 77b40000 77b62000   C:\WINDOWS\system32\Apphelp.dll
eax=76390000 ebx=00000000 ecx=7e410000 edx=77c61ae8 esi=7c90de6e edi=00000000
eip=7c90e514 esp=0013fdc4 ebp=0013fec0 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!KiFastSystemCallRet:
7c90e514 c3              ret


Did that help? :D
Comment 15 Michael Meeks 2012-05-09 11:29:08 UTC
Wow - that is interesting; it crashes in the soffice.exe wrapper. If you rename 'soffice.bin' in that directory to 'soffice_bin.exe' and run that - does LibreOffice start nicely for you ?

This looks a bit odd: c:\winstuff\outpos~1\wl_hook.dll

what is that DLL doing getting loaded from there ? looks unusual to me.

It'd be better to get a trace with wingdb and open that application and run it - hopefully we'd get symbols (if you setup the symbol server as-per the video).

It looks like something very odd, related to very early startup - never seen one like this before :-) What is c:\winstuff ? and who is hooking your early executable startup DLLs ?

I'm suspicious of either your virus checker, or your virus ;-)
Comment 16 Ant 2012-05-09 11:37:00 UTC
(In reply to comment #15)
> Wow - that is interesting; it crashes in the soffice.exe wrapper. If you rename
> 'soffice.bin' in that directory to 'soffice_bin.exe' and run that - does
> LibreOffice start nicely for you ?

I will do that later tonight or the next day since I am not at that computer at the moment. :)

 
> This looks a bit odd: c:\winstuff\outpos~1\wl_hook.dll
> 
> what is that DLL doing getting loaded from there ? looks unusual to me.

c:\winstuff\outpos~1\ is my old Outpost Firewall 2009 v6.5.1 (2725.381.0687) software. Weird how that is conflicting with the newer LO versions, and not the older versions. You can download a copy from http://www.filehippo.com/download_outpost_firewall/tech/5559/ ...

 
> It'd be better to get a trace with wingdb and open that application and run it
> - hopefully we'd get symbols (if you setup the symbol server as-per the video).

Hmm, I recall the video showed symbol server with MS but did it show one for LO? I don't remember seeing it. 

 
> It looks like something very odd, related to very early startup - never seen
> one like this before :-) What is c:\winstuff ? and who is hooking your early
> executable startup DLLs ?

Winstuff is where I install my Windows stuff/softwares. I don't keep in their default folders/directories. :)

 
> I'm suspicious of either your virus checker, or your virus ;-)

Nah, I already scanned for malwares. Clean except stupid privcacy cookies. :P
Comment 17 Ant 2012-05-09 20:48:13 UTC
(In reply to comment #15)

> Wow - that is interesting; it crashes in the soffice.exe wrapper. If you rename
> 'soffice.bin' in that directory to 'soffice_bin.exe' and run that - does
> LibreOffice start nicely for you ?

"This application has failed to start because sal3.dll was not found. Re-installing the application may fix the problem."

C:\winstuff\LOdev3.5.3rc1\URE\bin\ has sal3.dll. Weird? I tried copying sal3.dll with soffice_bin.exe's folder/directory, and LO still failed to start. :(

For kicks, I ran old Dependency Walker v2.2.6000 said these files also could not be found as well beside SAL3.DLL:
CPPU3.DLL
CPPUHELPER3MSC.DLL
JVMFWK3.DLL
SALHELPER3MSC.DLL
UWINAPI.DLL

What's the frak? :( Google says SAL3.dll is an Sun file. IIRC, I did run StarOffice and OpenOffice in the past before Oracle took over.
Comment 18 Ant 2012-05-09 22:08:27 UTC
FYI with that renamed file to skip the wrapper part. WinDbg complained about missing sal3.dll file. Here's the debug on soffice_bin.exe: 
Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.

CommandLine: C:\winstuff\LOdev3.5.3rc1\program\soffice_bin.exe
Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols
Executable search path is: 
ModLoad: 00400000 004aa000   soffice_bin.exe
ModLoad: 7c900000 7c9b2000   ntdll.dll
ModLoad: 7c800000 7c8f6000   C:\WINDOWS\system32\kernel32.dll
(b60.dcc): Unknown exception - code c0000135 (first chance)
(b60.dcc): Unknown exception - code c0000135 (!!! second chance !!!)
eax=00e3fc54 ebx=00000000 ecx=00e3fca8 edx=7c90e514 esi=7ffda000 edi=c0000135
eip=7c9673be esp=00e3fc54 ebp=00e3fca4 iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00000246
ntdll!RtlRaiseStatus+0x26:
7c9673be c9              leave
0:000> g
WARNING: Continuing a non-continuable exception
(b60.dcc): Access violation - code c0000005 (first chance)
First chance exceptions are reported before any exception handling.
This exception may be expected and handled.
eax=00e3ffb4 ebx=ffff0000 ecx=00e3ffb0 edx=7c90e514 esi=018ff76c edi=bb40e64e
eip=00003822 esp=00e3ff98 ebp=00e3ffbc iopl=0         nv up ei pl zr na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=003b  gs=0000             efl=00010246
00003822 ??              ???


I also tried portable LO v3.3.4, but got no complaints about SAL3.dll even though DependencyWalker showed it (and others) missing for soffice.bin as an EXE.
Comment 19 Ant 2012-05-17 05:24:08 UTC
So, any other ideas? :)
Comment 20 Michael Meeks 2012-05-22 01:39:34 UTC
Andras - some strange (library path?) problem running DLLs in the ure/lib directory from program/ on windows.

Ant - copying those libraries into program/ is unlikely to work - they try to locate all sorts of files in relation to where the actual binary library is, and there is a ton of complexity there.

It seems though that it is possible to run soffice.exe and get it to crash if it's run by itself; I wonder if it's possible to get the debugger to attach at the point of failure ? Thoughts Andras ?
Comment 21 Ant 2012-05-30 21:39:00 UTC
I see v3.5.4 was released. I assume it has no fixes for startups?
Comment 22 Michael Meeks 2012-06-01 04:03:24 UTC
Hi Ant:

> I see v3.5.4 was released. I assume it has no fixes for startups?

Without a stack-trace with debugsymbols and/or a repeatable problem we are totally stymied here.

Fridrich ... is it truly the case that there is no Windows build that actually works with debug symbols ? I couldn't make Jesus' builds work, and the tinderbox builds appear not to have the symbols packaged / distributed with them.
Comment 23 Ant 2012-06-01 06:09:21 UTC
(In reply to comment #22)
> Hi Ant:
> 
> > I see v3.5.4 was released. I assume it has no fixes for startups?
> 
> Without a stack-trace with debugsymbols and/or a repeatable problem we are
> totally stymied here.
> 
> Fridrich ... is it truly the case that there is no Windows build that actually
> works with debug symbols ? I couldn't make Jesus' builds work, and the
> tinderbox builds appear not to have the symbols packaged / distributed with
> them.


Yeah, I need those LO symbols. :(  It IS a repeatable problem. I can reproducable easily and quickly.
Comment 24 Michael Meeks 2012-06-01 06:59:45 UTC
Fridrich is working to get you a build with some symbols that can be tested - sorry for the pain here.
Comment 25 Ant 2012-06-04 21:34:01 UTC
(In reply to comment #24)
> Fridrich is working to get you a build with some symbols that can be tested -
> sorry for the pain here.

Thanks. :)
Comment 26 Ant 2012-08-09 05:15:24 UTC
So, I installed v3.6 today and can finally launch it fully. Although Help About crashes. LOL! I wonder what changed.
Comment 27 Michael Meeks 2012-08-09 09:08:26 UTC
> Although Help About crashes. 

please can you file a bug for this with a trace, and mark it as a dependent of bug#44446

thanks ! :-)
Comment 28 Ant 2012-08-09 13:30:20 UTC
(In reply to comment #27)
> > Although Help About crashes. 
> 
> please can you file a bug for this with a trace, and mark it as a dependent of
> bug#44446
> 
> thanks ! :-)

https://bugs.freedesktop.org/show_bug.cgi?id=53296 ... FYI, Apache OpenOffice v3.4.0 does not have the startup crash and help about problems.
Comment 29 Julien Nabet 2012-08-09 13:46:35 UTC
So put to RESOLVED/WORKSFORME since splashscreen is ok for you and you created the fdo#53296 (1 problem/1 bug).
Comment 30 Ant 2012-08-09 13:58:09 UTC
(In reply to comment #29)
> So put to RESOLVED/WORKSFORME since splashscreen is ok for you and you created
> the fdo#53296 (1 problem/1 bug).

Ah OK. I see you already did that. Thanks. I am curious what was fixed to make startup work for me.