Bug Hunting Session
Bug 49502 - RTF: opening RTF file failed
Summary: RTF: opening RTF file failed
Status: RESOLVED DUPLICATE of bug 55939
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium normal
Assignee: Miklos Vajna
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-04 11:06 UTC by francis wintzenrieth
Modified: 2013-12-05 15:19 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
RTF file causing the error (795.35 KB, application/rtf)
2012-05-04 11:06 UTC, francis wintzenrieth
Details
LO 3.6 generated .rtf (31.99 KB, application/rtf)
2012-11-13 00:25 UTC, NoOp
Details
LO Ubuntu generated .rtf (31.77 KB, application/rtf)
2012-11-13 00:26 UTC, NoOp
Details
LO 3.5rc3 generated .rtf (31.80 KB, application/rtf)
2012-11-13 00:27 UTC, NoOp
Details
Broken RTF file (6.15 KB, application/rtf)
2012-11-30 17:36 UTC, Michal Nowak
Details
ODT from which was RTF generated (13.04 KB, application/vnd.oasis.opendocument.text)
2012-11-30 17:37 UTC, Michal Nowak
Details
Working RTF file created by LO 4.0.0.0.beta2 (6.16 KB, text/rtf)
2012-12-22 20:40 UTC, Michal Nowak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description francis wintzenrieth 2012-05-04 11:06:26 UTC
Created attachment 61041 [details]
RTF file causing the error

Problem description: 
When trying to open the RTF file attached, content is not displayed and an error message appears : 
general error
general input/output error

the RTF file is generated by a french professional software of thermal calculations in HVAC 

Steps to reproduce:
1. open the attached file in writer

Current behavior: display a message error

Expected behavior: display content of the file

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:12.0) Gecko/20100101 Firefox/12.0
Comment 1 Jean-Baptiste Faure 2012-05-04 12:51:44 UTC
Reproducible with LO 3.5.4rc0+ and master (Version ID : 3e0b229).
No error message if I do Insert sheet from file in Calc
LO 3.3 and LO 3.4 open this file without error message.

Miklos: please have a look. Feel free to reassign if you can't handle this bug.

Best regards. JBF
Comment 2 francis wintzenrieth 2012-10-21 17:30:37 UTC
There is no problem with this file when using Insertion >> File. All the content of this file is perfectly imported (table, format, page break).
Hoping this will help...
Comment 3 NoOp 2012-11-13 00:24:18 UTC
I can replicate with Version 3.6.3.2 (Build ID: 58f22d5) (linux and Windows).

In attempting to troubleshoot this Ubuntu bug:
<https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1077361>
[Saving as RTF messes with page 1]
I downloaded the authors .doc:
<https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/1077361/+attachment/3429482/+files/bug2.doc>
and saved it to an .rft (attached as bug2.rtf) with LO (standard - non-distro/Ubuntu version), closed LO and attempted to reopen. The result is 

general error
general input/output error

Interestingly enough, I can successfully 'Insert|File' into a blank LO Writer document. However, note that the .rtf file inserts a 'Section'; most likely related bug for that is: https://bugs.freedesktop.org/show_bug.cgi?id=45325

I then replicated in a Windows version, and 3.5.7.2 (Windows and linux). If I back 3.5 down to 3.5.0rc3 (attached as bug2GLO35rc3.rtf) I do not encounter the issue.

I then tested with the distro modified (Ubuntu LO 3.5.4-0ubuntu1.1) version and the .rtf saves (with the exception of inserting the section break), and opens correctly (.rtf attached as bug2LOUbuntu.rtf). That .rtf can be compared against 'bug2.rtf' and essai.rtf for troubleshooting purposes.
Comment 4 NoOp 2012-11-13 00:25:54 UTC
Created attachment 69970 [details]
LO 3.6 generated .rtf
Comment 5 NoOp 2012-11-13 00:26:38 UTC
Created attachment 69971 [details]
LO Ubuntu generated .rtf
Comment 6 NoOp 2012-11-13 00:27:26 UTC
Created attachment 69972 [details]
LO 3.5rc3 generated .rtf
Comment 7 Michal Nowak 2012-11-30 17:36:21 UTC
Created attachment 70839 [details]
Broken RTF file

I have also General input/output error with attached RTF file created by LO 3.6.3.2 (3.5.7 is the same). The problem is with the footnote in the ODF file from which is the RTF generated, once is footnote removed RTF opens just fine.
Comment 8 Michal Nowak 2012-11-30 17:37:16 UTC
Created attachment 70840 [details]
ODT from which was RTF generated
Comment 9 Michal Nowak 2012-12-22 20:40:03 UTC
Created attachment 71999 [details]
Working RTF file created by LO 4.0.0.0.beta2

This is fixed for me with:

  Version 4.0.0.0.beta2 (Build ID: 4104d660979c57e1160b5135634f732918460a0)

on Fedora 17 x86_64 (RPM).

Created RTF with 4.0.0.0.beta2 and now I am able to open it with both 3.5.7.2 and 4.0.0.0.beta2. Resulted RTF attached.
Comment 10 Miklos Vajna 2012-12-22 21:07:40 UTC
Michal,

Thanks for the feedback -- so if it was about footnote RTF export in general, I think I know when this got fixed.

*** This bug has been marked as a duplicate of bug 55939 ***