Download it now!
Bug 49522 - scrolling back through datagrid not updating data.
Summary: scrolling back through datagrid not updating data.
Status: RESOLVED DUPLICATE of bug 48345
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-05-05 01:58 UTC by Boudi
Modified: 2012-05-15 09:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
grid screenshot. (52.74 KB, image/png)
2012-05-05 01:58 UTC, Boudi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boudi 2012-05-05 01:58:18 UTC
Created attachment 61072 [details]
grid screenshot.

When scrolling back through a datagrid, the data in the grid is not updated.
(MySQL connected DB.)
Comment 2 Ian~G 2012-05-14 03:42:14 UTC
same here on 3.5.3 ubuntu 12.04

also note this same bug affects OPENOFFICE 3.4 

this is a total blocker for us, since we use direct table editing quite a bit and the openoffice front end is more familiar and friendly for our users than MySQL Admin/Query or Workbench.
Comment 3 Petr Mladek 2012-05-15 05:54:50 UTC
Reporters, could you please attach a test document that would help to reproduce the problem?

As mentioned in the comment #2, it seems to be an older bug. I agree that it is pretty annoying, so I am going to add it to most annoying bugs. On the other hand, it can't block release of the other bug fixes => lowering the severity a bit.
Comment 4 Ian~G 2012-05-15 06:41:20 UTC
"As mentioned in the comment #2, it seems to be an older bug."

I'm a bit confused by this. OpenOffice 3.4 was only released a few days ago.

Just to clarify. You can scroll down through a table and can also scroll left and right, but you cannot scroll back UP the table.

You can kind of get round it a bit by scrolling down to the record you want to look at then refresh the data to get back to the top (ugh!)

Scrolling in earlier versions was always a bit duff. for example horiz scrolling didn't work with a mouse but the trackpad did work. Vertical scrolling worked with a scroll wheel or trackpad but not the scrollbar. I reckon fixing this has thrown up this new problem.

Sorry I can't copy the datafile for you; it contains sensitive data.

Many thanks for your help with this. I hate to be deploying new installations of two year old ubuntu with OpenOffice 3.2
Comment 5 Ian~G 2012-05-15 07:19:56 UTC
found an earlier report of the same thing see 48345

the reporter has attached a simple .odb file which gives the same behaviour on scrolling up through the data.
Comment 6 Lionel Elie Mamane 2012-05-15 09:42:11 UTC

*** This bug has been marked as a duplicate of bug 48345 ***