Download it now!
Bug 49529 - UI feature request: Sensible defaults for page margins
Summary: UI feature request: Sensible defaults for page margins
Status: RESOLVED DUPLICATE of bug 87902
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Page-Margins
  Show dependency treegraph
 
Reported: 2012-05-05 03:19 UTC by Andreas
Modified: 2017-06-16 17:08 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas 2012-05-05 03:19:06 UTC
As per the following ressources, page-margins is a pretty complex and important craft. One of the reasons e.g. LateX looks so nice is it's parge-margins defaults.

Fortunately there exists good 'fallback' defaults (described in the ressources below). Since I always use time on creating page margins for my templates - it would be a strong feature if I could simply choose between a few predefined sensible defaults.

This would also make most libreoffice documents so much nicer than MS word.

Suggestions for defauls:
Van de Graaf
Rasarivo
simple: 2:3
simple: Golden ratio
simple: 1:√2

Ressource:
Wikipage: https://en.wikipedia.org/wiki/Canons_of_page_construction
Article: https://eegg.wordpress.com/2010/01/25/page-margins-in-principle-and-practice/#comment-21
Comment 1 Regina Henschel 2012-05-05 10:35:59 UTC
There do not exist margins which are good per se, but it depends on the purpose of the document and the environment in which it is used. For example, compare writing a single sheet business letter in USA on legal paper format with a technical magazine on DIN A4, or a Japanese chapbook.

Therefore LO has the concept of document templates, so that everyone can make a set of his favorite document style settings. Of cause you are right, that not everyone will know about typography. For those some well styled templates are useful. Perhaps you can generate some? You can use our page http://templates.libreoffice.org/ to provide them. And if they are generally approved, we can discuss to deliver those together with the program.

I will set this issue to new, so that others might read this task and help in generating improved templates.
Comment 2 V Stuart Foote 2017-06-16 14:47:02 UTC
the bug 87902 has more complete discussion

*** This bug has been marked as a duplicate of bug 87902 ***