Bug Hunting Session
Bug 87902 - Default page margins
Summary: Default page margins
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: needsDevEval, topicUI
: 49529 (view as bug list)
Depends on:
Blocks: Page-Margins
  Show dependency treegraph
 
Reported: 2014-12-31 11:34 UTC by Yousuf Philips (jay) (retired)
Modified: 2018-08-21 16:20 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-31 11:34:14 UTC
Presently LO uses .79" (2cm) margins on all 4 sides in its default page style and i wonder if this topic was ever discussed.

Here are the page margins used by other word processors.

MS Word 2003: 1.25" (left and right), 1.00" (top and bottom)
MS Word 2010: 1.00" (all sides)
WordPerfect X7: 1.00" (all sides)
WPS Writer: 1.25" (left and right), 1.00" (top and bottom)
Calligra Words: 1.25" (left and right), 1.00" (top and bottom)
Google Docs: 1.00" (all sides)
Abiword: 1.00" (all sides)
Comment 1 Yousuf Philips (jay) (retired) 2014-12-31 11:56:24 UTC
iWork Pages: 0.79" (all sides)
Comment 2 Cor Nouws 2014-12-31 13:07:21 UTC
(In reply to Jay Philips from comment #0)
> Presently LO uses .79" (2cm) margins on all 4 sides in its default page
> style and i wonder if this topic was ever discussed.

Yes, in the past is was 2.54 cm IIRC. Changed on purpose.
Comment 3 Yousuf Philips (jay) (retired) 2014-12-31 18:24:00 UTC
(In reply to Cor Nouws from comment #2)
> Yes, in the past is was 2.54 cm IIRC. Changed on purpose.

When you say past, i'm assuming you mean OOo time, as its been the same since LO was created.
Comment 4 Yousuf Philips (jay) (retired) 2015-08-19 02:21:32 UTC
Can anyone identify where/why this change was discussed in the OOo days?
Comment 5 Jean-Baptiste Faure 2015-08-19 20:07:35 UTC
(In reply to Yousuf (Jay) Philips from comment #4)
> Can anyone identify where/why this change was discussed in the OOo days?

Use the metric system ?

Best regards. JBF
Comment 6 Maxim Monastirsky 2015-08-19 20:54:39 UTC
(In reply to Cor Nouws from comment #2)
> Yes, in the past is was 2.54 cm IIRC. Changed on purpose.
I tested now with OOo 1.1.5, and it has the same 2cm as default.
Comment 7 Yousuf Philips (jay) (retired) 2016-08-07 15:41:26 UTC
@Heiko, @Stuart, @Regina, @Sophie: Do you guys have an opinion on this issue?
Comment 8 Cor Nouws 2016-08-07 21:13:19 UTC
(In reply to Maxim Monastirsky from comment #6)
> (In reply to Cor Nouws from comment #2)
> > Yes, in the past is was 2.54 cm IIRC. Changed on purpose.
> I tested now with OOo 1.1.5, and it has the same 2cm as default.

So what I remembered was seen in a different word processor :) Apologies!
Comment 9 Regina Henschel 2016-08-07 22:24:19 UTC
Bugs in OOo about changing the defaults were closed with the hint, that users can easily set their own default document template.

You have to consider e.g.
* If you will use a loose-leaf binder, you need a larger left margin.
* If you will use a coil binding, you need a smaller left margin.
* If you will follow any of the typographical rules (https://en.wikipedia.org/wiki/Canons_of_page_construction) you will need different values on all four edges.
* If you will give readers the optimal line width of 40-60 characters, it requires a much larger (right) margin.

I think, this demonstrates, that there does not exist a "correct" margin. So 2cm is a neutral start value.
Comment 10 Heiko Tietze 2016-08-08 07:06:42 UTC
First idea: yes, second: but with caution, third: keep it.

Additional to Regina's comment there is https://en.wikipedia.org/wiki/Margin_(typography), which states "By default, LaTeX uses 1.5 inches margin sizes for 12pt documents, 1.75 inches for 11pt, and 1.875 inches for 10pt". I like the idea of a more or less constant number of letters per line, and since we cannot know how the user formats his or her text we should go with a conservative setting. 

Of course, we could make the left margin smaller even in case of the default page style (not sure how it is defined for left and right pages) but that wouldn't solve the consistency question.

-> WONTFIX
Comment 11 sophie 2016-08-08 08:20:27 UTC
Hi, I agree with Heiko here, and I recall that during the discussion we already had, 2cm was the standard for legal letters in most countries. Sophie
Comment 12 Yousuf Philips (jay) (retired) 2016-08-29 17:40:19 UTC
(In reply to Regina Henschel from comment #9)
> Bugs in OOo about changing the defaults were closed with the hint, that
> users can easily set their own default document template.
> 
> I think, this demonstrates, that there does not exist a "correct" margin. So
> 2cm is a neutral start value.

Yes there definitely isnt a "correct" margin that will suit everyones needs, just like there is no "correct" page size or font size that will suit everyones needs, but we are looking for a good default that is very common so most users dont have to change this default, especially novice users (e.g. benjamin) who wont know how to modify their default template.

https://en.wikipedia.org/wiki/APA_style
http://www.apastyle.org/learn/quick-guide-on-formatting.aspx
APA style is a format for academic documents such as journal articles and books. ... Set uniform margins of at least 1 in. (2.54 cm) on the top, bottom, left, and right of every page.

http://practicaltypography.com/page-margins.html
https://www.reference.com/education/standard-margins-dd752171075eac9d
Most word proces­sors de­fault to page mar­gins of one inch. On stan­dard 8.5"× 11" pa­per, that pro­duces a line length of 6.5 inches. That’s fine for type­writer-style mono­spaced fonts, which use a lot of hor­i­zon­tal space. But for pro­por­tional fonts, one-inch mar­gins are too small. ... At 12 point, left and right page mar­gins of 1.5–2.0 inches will usu­ally give you a com­fort­able line length.

Maybe it would be useful to do a poll to see what margins users use in their documents, and whether their profession dictates these margins.
Comment 13 Heiko Tietze 2016-08-29 20:15:43 UTC
(In reply to Yousuf (Jay) Philips from comment #12)
> Maybe it would be useful to do a poll to see what margins users use in their
> documents, and whether their profession dictates these margins.

Good idea
Comment 14 Cor Nouws 2016-08-29 20:33:00 UTC
(In reply to Heiko Tietze from comment #13)
> (In reply to Yousuf (Jay) Philips from comment #12)
> > Maybe it would be useful to do a poll to see what margins users use in their
> > documents, and whether their profession dictates these margins.
> 
> Good idea

then add some questions that make clear if they use the margins in 'blank' documents or from templates
Comment 15 Yousuf Philips (jay) (retired) 2017-06-16 13:41:15 UTC
For those that didnt already know, we ran a survey about this.

https://design.blog.documentfoundation.org/2017/05/21/please-participate-survey-page-margins/
Comment 16 V Stuart Foote 2017-06-16 14:47:02 UTC
*** Bug 49529 has been marked as a duplicate of this bug. ***
Comment 17 V Stuart Foote 2017-06-16 16:17:33 UTC
From dupe bug 49529, very different issues when setting a single page (e.g. non-bound) electronic document compared to something intended to be edge bound.

Frankly in modern use, most of the moveable type "cannons" [1] are nonsense, but can be implemented with document templates if needed/preferred for bound layouts. 

The "Double-Circle" single-page cannon [2] has merit for preparing new defaults based on locale.

But as most publication styles (i.e. CSL) specify specific page size and corresponding margins for submission--our existing defaults--A4/2cm and Letter/.79in--are acceptable to vast majority of LO users. Others with more specialized needs should be preparing templates.


=-ref-=
[1] https://en.wikipedia.org/wiki/Canons_of_page_construction

[2] https://eegg.wordpress.com/2010/01/25/page-margins-in-principle-and-practice
Comment 18 Timur 2017-06-16 17:08:10 UTC
Since I wasn't in the survey, let me give an opinion. Current margins look OK for general use.
Personally, for the sake of saving space or Mottainai, I use even  smaller margins top and bottom but there's a memo template. Saying because who needs different will create template. 
Related to issue in Bug 33304. 
In this bug, I didn't see there will be change, so I can't see why it's still open. WFM.
Comment 19 Heiko Tietze 2017-09-28 13:34:20 UTC
Results are available at https://design.blog.documentfoundation.org/2017/09/26/default-margins-users-apply-libreoffice-writer/

In a nutshell, most users are happy with 2cm, some change it to smaller margins, the US people prefer inch (1"), and it would be a good solution to have templates for the few standards. Closing this ticket as WFM.