Bug Hunting Session
Bug 49545 - EDITING: CRASH when add custom animation to media (Movie, Sound)
Summary: EDITING: CRASH when add custom animation to media (Movie, Sound)
Status: RESOLVED DUPLICATE of bug 45081
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.5
  Show dependency treegraph
 
Reported: 2012-05-06 04:09 UTC by Rainer Bielefeld Retired
Modified: 2012-05-11 02:51 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (873.33 KB, application/zip)
2012-05-06 04:09 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-06 04:09:12 UTC
Created attachment 61093 [details]
Test Kit

Steps how to reproduce with parallel installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 35ec153]" (tinderbox: Win-x86@6-fast, pull time 2012-05-02 06:53:41):

1. open "samplecrash_a.odp" from attached test kit
2. click top left movie/sound (audio)
3. Tasks Area 'Custom animatoin -> Modify Effect - Add - Misc Effects - Start 
   Media'
   Expected: "Start Media" selected, will be added with <ok>
   Actual: LibO crashes immediately

Same with 3.5.3

No Crash with 3.3.3, 3.4.5, so Regression

Doug that that started with 3.5.3, I will check later
Comment 1 Rainer Bielefeld Retired 2012-05-06 04:17:45 UTC
Works fine with Server installation of MSVC Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: a653e50-1f92ab1-3bd0388]" Win-x86@6  - 2011-11-28)
and with 
Server installation of Master "LibO-dev 3.5.0 – WIN7 Home Premium (64bit) English UI [(Build ID:  3b32204-7f92fce-2ba0a9f)]" (2011-09-03)

[Reproducible] with "LibreOffice 3.5.0 RC2 German UI/Locale [Build-ID: e371a95-bf68a13-5a1aa2b-d3c1ae9-b938258] on German WIN7 Home Premium (64bit)
Comment 2 Roman Eisele 2012-05-07 23:55:32 UTC
NOT REPRODUCIBLE with LibreOffice 3.5.3.2 (Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80), German langpack installed, on MacOS X 10.6.8 German UI.

Following the steps listed in the original description, no crash occurs. In step 3 happens exactly what one would expect: "Start Media" selected, will be added with <ok>.

So, Windows only?!
Comment 3 Michael Meeks 2012-05-10 02:44:12 UTC
possibly related to bug#45081
Comment 4 Don't use this account, use tml@iki.fi 2012-05-11 02:51:44 UTC
Yes, the fix for bug #45081 helps here, too.

*** This bug has been marked as a duplicate of bug 45081 ***