Bug Hunting Session
Bug 49555 - EDITING: improve access to contents in Frames with wrap=through and "in background" option
Summary: EDITING: improve access to contents in Frames with wrap=through and "in backg...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-06 09:12 UTC by Saverio
Modified: 2015-06-05 13:31 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
The sample file where I followed the above procedure (9.24 KB, application/vnd.oasis.opendocument.text)
2012-05-06 09:12 UTC, Saverio
Details
New Sample, additional objects (22.65 KB, application/3dr)
2012-05-06 10:42 UTC, Rainer Bielefeld Retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Saverio 2012-05-06 09:12:52 UTC
Created attachment 61105 [details]
The sample file where I followed the above procedure

It is not possible to select the text into a textbox, when the frame wrap status is "through", the "in background" option is selected and after having resized it.

Steps to reproduce:
1. Open a new document
2. Insert a frame by clicking Insert->Frame... and the OK button
3. write something in the textbox frame
4. right-click on the frame and select the wrap->through->in background option
6. resize the frame
7. try to select again the text into the frame.

Current behavior:
The only way to select again the text is to uncheck the "in background" option from the textbox dialog.

Expected behavior:

Platform (if different from the browser): 
              
Browser: Mozilla/5.0 (Windows NT 6.0) AppleWebKit/535.19 (KHTML, like Gecko) Chrome/18.0.1025.168 Safari/535.19
Comment 1 Rainer Bielefeld Retired 2012-05-06 10:42:41 UTC
Created attachment 61107 [details]
New Sample, additional objects

I see the effect with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit). I can reach text contents via Navigator or after having clicked frame border with <f2>. But there is no way to reach the text contents dirctly using mouse after frame border has been selected.

That woks better for DRAW rectangles / shapes and DRAW text boxes as you see in my modified sample document. I believe selecting in text box should be possible in the same way as for the DRAW objects.

I can't believe that we should not already have a report for this.
Comment 2 Rainer Bielefeld Retired 2012-05-06 10:48:48 UTC
Same for me with LibO 3.3.3 and OOo 3.3, so I believe current behavior is inherited from OOo.

@Reporter: 
what solution do you expect?
Can you try to help to check for DUPLICATES?
Comment 3 Saverio 2012-05-07 03:28:52 UTC
I'm not sure about that, since I encountered no problems, with the same file, with LibO 3.4.3 of my previous Ubuntu 11.10 distribution.

(In reply to comment #2)
> Same for me with LibO 3.3.3 and OOo 3.3, so I believe current behavior is
> inherited from OOo.
> 
> @Reporter: 
> what solution do you expect?
> Can you try to help to check for DUPLICATES?
Comment 4 Rainer Bielefeld Retired 2012-05-20 22:03:08 UTC
@Cédric:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 5 Cédric Bosdonnat 2014-01-20 08:57:48 UTC
Restricted my LibreOffice hacking area
Comment 6 Gordo 2015-06-05 13:31:18 UTC
Tis no longer the case.

Windows Vista 64
Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16