Bug 49618 - odf_validation Error: attribute "draw:fit-to-size" has a bad value
Summary: odf_validation Error: attribute "draw:fit-to-size" has a bad value
Status: RESOLVED DUPLICATE of bug 45534
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL: https://bugs.freedesktop.org/attachme...
Whiteboard: odf odf_validation
Keywords:
Depends on:
Blocks: 49569
  Show dependency treegraph
 
Reported: 2012-05-08 00:45 UTC by Rainer Bielefeld Retired
Modified: 2012-09-13 14:20 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rainer Bielefeld Retired 2012-05-08 00:45:40 UTC
Document source: See URL

Steps how to reproduce: Download sample document, open with LibO Version mentioned below, save under new name, then do validator tests.

Text document saved with:  LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) 
PDF File Format: 1.2 Extended

Validation results (+ = ok, - = not ok), Message behind ":"
- odf-validator.rhcloud: Error: attribute "draw:fit-to-size" has a bad value. 
  Possible values are: false,true 
- Officeotron: bad value for attribute "fit-to-size" from namespace 
- Cyclone: Error: in styles.xml – Expecting element map, got graphic-properties 
  // Element style has extra content: graphic-properties //  
  Extra element style in interleave //  Invalid sequence in interleave // 
  Element styles failed to validate content 
> ODFToolkit: no test rewult 
> opendocumentfellowship: no test result 

I do not know whether additional "Cyclone" messages are related
Comment 1 Rainer Bielefeld Retired 2012-05-14 04:44:23 UTC
Same problem:
Document source: 30519 - Bad transitions if "use hardware acceleration" is enabled attachment 39102 [details]

Steps how to reproduce: Download sample document, open with LibO Version mentioned below, then do validator tests

Text document saved with:  LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) 
PDF File Format: 1.2 Extended

Validation results (+ = ok, - = not ok), Message behind
+ odf-validator.rhcloud:  styles.xml[2,13354]: Error: attribute "draw:fit-to-size" has a bad value. Possible values are: false,true 
+ Officeotron: (styles.xml:2 col:13,354) bad value for attribute "fit-to-size" from namespace 
+ Cyclone: Expecting element map, got graphic-properties – Element style has extra content: graphic-properties-- xtra element style in interleave – Invalid sequence in interleave – Element styles failed to validate content
+ ODFToolkit: not tested
Comment 2 Rodolfo 2012-08-02 05:37:16 UTC
The attribute only allows boolean values (ODF 1.2, §20.123 [1]).
However, maybe inspired by MS OOXML standards (I don't know them), LibO uses "shrink-to-fit", "stretch-to-fit" and "best-fit". [2] [3]

The ODF does not support these specifications.

[1] http://docs.oasis-open.org/office/v1.2/os/OpenDocument-v1.2-os-part1.html#__RefHeading__1419674_253892949   (Big file)
[2] http://opengrok.libreoffice.org/xref/core/oox/source/dump/dffdumper.ini#425
[3] http://opengrok.libreoffice.org/xref/core/svx/inc/svx/sdtfsitm.hxx#36
Comment 3 Michael Stahl (CIB) 2012-09-13 14:12:01 UTC
additional non-standard draw:fit-to-size values are only written in
ODF 1.2 extended mode since bug 45534 was fixed.

*** This bug has been marked as a duplicate of bug 45534 ***