Bug 49627 - First Launch of LibreOffice (shared installation) crashes after the splash screen, when loading extensions
Summary: First Launch of LibreOffice (shared installation) crashes after the splash sc...
Status: RESOLVED DUPLICATE of bug 43989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-08 03:08 UTC by osd.knights
Modified: 2012-05-10 12:25 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description osd.knights 2012-05-08 03:08:44 UTC
I have a shared installation of LibreOffice installed on Windows machine. It works fine for the user who installed and for any other user who logs-in, by default.

But after installing any shared extension using unopkg --shared, when a user other than the one who installed the extension, launches libreoffice, it crashes at the first launch without any error message. The subsequent launch works fine. 
In the case of the new user logging in, the libreoffice user profile folder does not pre-exist at the first launch. But after the crash, the libreoffice user profile folder is generated and the subsequent launch works fine. 

This behavior happens only after installing shared extensions. Also for the user who installed the extension, if the Libreoffice profile folder is deleted, the Libreoffice crash is reproducible.

The behavior is very consistent and reproducible on both windows XP 32-bit and windows 7 64-bit machines with different versions of Libreoffice like 3.3, 3.4 and 3.5

If not for shared extensions, the Libreoffice shared installation works fine.

Is there any workaround or existing solution?
Comment 1 Andras Timar 2012-05-10 12:25:52 UTC

*** This bug has been marked as a duplicate of bug 43989 ***