Bug 49639 - FILEOPEN html content .xls files shows text.csv with html tags instead of Spreadsheet contents
Summary: FILEOPEN html content .xls files shows text.csv with html tags instead of S...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: All All
: medium normal
Assignee: Eike Rathke
QA Contact:
URL:
Whiteboard: target:3.6.0 target:3.5.4
Keywords: regression
Depends on:
Blocks:
 
Reported: 2012-05-08 07:17 UTC by David Clayton
Modified: 2015-01-22 17:57 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file 1 (1.80 KB, application/vnd.ms-excel)
2012-05-08 07:17 UTC, David Clayton
Details
Example file 2 (8.12 KB, application/vnd.ms-excel)
2012-05-08 07:18 UTC, David Clayton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Clayton 2012-05-08 07:17:40 UTC
Created attachment 61231 [details]
Example file 1

When you open the sample files in calc you get an import dialogue, and the data is brought in with all the html formatting. If you delete the .xls file exension
and open using sweb.exe, the table and data seem as expected.

Tested on Win 7 32bit and Win Vista, it has only just started happening on
3.5.3 after we upgraded these machines last week. 

I can confirm that opening these documents worked on 3.5.2

Please see reference to bug 37972.
Comment 1 David Clayton 2012-05-08 07:18:13 UTC
Created attachment 61232 [details]
Example file 2
Comment 2 Rainer Bielefeld Retired 2012-05-08 07:47:19 UTC
I was able to reproduce the problem in Bug 37972#c17

Was still ok with parallel Server installation of "LOdev 3.5.1rc0+   [Build ID: e80d2ea-73cb0b8-f269e46] Win-x86@6-fast  pull time 2012-02-24 11:11:48  – WIN7 Home Premium (64bit) and
ok in 3.5.0, so regression.

@Kohei:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug or forward the Bug if it's not your turf.
Comment 3 Eike Rathke 2012-05-10 08:05:08 UTC

*** This bug has been marked as a duplicate of bug 46233 ***
Comment 4 Eike Rathke 2012-05-10 08:46:55 UTC
Damn, this is yet something different. Regression introduced with the fix for bug 40021.
Comment 5 Not Assigned 2012-05-10 10:10:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aeb1451dff06ad00b1719f9bc45a2c8bdfa904f8

resolved fdo#49639 import .xls with HTML as such, not CSV
Comment 6 Not Assigned 2012-05-11 09:01:37 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c4f1c3053a4d892b0bbc8842044133b64eee00ae&g=libreoffice-3-5

resolved fdo#49639 import .xls with HTML as such, not CSV


It will be available in LibreOffice 3.5.4.