Bug Hunting Session
Bug 49653 - Allow objects to be anchored to page inside section.
Summary: Allow objects to be anchored to page inside section.
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-08 12:20 UTC by vitruss
Modified: 2013-06-23 15:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description vitruss 2012-05-08 12:20:06 UTC
I want to propose an enhanced way of anchoring images (and other objects). 
Till now, if the object is anchored to the page inside any section it doesn't move if previous section grows or shrinks. 

To my opinion this behavior is not correct. If the image is anchored to the page, which is inside the section it have to move with whole section.

Simple example.
We have two sections:
Section1 - page 1-3
Section2 - page 4-6
Image1 is located on page 5 (so it belongs to Section2).

If the content is added to Section1, so it takes now pages 1-4, Image1 have to move from page 5 to page 6, because all the Section2 content have moved from page 4-6 to page 5-7.

I can imagine the situation, when somebody don't want to move the image with the section, so my preposition is to add the checkbox in the "Type" tab of Picture, Frame etc. menu (and inside the style options to!) to allow the image anchoring inside the section.

I've tried to do images anchored as character as it is written in handbook. This fails to me, because I need images (Sometimes two of them in parallel) to be located exactly at the top or bottom of the page, but not moving within the text through all the page.
Comment 1 Joel Madero 2013-06-23 15:29:38 UTC
This is expected and intended behavior - if you want it to move you should anchor it to the paragraph and as paragraph shifts to next page, so will object.

We wouldn't change behavior of anchor to page, adding an additional anchoring option is tricky (as it might not comply with open standards) and seems like it would just provide a slightly (very slightly) different anchor than anchor to paragraph.

Therefore, marking as WONTFIX


Thanks for the suggestion