Bug Hunting Session
Bug 49724 - Update filters for file selector's file type categories
Summary: Update filters for file selector's file type categories
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.5.5 target:3.6....
Keywords: difficultyBeginner, easyHack, topicUI
: 39807 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-10 03:49 UTC by Andras Timar
Modified: 2015-12-16 05:25 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Text Filters and Spreadsheet Filters update (4.48 KB, patch)
2012-06-07 17:46 UTC, Alberto Ferreira
Details
update type filter for Impress (2.14 KB, patch)
2012-06-07 19:09 UTC, Alberto Ferreira
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andras Timar 2012-05-10 03:49:14 UTC
Open LibreOffice and select File - Open... menu. The File selector dialog appears. Here the user can select file type categories, like "All files", "Text documents", etc.

The problem is that not all text documents known by LibreOffice filters are classied as such, so for example when the user selects Text documents, the dialog will not show .docx files.

In http://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI.xcu#39 you can see the list of filters that are taken into account now, some of them are obsolete (WW4), some are missing. The filter names are from filter\source\config\fragments\filters\. You can find out the associated extensions from filter\source\config\fragments\types\.

Task: update officecfg/registry/data/org/openoffice/Office/UI.xcu with current filter information for all file type categories.
Comment 1 Alberto Ferreira 2012-06-07 17:46:09 UTC
Created attachment 62773 [details]
Text Filters and Spreadsheet Filters update
Comment 2 Alberto Ferreira 2012-06-07 19:09:54 UTC
Created attachment 62774 [details]
update type filter for Impress
Comment 3 Andras Timar 2012-06-08 02:50:54 UTC
Hi Alberto,

I notice you're not yet listed on

 http://wiki.documentfoundation.org/Development/Developers

, did you state the license your work is under already? If not, the
easiest way is to send a mail to libreoffice@lists.freedesktop.org saying something along the lines of

 "My previous and all future contributions to LibreOffice, unless
stated otherwise, are licensed under LGPLv3+/MPL"

Thanks a lot,
Andras
Comment 4 Alberto Ferreira 2012-06-08 03:32:52 UTC
Dearm Andras,

I have send my request to be included in developers list.

I'm waiting.

Nest Reagrds,
Alberto
Comment 5 Not Assigned 2012-06-08 12:35:56 UTC
Alberto Ferreira committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f35d1e70e70a1c074bc16cbc430ba93d89a717b

fdo#49724 - Update filters for file selector's file type categories
Comment 6 Not Assigned 2012-06-08 12:47:11 UTC
Alberto Ferreira committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0282fa7fa31256c510b9f4818a049e5d2e32a8a4&g=libreoffice-3-5

fdo#49724 - Update filters for file selector's file type categories


It will be available in LibreOffice 3.5.5.
Comment 7 Not Assigned 2012-06-08 12:58:25 UTC
Alberto Ferreira committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=afe5eaff843506a7796eafedcd967fcb68c2219f&g=libreoffice-3-6

fdo#49724 - Update filters for file selector's file type categories


It will be available in LibreOffice 3.6.
Comment 8 Korrawit Pruegsanusak 2012-06-08 20:46:50 UTC
Hi Alberto,

Thanks for working on this!

Anyway, you have removed the following filters:
> MS Winword 6.0
> MS Word 95
> MS Word 95 Vorlage
> MS Excel 4.0
> MS Excel 4.0 Vorlage/Template
> MS Excel 5.0/95
> MS Excel 95
> MS Excel 95 Vorlage/Template
> StarOffice XML (Impress)

These filters still listed in filter/source/config/fragments/filters/. Is this intended?
Comment 9 Korrawit Pruegsanusak 2012-06-08 20:47:44 UTC
*** Bug 39807 has been marked as a duplicate of this bug. ***
Comment 10 Andras Timar 2012-06-08 22:33:00 UTC
(In reply to comment #8)
> 
> These filters still listed in filter/source/config/fragments/filters/. Is this
> intended?

Only the file extension counts here, it is not necessary to list all filters, that open *.doc, for example.
Comment 11 Rainer Bielefeld Retired 2012-08-03 09:22:20 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.
Comment 12 Robinson Tryon (qubit) 2015-12-16 05:25:35 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner TopicUI )
[NinjaEdit]