Bug 49827 - Incomplete MacOS Finder integration: direct printing not working when LO already in Dock
Summary: Incomplete MacOS Finder integration: direct printing not working when LO alre...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.4.6 release
Hardware: All Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2012-05-12 00:39 UTC by Roman Eisele
Modified: 2015-03-08 14:47 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash with LibO 3.4.6 when trying to print .odt files from the Finder (1) (42.68 KB, text/plain)
2012-05-12 01:06 UTC, Roman Eisele
Details
Crash with LibO 3.4.6 when trying to print .odt files from the Finder (2) (42.94 KB, text/plain)
2012-05-12 01:06 UTC, Roman Eisele
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-05-12 00:39:09 UTC
The MacOS X Finder has a 'Print' item in the 'File' menu. This 'Print' item is enabled as soon as you select one or more document(s) in the Finder. If you select the menu item, MacOS X starts the application(s) associated with the selected files, the files get opened and get printed via the associated applications.

This should also work with LibreOffice. But if I select one ore more .odt/.ods/.odp document(s) in the Finder and select 'Print' from the 'File' menu, the only thing which happens is that LibreOffice comes to the front (if it is running) or is started (if it isn't running). No file is opened, no Print dialog appears, regardless whether I select 1 or 2 or 3 ... .odt/.ods/.odp file(s).

On my machine (running MacOS X 10.6.8 with German UI and LibreOffice 3.5.3.2, German langpack installed), the 'Print' command from the Finder works just fine with other apllications. So I suspect that this is a LibreOffice bug: the print event sent from the Finder (or the OS?) to LibreOffice is not handled at all.

Please note that there is a similar problem on Windows (bug 33484), but the details are different, so that this (present) issue seems to be a special Mac-specific bug (cf. comment #15 to bug 33484).
Comment 1 Roman Eisele 2012-05-12 01:01:54 UTC
I tried the same with LibreOffice 3.4.6 (on a separate user profile). Here the results are different:

* When I select one or more .ods files in the Finder and select 'Print', nothing happens (like with LibreOffice 3.5.3.2)

* But when I select one or more .odt files in the Finder and select 'Print', LibreOffice 3.4.6 crashes with EXC_BAD_ACCESS (SIGBUS). I will attach two Log files created by MacOS X for this kind of crash (there are small differences in the thread 0 dispatch queue).

So it seems that LibreOffice 3.4.x tries to handle the print event, but does not succeed, while LibreOffice 3.5.3.2 (see description above) seems to ignore the print event completely.

Therefore, the crash in 3.4.6 may be a different iusse, but I don't file a separate bug report for it because the 3.4.x branch is closed. I provide this comment on LibO 3.4.6 just as some kind of background information. The summary is the same: direct printing (from Finder) not working, whether by crashing or by doing nothing ;-).
Comment 2 Roman Eisele 2012-05-12 01:06:25 UTC
Created attachment 61478 [details]
Crash with LibO 3.4.6 when trying to print .odt files from the Finder (1)
Comment 3 Roman Eisele 2012-05-12 01:06:48 UTC
Created attachment 61479 [details]
Crash with LibO 3.4.6 when trying to print .odt files from the Finder (2)
Comment 4 Rainer Meier 2012-05-13 04:06:01 UTC
Roman has asked me to comment here. But unfortunately I can't provide much input as I am not using MacOS X on a regular base. So maybe the issue that sometimes one document prints and sometimes none of then is related to bug 33484.

Maybe anybody could test printing multiple documents and then check the process tree whether there are multiple soffice process entries visible which seem to block each other. On Windows this is exactly what happens. After launching multiple soffice instances via print functionality they seem to be locked in some kind of deadlock and only hard-terminating them via task manager unblocks the situation. On Windows the situation is even worse as these hanging soffice processes seem not to respond to normal kill signals (SIGHUP) and therefore prevent users to reboot. But maybe this does not happen on MacOS X if it's force-terminating (SIGKILL) the processes if they do not terminate within a defined time frame.
Comment 5 Alex Thurgood 2012-10-04 13:00:27 UTC
If LO is not already open, I can not reproduce. Multiple ODT documents selected in Finder will cause LO to open reduced (no window is displayed) and then passed to the printer. All the documents selected are printed out.


If LO is already running in the Dock with no other document open, then no documents get printed, and LO hangs requiring force kill to release.


So for me, there are 2 different situations :
(1) when LO is not already running - printing works
(2) when LO already running - printing doesn't work and causes the app to hang.

Alex
Comment 6 Alex Thurgood 2012-10-04 13:00:56 UTC
Tested with Version 3.7.0.0.alpha0+ (Build ID: b966a09)


Alex
Comment 7 Alex Thurgood 2012-10-04 13:02:54 UTC
Note that no printer dialog is displayed, the documents just get sent to the printer with whatever default settings are available.


Alex
Comment 8 Roman Eisele 2012-10-04 14:27:32 UTC
@ Alex:

Thank you for testing and helpful comments!

Can’t we set the status of this bug to NEW if we change the summary according to your comment #5 -- i.e., add the condition that LibO is already running to the summary? ;-)
Comment 9 Alex Thurgood 2012-10-05 10:17:13 UTC
(In reply to comment #8)
> @ Alex:
> 
> Thank you for testing and helpful comments!
> 
> Can’t we set the status of this bug to NEW if we change the summary
> according to your comment #5 -- i.e., add the condition that LibO is already
> running to the summary? ;-)

Sure, done :-)

Alex
Comment 10 QA Administrators 2015-01-05 17:51:21 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.3.5 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior

If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

Thank you for your help!

-- The LibreOffice QA Team
Comment 11 Alex Thurgood 2015-03-08 14:42:13 UTC
Tested on master

Version: 4.5.0.0.alpha0+
Build ID: 6a150d772f6192579af95bef314cae7fca592d5b
Locale: fr_

with OSX 10.10.2

Single ODT > prints from Finder
Single ODG > prints from Finder
Single ODS > prints from Finder

Multiple ODS files > prints from Finder

so I would set this as RESOLVED WFM
Comment 12 Alex Thurgood 2015-03-08 14:45:05 UTC
It also works whether LibreOffice is already running and in the Dock, or if it is launched via the Print command from Finder.
Comment 13 Alex Thurgood 2015-03-08 14:47:13 UTC
Also works with LibreOffice
 
Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale : fr_