Download it now!
Bug 49847 - FILEOPEN .doc (created with LibO) vertically merged cells of TABLE shown as separate cells
Summary: FILEOPEN .doc (created with LibO) vertically merged cells of TABLE shown as s...
Status: RESOLVED DUPLICATE of bug 54862
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-12 11:24 UTC by Ingeborg Inacio
Modified: 2012-11-02 15:06 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Test Kit (3.01 KB, application/x-zip-compressed)
2012-05-13 01:22 UTC, Rainer Bielefeld Retired
Details
Vertical merge test (8.68 KB, application/x-zip-compressed)
2012-08-30 03:48 UTC, viiri
Details
Merged cells in 3.6.1 (78.12 KB, image/png)
2012-08-30 04:07 UTC, viiri
Details
Merged cells in 3.5.6 (78.42 KB, image/png)
2012-08-30 04:08 UTC, viiri
Details
Files where you can see the problem (70.81 KB, application/zip)
2012-09-15 22:04 UTC, jagelmetti
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ingeborg Inacio 2012-05-12 11:24:37 UTC
Problem description: Merging cells seems to go ok on screen but is gone after saving and reloading the file.

Steps to reproduce:
1. Make a table of 3 rows, 5 col.
2. Type something into certain cells.
3. Merge som of the empty cells.
4. Save as .doc and close.
5. Open the file. 

Current behavior: No merged cells.

Expected behavior: Merged cells.

Platform (if different from the browser): Ubuntu 12.04
              
Browser: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/12.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19
Comment 1 Rainer Bielefeld Retired 2012-05-13 01:20:50 UTC
NOT reproducible with "LibreOffice 3.5.3.2 (RC2) German UI/Locale [Build-ID: 235ab8a-3802056-4a8fed3-2d66ea8-e241b80] on German WIN7 Home Premium (64bit) and "sample1.doc" from attached "testkit.zip" (see "sample2.doc").

@reporter:
Thank you for your report – unfortunately important information is missing.
May be hints on <http://wiki.documentfoundation.org/BugReport> will help you to find out what information will be useful to reproduce your problem? If you believe that that  is really sophisticated please as for Help on a user mailing list
Please:
- Write a meaningful Summary describing exactly what the problem is
- Attach a sample document (not only screenshot) or refer to an existing 
  sample document in an other Bug with a link.
- Attach screenshots with comments if you believe that that might explain the 
  problem better than a text comment. Best way is to insert your screenshots
  into a DRAW document and to add comments that explain what you want to show
- Contribute a step by step instruction containing every key press and every 
  mouse click how to reproduce your problem (due to example in Bug 43431)
– if possible contribute an instruction how to create a sample document 
  from the scratch
- add information 
   -- concerning your OS (Language)
  -- concerning your LibO version (with Build ID if it's not a public release)
     and localization (UI language, Locale setting)
  –- Libo settings that might be related to your problems 
  -- how you launch LibO and how you opened the sample document
  -- everything else crossing your mind after you read linked texts
Comment 2 Rainer Bielefeld Retired 2012-05-13 01:22:11 UTC
Created attachment 61544 [details]
Test Kit
Comment 3 viiri 2012-08-30 03:47:45 UTC
Bug exists in 3.6.0 and 3.6.1, but not in 3.5.x.
Comment 4 viiri 2012-08-30 03:48:40 UTC
Created attachment 66309 [details]
Vertical merge test
Comment 5 viiri 2012-08-30 04:07:20 UTC
Created attachment 66311 [details]
Merged cells in 3.6.1

How it looks in 3.6.1
Comment 6 viiri 2012-08-30 04:08:09 UTC
Created attachment 66312 [details]
Merged cells in 3.5.6

How it should look and how it looks in 3.5.6
Comment 7 Rainer Bielefeld Retired 2012-08-30 04:45:24 UTC
Steps how to reproduce:
1. Create new Writer document from Start Center
2. Click Table Icon in Tollbar, insert Table 5 rows 5 columns
3. Starting with top left cell type 1 ... 5 into the diagonal cells
4. Click into cell with "1", with pushed left mose utton select together 
   with cell below
5. Menu 'Table -> Merge Cells'
   > Highligted Cells will be merged
6. Click into cell below the one with contents "2"
7. Merge with cell containing "3" 
   > Cells will be merged
   > Unexpetedly now row has double hight,but that#s a diffrent problem
8. Save as "sample1.odt", close and reopen
   > Nothing unexpected
9. Save as "sample1.doc", close and reopen
   Expected: looks exactly as "sample1.odt"
   Actual: Cell with "1" and Cell below are separated again

The unexpected View in Step 9 is a FILEOPEN problem, in MS WORD VIEWER the cells still are merged.

No idea what that has to do with report, what is much too rare to find the problem. But my problem is not reproducible with 3.5.2, so I think reporter's problem was different.

Most simple document with what I was able to reproduce contains an empty table, 2 rows, 2 columns, left cells vertically merged.

Already [Reproducible] with 
- Server installation of Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 7175cee]" (tinderbox: Win-x86@6-fast, pull time 2012-05-16 22:07:37)
- MinGW build 2012-04-26

Was still ok with 
- Server installation of  Master "LOdev 3.6.0alpha0+  – WIN7 Home Premium (64bit) ENGLISH UI [Build ID: 475d0c5-829fc92-39746e8-206648e-fefd87]" (2012-02-14)

@viiri@mail.ru:
<http://wiki.documentfoundation.org/BugReport_Details#Version>
If you see more problems with merged cells please submit additional reports and try to be similar precise as you see in my examinations above!
What is your Operating System?

@Michael:
Please set Status to ASSIGNED and add yourself to "Assigned To" if you accept this Bug
Comment 8 Rainer Bielefeld Retired 2012-08-30 04:46:07 UTC
Comment on attachment 61544 [details]
Test Kit

Irrelevant for final bug description
Comment 9 jagelmetti 2012-09-15 22:04:25 UTC
Created attachment 67216 [details]
Files where you can see the problem

I saw the problem in LibO Versión 3.6.1.2 (ID de compilación: e29a214) and 3.6.0 - Windows 7 Home Basic SP1 - 64Bits
Comment 10 Rainer Bielefeld Retired 2012-11-02 15:06:56 UTC
I am pretty sure that this one is a DUP of "Bug 54862 - FILEOPEN, TABLES: Merged table cells from .doc file appear split in Writer", especially because the problem is fixed for "LibreOffice 3.6.3.2” German UI/ German Locale [Build-ID: 58f22d5]" on German WIN7 Home Premium (64bit)  

@reporter:
Please feel free to reopen this Bug if you find evidence that we have an independent issue here.

*** This bug has been marked as a duplicate of bug 54862 ***