Download it now!
Bug 49858 - : libreoffice-kde doesn't look native but libreoffice-gtk does
Summary: : libreoffice-kde doesn't look native but libreoffice-gtk does
Status: RESOLVED DUPLICATE of bug 48611
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.2.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-13 01:13 UTC by christitze
Modified: 2013-08-14 21:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of both desktop-integration packages in comparison to each other (190.42 KB, image/png)
2012-05-13 01:13 UTC, christitze
Details

Note You need to log in before you can comment on or make changes to this bug.
Description christitze 2012-05-13 01:13:50 UTC
Created attachment 61543 [details]
screenshot of both desktop-integration packages in comparison to each other

Sorry if this is the wrong place to report bugs with the desktop-integration packages for LO, but I couldn't find another appropriate place to report this bug.

Problem description:
The menus displayed when the libreoffice-kde integration is installed look ugly and not native in KDE. It is also hard to work with them because there are no borders around the menus and so they're not distinctive enough.

Steps to reproduce:
1. install libreoffice-kde and look at UI
2. install libreoffice-gtk and look at UI

Current behavior:
libreoffice-gtk looks much more native in KDE than libreoffice-kde

Expected behavior:
libreoffice-kde should look native in KDE
              
Browser: Mozilla/5.0 (X11; Linux i686) AppleWebKit/535.19 (KHTML, like Gecko) Ubuntu/12.04 Chromium/18.0.1025.151 Chrome/18.0.1025.151 Safari/535.19
Comment 1 Marco Menardi 2012-12-31 13:16:03 UTC
I've to admit that maybe the good work is done by gtk2-engine-oxygen more than the libreoffice-kde. I've removed libreoffice-kde and installed libreoffice-gtk and things look the same if not better (i.e. bug #57089 seems solved).
If you remove gtk2-engines-oxygen instead the integration disappears at all level (look and system dialogs, like "file open").
We need a developer with a broader picture of the situation to understand if libreoffice-kde is obsolete thanks to new KDE ability to nicely integrate GTK aps.
Comment 2 Marco Menardi 2012-12-31 13:35:52 UTC
Investigating bug #49696 I've found that libreoffice-kde offers the "single click" general behaviour when navigating directories in the file dialog that is missed if that package is removed.
Comment 3 Mirosław Zalewski 2013-08-14 21:05:25 UTC
This is because upstream LibreOffice packages provide integration with KDE3, not KDE4 (which most distributions ship for years now).

Please provide any additional comments in Bug 48611. I am marking this one as duplicate of it.

*** This bug has been marked as a duplicate of bug 48611 ***