Bug 49859 - FORMATTING, UI: numbering alignment or indentation is not applied in Impress
Summary: FORMATTING, UI: numbering alignment or indentation is not applied in Impress
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.7.0 target:3.6.0.0.beta1
Keywords:
Depends on:
Blocks: Impress-Bullet-Number
  Show dependency treegraph
 
Reported: 2012-05-13 01:58 UTC by Stephan van den Akker
Modified: 2013-04-25 16:29 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephan van den Akker 2012-05-13 01:58:01 UTC
How to reproduce (use any presentation):

- In the main menu choose Format | Bullets and Numbering
- The dialog "Bullets and Numbering" appears
- In the dialog choose Tab "Position"
- Choose a Level that is used in the presentation
- Change the value for "Ident" or "Width of numbering"
- Change to other tab in dialog (without first changing input focus 
  to another field in the "Position" tab)
- Press OK

Expected result:
Spacing of numbering is changed

Actual result:
formatting of bullets and numbering is unchanged in the slides
Revisit the "Position" tab: Value is unchanged

Changes in a numerical input field in the Positions tab are applied
when the field looses keyboard focus. This event is not triggered
for the input field when it looses focus because of a tab switch.

Bug is present in OpenOffice 3.1.0 on Windows.
Bug is still present in LO master (as of Build ID: 7327195, 11 May 2012)
Comment 1 sasha.libreoffice 2012-05-14 02:03:19 UTC
Thanks for bugreport
Reproduced in 3.3.4 and 3.5.3 on Fedora 64 bit
Comment 2 Not Assigned 2012-06-07 00:30:38 UTC
Stephan van den Akker committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5601c5d395a5eece95a8d8a5600de91aa20485c6

Fix for fdo#49859 Impress bullet indent data entry
Comment 3 Not Assigned 2012-06-07 00:36:53 UTC
Stephan van den Akker committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9277c7320406b4737bd71564e341464676c66e31&g=libreoffice-3-6

Fix for fdo#49859 Impress bullet indent data entry


It will be available in LibreOffice 3.6.
Comment 4 Rainer Bielefeld Retired 2012-08-03 09:15:02 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.
Comment 5 Winfried Donkers 2012-10-31 08:46:09 UTC
In version 3.6.3RC2 problem still occurs:

in a slide:
-press button 'numbering ON'
-enter multiple lines; these are marked with a bullet
-select any line; the buttons indent left/right are disabled
-pressing Alt+Shift+Left/Right produces irregular (and certainly unexpected) results
Comment 6 Stephan van den Akker 2012-10-31 12:30:21 UTC
@Winfried:

This report is about a bug in the "Bullets and Numbering" dialog that has been fixed. It might get a status FIXED any time now.

You report a bug is about a different problem in the main window UI.

To prevent your problem from accidentally being "buried" along with this one you might consider filing it as a separate issue.
Comment 7 Winfried Donkers 2012-11-01 06:30:48 UTC
(In reply to comment #6)
@Stephan:

Ok, I will create a new bug for my problem. Trying to avoid duplicate bugs sometimes leads to polltion such as this ;)
Given that the bug is still open: what is withholding the status resolved/fixed?
Comment 8 Samuel Mehrbrodt (CIB) 2013-04-25 16:29:29 UTC
Verified it works here.