Bug Hunting Session
Bug 49903 - FILEOPEN: large sheet causes crash
Summary: FILEOPEN: large sheet causes crash
Status: RESOLVED DUPLICATE of bug 47044
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-14 05:40 UTC by rim
Modified: 2012-06-12 01:14 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Calc crashes on opening this (257.62 KB, application/vnd.oasis.opendocument.spreadsheet)
2012-05-14 05:40 UTC, rim
Details
Bug 49903 - WinDbg session with FAILED_SOURCE_CODE (38.42 KB, text/plain)
2012-05-31 02:59 UTC, bfoman (inactive)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rim 2012-05-14 05:40:23 UTC
Created attachment 61610 [details]
Calc crashes on opening this

there are a number of similar bugs in about all LO-versions up to 3.5.3.2.
LO cannot open reliably large sheets, containing (many) matrix formula.
When opening attached file in LibreOffice calc progress bar "Load document..." stops just before completion and LO crashes "Due to an unexpected error..."
On rare occasions (after closing down all resident programs, stopping AV, etc.) you may be lucky, but normally LO crashes.
My configuration: Win7-64 home SP1, 4GB, AMD Phenom II X4 820, ATI Radion HD 5300/5400.
Comment 1 s-joyemusequna 2012-05-14 06:48:04 UTC
Confirmed with LibO 3.4.5.

Works for me with LOdev 3.6 (master - 14-May-2012 02h55 x86@6-fast; Build ID: 347e345) and LibO 3.5.3. Tested on Windows XP and Vista 64.
Comment 2 Julien Nabet 2012-05-15 14:02:38 UTC
On pc Debian x86-64, with 3.5 branch updated today, I don't reproduce the problem.

However, I noticed that it takes about 20 seconds + these kind of messages.

(pkix_CacheCert_Add: PKIX_PL_HashTable_Add for Certs skipped: entry existed

warn:legacy.tools:15271:1:/home/julien/compile-libreoffice/libo_3_5/sfx2/source/appl/appuno.cxx:512: invalid type for InteractionHandler

warn:legacy.osl:15271:1:/home/julien/compile-libreoffice/libo_3_5/sc/source/core/data/documen7.cxx:247: RemoveFromFormulaTree: nFormulaCodeInTree < nRPN

Remark : the file contains some macro.
Comment 3 bfoman (inactive) 2012-05-16 23:38:56 UTC
Confirmed with:
LOdev 3.5.3rc1+ 
Build ID: 51648779-22e3d74-d554af7
Windows 7 Professional SP1 64 bit

Calc crashes near the end of loading file progress bar.
Comment 4 rim 2012-05-17 01:04:02 UTC
just retested running Ubuntu-12.04.
Same crash on 3.5.2 - but now runs well after the recent update (3.5.3).
Strange difference between the 'same' 3.5.3-versions of Win7 and Ubuntu-12.04 ...
Comment 5 Julien Nabet 2012-05-24 15:22:42 UTC
So it seems ok now with last versions.

bfoman: could you try with 3.5.3.2 and if necessary with a brand new LO profile (see http://wiki.documentfoundation.org/Documentation/UserProfile) ?
Comment 6 rim 2012-05-29 14:39:01 UTC
LibO 3.5.3.2 for Windows still has the exact same issue. Even after 'cleaning' the user profile as suggested. I have to close many background programs to make it work. To me that's strange because there is enough free memory of the installed 4GB...
Comment 7 Julien Nabet 2012-05-29 15:33:12 UTC
It could be interesting you follow the memory used during the opening of the file with builtin Windows tools.
Could you test ?
Comment 8 rim 2012-05-30 06:25:07 UTC
Total memory is not the issue: just ran a test, after starting LibO memory usage goes up from 1.7 GB to just 1.8 GB memory usage (of 4 GB total) and then LibO crashes. Processes remain 'running' in the background and after killing those I'm back at 1.7 GB. Nothing special except those crashes. Perhaps some timing issues?
Comment 9 bfoman (inactive) 2012-05-31 02:59:24 UTC
Confirmed with:
LO 3.5.4.2 
Build ID: own W7 debug build
Windows 7 Professional SP1 64 bit

Calc crashes near the end of loading file progress bar.
I am surprised as load crash is initiated by the same source section that bug 47044 is about (and others alike).
Comment 10 bfoman (inactive) 2012-05-31 02:59:58 UTC
Created attachment 62324 [details]
Bug 49903 - WinDbg session with FAILED_SOURCE_CODE

Attached full WinDbg session with FAILED_SOURCE_CODE.
Comment 11 Julien Nabet 2012-05-31 04:54:05 UTC
Noticed same top line in bt than fdo#47044 (see also http://nabble.documentfoundation.org/About-fdo-47044-crashed-when-accessing-Proxy-etc-td3986891.html#a3987011)
It would mean that if fdo#47044 is solved, this tracker might be solved too.
Comment 12 Stephan Bergmann 2012-06-12 01:14:35 UTC
This looks like it was once also reproduced on Linux (comment 4: "just retested running Ubuntu-12.04.  Same crash on 3.5.2 - but now runs well after the recent update (3.5.3)."), but the backtrace in attachment 62324 [details] indicates that all the reported failures on Windows are due to bug 47044.  So marking this as a duplicate anyway.

*** This bug has been marked as a duplicate of bug 47044 ***