Download it now!
Bug 49914 - On MacOS X, the new rulers always look like disabled
Summary: On MacOS X, the new rulers always look like disabled
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0
Keywords: regression
Depends on:
Blocks: MacOS-Wishlist
  Show dependency treegraph
 
Reported: 2012-05-14 07:25 UTC by Roman Eisele
Modified: 2014-08-16 10:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer screenshot: new rulers look like disabled (192.43 KB, image/png)
2012-05-14 07:25 UTC, Roman Eisele
Details
Impress screenshot: new rulers look like disabled (135.31 KB, image/png)
2012-05-15 00:10 UTC, Roman Eisele
Details
Writer screenshot (Master build 2012-05-18): page border/shadow looks better, but rulers still the same (187.36 KB, image/png)
2012-05-18 07:23 UTC, Roman Eisele
Details
Writer screenshot: this is how the same document looks in LibO 3.5.3.2 (170.59 KB, image/png)
2012-05-18 07:29 UTC, Roman Eisele
Details
Writer screenshot: new rulers look enabled again in Master build 2012-05-24 (207.65 KB, image/png)
2012-05-24 10:24 UTC, Roman Eisele
Details
Impress screenshot: new rulers look enabled again in Master build 2012-05-24 (165.38 KB, image/png)
2012-05-24 10:24 UTC, Roman Eisele
Details
Screenshot showing LibreOffice Writer 3.6.2.2 on Mac OS X 10.6.8 (145.89 KB, image/png)
2012-10-04 10:47 UTC, Roman Eisele
Details
LO4.3.1RC1, rulers, looking good to me (105.19 KB, image/jpeg)
2014-08-16 10:07 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Eisele 2012-05-14 07:25:23 UTC
Created attachment 61624 [details]
Writer screenshot: new rulers look like disabled

The new rulers (implemented with commit: http://cgit.freedesktop.org/libreoffice/core/commit/?id=778d80bc2c37e4549daff2cc1f74f8665235407b, cf. mail on design list: http://listarchives.libreoffice.org/global/design/msg04151.html) are nice, thank you! You are right, simplicity is beautiful.

However, at least on MacOS X (10.6.8 in my case) there is a problem: the new rulers always look like disabled. When I first opened a document and selected some text to test the new rulers, I was really irritated: I thought that the rulers were disabled and did not work. I soon recognized that they work as expected, but it is still irritating ...

I will attach a screenshot which shows the new rulers in action. Some text in the main text area is selected (and no dialog window is open), so the rulers are active (you can change margins, tabulators, etc.), but their look still suggests (at least to me) that they don't work.
Comment 1 Roman Eisele 2012-05-14 07:33:16 UTC
Sorry, an addendum:
The screenshot was created with LOdev version 3.6.0alpha0+ (Build ID: e3bc45b; installation file: master~2012-05-13_00.05.49_LibO-Dev_3.6.0alpha0_MacOS_x86_install_en-US.dmg), on MacOS X 10.6.8 with German UI. All LibreOffice UI colors are set to default values.

Could someone please test on Windows / Linux to verify if the rulers look right on other platforms?
Comment 2 Roman Eisele 2012-05-15 00:10:23 UTC
It's the same with the rulers in Impress; therefore changed Component field to 'UI'. Will attach an Impress screenshot.
Comment 3 Roman Eisele 2012-05-15 00:10:55 UTC
Created attachment 61668 [details]
Impress screenshot: new rulers look like disabled
Comment 4 Roman Eisele 2012-05-18 07:23:55 UTC
Created attachment 61807 [details]
Writer screenshot (Master build 2012-05-18): page border/shadow looks better, but rulers still the same
Comment 5 Roman Eisele 2012-05-18 07:29:24 UTC
Created attachment 61808 [details]
Writer screenshot: this is how the same document looks in LibO 3.5.3.2
Comment 6 Roman Eisele 2012-05-18 07:34:09 UTC
But what is wrong with the new look? It's just that everything in the new rulers is grey, and not only grey, but only bright and medium grey colors. But using light and medium grey only suggests 'disabled' to me, and probably not only to me, but to many (MacOS X) users.

This seems to be a special MacOS-iusse, because on some screenshots of the new rulers on other platforms, e.g.

http://artax.karlin.mff.cuni.cz/~kendy/blog/pics/updated-rulers.png

the rulers do not have this 'disabled' look: the scale numbers are still black or dark grey.
Comment 7 Not Assigned 2012-05-23 03:12:54 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=422647493b33e397bcc19031ee13693ecaa65ba8

fdo#49914, rulers: DarkShadow color is supposed to be dark (even on Mac).
Comment 8 Roman Eisele 2012-05-24 10:22:18 UTC
VERIFIED FIXED: In LOdev version 3.6.0alpha0+ (Build ID: 2398b9c, date: 2012-05-24), the rulers now look 'enabled' again.

I will attach two screenshots confirming this (and which may be useful for comparison, too).

Thank you very much!
Comment 9 Roman Eisele 2012-05-24 10:24:07 UTC
Created attachment 62061 [details]
Writer screenshot: new rulers look enabled again in Master build 2012-05-24
Comment 10 Roman Eisele 2012-05-24 10:24:38 UTC
Created attachment 62062 [details]
Impress screenshot: new rulers look enabled again in Master build 2012-05-24
Comment 11 Adolfo Jayme 2012-07-03 07:21:42 UTC
Hi Roman, I've included two of your Writer comparison screenshots in the release notes page in the wiki <https://wiki.documentfoundation.org/ReleaseNotes/3.6#GUI>, hope you don't mind ;-)
Comment 12 Roman Eisele 2012-07-03 12:16:09 UTC
(In reply to comment #11)
> Hi Roman, I've included two of your Writer comparison screenshots in the
> release notes page in the wiki
> <https://wiki.documentfoundation.org/ReleaseNotes/3.6#GUI>, hope you don't mind
> ;-)

All right -- thank you!
Comment 13 Roman Eisele 2012-10-04 10:45:16 UTC
This bug has returned:

while in LibreOffice 3.6.0.4 it was fixed (I checked again), it is again in LibreOffice 3.6.2.2; the rulers look again like disabled. I will attach a screenshot showing the current state of affairs.
Comment 14 Roman Eisele 2012-10-04 10:47:10 UTC
Created attachment 68070 [details]
Screenshot showing LibreOffice Writer 3.6.2.2 on Mac OS X 10.6.8



The screenshot shows LibreOffice Writer 3.6.2.2 on Mac OS X 10.6.8; please note that the bug has returned, the rulers look again like on attachment 61624 [details].
Comment 15 Roman Eisele 2012-10-04 10:53:33 UTC
The bug was probably re-introduced when someone tried to fix bug 50610? The latter, which was probably a regression introduced by the fix for this (present) bug, commit 422647493b33e397bcc19031ee13693ecaa65ba8, seems to be gone.
Comment 16 retired 2014-08-16 10:04:54 UTC
I'm not sure what the problem is here. Is it the light grey? Attaching a screenshot, of what I see in LO 4.3.1RC1 which looks good to my eyes. OSX 10.9.4.

I light the light grey. Let's me focus more on the sheet I'm working on.

Maybe it's just adjusting to this change that is a little odd at first. But I'm rather sure, new users will like the view and since they do not adapt will not find it disturbing at all.

WORKSFORME.
Comment 17 retired 2014-08-16 10:07:39 UTC
Created attachment 104725 [details]
LO4.3.1RC1, rulers, looking good to me