Bug Hunting Session
Bug 49983 - Writer: Second and subsequent windows are poorly positioned
Summary: Writer: Second and subsequent windows are poorly positioned
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-15 19:40 UTC by Steve Grace
Modified: 2013-06-24 01:44 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Grace 2012-05-15 19:40:55 UTC
Tested on two PCs running Xubuntu 12.04.

Writer does not appear to be completely aware of a horizontal panel along the top edge of the screen. The first Writer window opens at the expected position. Subsequent windows open at the absolute top left relative to the entire screen, ignoring the panel. As a result, the subsequent window title bars are "underneath" the panel.

The workaround is to press Ctrl+Shift+J (or select View > Full Screen) twice to first make the screen full screen and then reset it back to "normal" size. This moves the subsequent windows below the panel.
Comment 1 ydutrieux 2012-12-17 07:57:56 UTC
NOT reproduced with libo Version 4.0.0.0.beta1 (Build ID: 87906242e87d3ddb2ba9827818f2d1416d80cc7)
Ubuntu 12.04 64bits

BUT

I have make some test and second windows seem to appear randomly and doesn't take care of the first windows open.

Sometimes, it's open some pixels below, sometimes above (but never when my windows is on top) ! 
So, perhaps the problem is why somethimes the windows appear above ??
it would be nice to know how Writer decide to place next windows ?
Comment 2 Joel Madero 2013-06-24 01:43:50 UTC
Version: 4.2.0.0.alpha0+Build ID: b0a1666f756aa5f5315366eca9d7d02ddd55d2b
Date:   Tue May 28 08:51:01 2013 +0300 
Platform: Bodhi Linux 2.2 x64

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +

I cannot reproduce this, windows open just below the 1st one and every subsequent window opens up in a similar position just under the titlebar of the last Window that was opened.


If this is still an issue with version 4 please let us know what version you have tested on and still see the issue, mark the bug as UNCONFIRMED and we'll go from there.


Thanks

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material