Bug Hunting Session
Bug 50104 - UI Calc: Add to context menu "Move&Paste" (insert mode) additionally to "Cut content&Paste" (overwrite mode)
Summary: UI Calc: Add to context menu "Move&Paste" (insert mode) additionally to "Cut ...
Status: RESOLVED DUPLICATE of bug 39936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-18 14:53 UTC by gleppert
Modified: 2012-10-15 16:12 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description gleppert 2012-05-18 14:53:15 UTC
Drag-and-drop of cells in Calc has two important modes: The overwrite mode and the insert mode (please see http://help.libreoffice.org/Calc/Moving_Cells_by_Drag-and-Drop). The overwrite mode ist the standard in LO and the insert mode can be activated with the Alt key when pasting.

However, if you don't use drag-and-drop, but you use the right mouse click context menu, only the first mode, the "overwrite mode" is accessible. It is called there "Cut&Paste" (IMHO it should be called "Cut content&Paste"

An equivalent to the insert mode in the context menu is missing!!! I suggest to add to the context menu the entry "Move&Paste" or "Cut cells&Paste" which does the same like the insert mode does when applying drag-and-drop.

This enhancement is of real competitive importance, because it is widely assumed that LibreOffice/OpenOffice cannot move rows/columns like Excel can do it: Moving rows/columns without leaving back empty spaces and without overwriting existing content. Excel calls it "Cut&Paste cut cells". I know many people who hate Calc, because they could never discover this feature!

I am quite sure that this must be a very EasyHack, since the feature is there and must be only made accessible. Could you please verify this as an EasyHack?
Comment 1 Joel Madero 2012-10-15 16:12:49 UTC
This is a duplicate of 39936
https://bugs.freedesktop.org/show_bug.cgi?id=39936

Trying to get it on the easy hack list, then hopefully we can get a developer to tackle it relatively quickly. Thanks for reporting

*** This bug has been marked as a duplicate of bug 39936 ***