Download it now!
Bug 50137 - After created user profile, LibO close
Summary: After created user profile, LibO close
Status: RESOLVED DUPLICATE of bug 43989
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks: mab3.6
  Show dependency treegraph
 
Reported: 2012-05-19 22:41 UTC by Korrawit Pruegsanusak
Modified: 2012-06-07 02:11 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Korrawit Pruegsanusak 2012-05-19 22:41:33 UTC
1. Install LibO, I use Administrative install (msiexec /a)

2. Do anything to make sure that this installation will create new user profile, such as:

2A. After install finished, go to path-to-installation/program/bootstrap.ini, change the value of UserInstallation to UserInstallation=$ORIGIN, or
2B. Delete old user profile

3. Run path-to-installation/program/soffice.exe

Actual: Splash screen show, and LibO closed. The process soffice.bin/.exe are not found in Task Manager. I have to run soffice.exe again to open LibO

Expected: Splash screen show, and LibO open at Start Center


Next test:
4. After LibO open at start center, close it by File > Exit.
5. Delete user profile
6. Run path-to-installation/program/soffice.exe, the result is same as the above.
7. Repeat step 4-6, the result is still the same

So, I conclude that, after creating user profile, LibO close, no matter it's the first run after install or not.


[REPRODUCIBLE] on Administrative install on Windows XP, with:
tinderbox W2008R2@16-minimal_build
pull time 2012-05-18 00:57:37
git core: 3da4ab93e14bbe472ac0a6bce52616a93a2506d2
Comment 1 Korrawit Pruegsanusak 2012-05-19 23:05:44 UTC
(In reply to comment #0)
> [REPRODUCIBLE] on Administrative install on Windows XP

Also REPRODUCIBLE with normal install of same build (by double-click the installer, and following the wizard) on Windows XP.
Comment 2 Korrawit Pruegsanusak 2012-05-30 04:07:14 UTC
with Administrative install (msiexec /a), still [REPRODUCIBLE] on WinXP with
> tinderbox: W2008R2@16-minimal_build
> pull time: 2012-05-28 04:23:11
> core: b5f066e64a49aa007e04dc57dc0bbd0857ca0e2f

Some testing indicate that this problem is regression BETWEEN
> tinderbox: pull time 2012-05-02 06:53:41
> core:35ec1539218523579e9877e0a6d135bde128ab81
> binfilter:65042e25c2d6c0d1b06a975b916fa61eb77f20ff
> dictionaries:cf84660ff8b6b89def50ca0d7af38d9577abcec7
> help:10a89e6fec25262205e54741db45823abb630d0b

AND

> tinderbox: pull time 2012-05-06 22:03:33
> core:34513fe619aee112b11a0a90dc2e981dccdb408e
> binfilter:1dbdf3726bd22e7e40d24eb2e4732865f4334a41
> dictionaries:cf84660ff8b6b89def50ca0d7af38d9577abcec7
> help:10a89e6fec25262205e54741db45823abb630d0b

I didn't download any tinderbox builds between May 02 and May 06
Comment 3 manj_k 2012-05-30 05:31:47 UTC
Reproducible on WinXP 32b
w/
LibO-Dev_3.6.0alpha0
W2008R2@20-With-Symbol-Bytemark-Hosting MASTER
pull time 2012-05-28 04:23:57
core:b5f066e64a49aa007e04dc57dc0bbd0857ca0e2f.

That happened with each of the pre-installed extensions (other pre-installed extensions each time removed).

Rename the folder 'extensions' [path-to-installation\share\extensions] to 'extensions_bak' (or remove all extensions from folder 'extensions'; then LibO will not be closed.
Comment 4 Stephan Bergmann 2012-05-30 05:58:25 UTC
It is normal that soffice.bin exits early (with a special exit code of 81) whenever it detects that the bundled and/or shared extensions are not in sync with the corresponding user profile data (which is esp. the case when a new user profile directory is created).  However, the outer soffice.exe should restart soffice.bin when it exits with the special code of 81.  Would be strange if that mechanism stopped working.
Comment 5 Petr Mladek 2012-06-01 01:21:14 UTC
I guess that this is duplicate of the bug 43989.
Comment 6 Korrawit Pruegsanusak 2012-06-06 02:04:29 UTC
[REPRODUCIBLE] on Windows XP with build from tinderbox Win-x86@6-fast, pull time 2012-06-05 10:06:05, core: 4cf7551c24f5dad694fecbb2b80b2b52173ffdb7

[NOT REPRODUCIBLE] on Windows XP with build from tinderbox Win-x86@6-fast, pull time 2012-06-05 23:16:58, core: b255de87082d11a42d7af7860dcc4e971342df06

So, I think yes, the fix also help here. Thanks Andras! :-)

*** This bug has been marked as a duplicate of bug 43989 ***
Comment 7 Andras Timar 2012-06-06 02:37:46 UTC
(In reply to comment #4)
> It is normal that soffice.bin exits early (with a special exit code of 81)
> whenever it detects that the bundled and/or shared extensions are not in sync
> with the corresponding user profile data (which is esp. the case when a new
> user profile directory is created).  However, the outer soffice.exe should
> restart soffice.bin when it exits with the special code of 81.  Would be
> strange if that mechanism stopped working.

I think that this is the case (started from LibreOffice 3.4). The fix of bug #43989 only prevents this happening, so we need to investigate a little bit, why this mechanism stopped working.
Comment 8 Stephan Bergmann 2012-06-07 02:11:03 UTC
(In reply to comment #7)
> The fix of bug
> #43989 only prevents this happening, so we need to investigate a little bit,
> why this mechanism stopped working.

see <https://bugs.freedesktop.org/show_bug.cgi?id=43989#c41>