Download it now!
Bug 50143 - Can't select drop-down tool buttons when they become list items (in narrow window)
Summary: Can't select drop-down tool buttons when they become list items (in narrow wi...
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: x86-64 (AMD64) All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-20 05:12 UTC by V字龍(Vdragon)
Modified: 2012-08-11 06:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description V字龍(Vdragon) 2012-05-20 05:12:56 UTC
reproduce steps
1.open Impress (or Writer), decrease the window width to let "font color" toolbar button disappear
2.Click >> to let the show the disappear toolbar buttons
3. click "Font Color"


Expect to see 
display a palette so I can select color

But see:
it just "clicked" and no palette shows up

Screenshot
http://ind.ntou.edu.tw/~pika1021/Files/Picture_cache/Screenshot28.png

I increase the severity a bit, since it is a frequently used function.
Feel free to turn it back if its inappropriate
Comment 1 Cheng-Chia Tseng 2012-05-22 11:22:07 UTC
I can confirm this with LibreOffice 3.5.2.1 on Fedora 17 (Beta).

Besides "font color", "character background" and "background" which have a dropdown menu are all affected. They cannot work with limited window width either.
Comment 2 Paul W. Frields 2012-08-10 12:14:06 UTC
This problem continues in libreoffice-core-3.5.5.3 (I'm using this on Fedora 17 x86_64 as well).  It has been present for quite some time.  I had to help a coworker with this problem yesterday.  Her screen was not high enough resolution to allow the LibreOffice window to grow any wider.

The only way to remedy the problem was to remove other toolbar buttons to make room for the font color button.  This is far from obvious to desktop productivity users.
Comment 3 Jean-Baptiste Faure 2012-08-10 18:23:09 UTC
Please don't change version number, it give the first version in which the bug has been found.

Please try with last release 3.6.0, the behavior of this button has been changed in LO 3.6. 

Best regards. JBF
Comment 4 Cheng-Chia Tseng 2012-08-11 04:35:17 UTC
I just confirmed 3.6.

There is nothing changed on this issue.
Comment 5 Jean-Baptiste Faure 2012-08-11 05:43:28 UTC
Indeed dropdown lists or palette are not available when clicking on the >> on too short toolbars. You have the same problem with borders or character sizes.

As a workaround you can undock the toolbar to make it floating.

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2012-08-11 06:25:04 UTC
Same behavior on MS-Windows. Changed platform to All

@Ivan: do you know if it is a bug or only a limitation in the toolbar mechanism?
In other words, it is a bug or an enhancement?

Best regards. JBF
Comment 7 Ivan Timofeev (retired) 2012-08-11 06:28:56 UTC
It is enhancement I guess. Known issue, but I almost forgot about it.

*** This bug has been marked as a duplicate of bug 42029 ***