Download it now!
Bug 50144 - Additional information in the Insert cross-reference dialogue Selection field
Summary: Additional information in the Insert cross-reference dialogue Selection field
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Andras Timar
URL:
Whiteboard: target:3.6.0.0.beta1 target:3.7.0 tar...
Keywords:
: 34872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-20 05:57 UTC by andis.lazdins
Modified: 2012-08-03 09:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description andis.lazdins 2012-05-20 05:57:12 UTC
It would be great if the Insert cross-reference dialogue Selection field would contain also content of reference text following to the caption number (caption of table or chart or other object) like in case of numbered paragraphs. It would make much easier editing of large documents with tens of tables with references in different pages.
Comment 1 Not Assigned 2012-06-06 14:19:48 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d56ad449084272e5ccc36444d5ce16e0b5e368a4&g=libreoffice-3-6

fdo#50144 put full reference text to selection field


It will be available in LibreOffice 3.6.
Comment 2 Not Assigned 2012-06-06 14:20:13 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=10837b669c9fe3f6b1e1905bfbb855ca02497eb7

fdo#50144 put full reference text to selection field
Comment 3 Andras Timar 2012-06-06 14:40:49 UTC
*** Bug 34872 has been marked as a duplicate of this bug. ***
Comment 4 Not Assigned 2012-06-07 00:36:29 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7f7dec9b42d347e06b71f81f1e18cbe881e16927&g=libreoffice-3-5

fdo#50144 put full reference text to selection field


It will be available in LibreOffice 3.5.5.
Comment 5 andis.lazdins 2012-06-07 23:05:41 UTC
I can confirm that this improvement, having first inquiries already in StarOffice 5.x, is finally implemented! It is excellent improvement in usability. From the versions 3.5.5 and 3.6 Libreoffice will be more advanced than Microsoft office in functionality of captions and cross-references, because there is default option to have caption identifier after number and now it is also possible to see the caption text in the cross-reference dialogue.

Thanks for this great improvement!
Comment 6 andis.lazdins 2012-06-14 00:38:30 UTC
I can confirm that it is fixed in LibreOffice 3.5.5.1 Build ID: c9944f7-48b7ff5-0507789-54a4c8a-8b242a8

Thanks for great job!
Comment 7 Rainer Bielefeld Retired 2012-08-03 09:14:36 UTC
We need exact and correct target information for automated lists in Wiki and LibO Web Site.