Download it now!
Bug 50178 - Reading Visio file causes crash
Summary: Reading Visio file causes crash
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: high normal
Assignee: Not Assigned
URL:
Whiteboard: target:3.6.0 target:3.5.5
Keywords:
: 50180 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-21 09:07 UTC by Tom
Modified: 2013-11-13 10:49 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
a visio file which crashes (85.50 KB, application/vnd.visio)
2012-05-21 22:48 UTC, Julien Nabet
Details
console msgs + bt (12.80 KB, text/plain)
2012-05-21 22:49 UTC, Julien Nabet
Details
test.VSD (165.16 KB, application/vnd.visio)
2012-05-24 13:01 UTC, Tom
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2012-05-21 09:07:04 UTC
The LibreOffice draw application seems to read MS Visio files most of the time.
Some Visio files cause the application to stop working.  Repeating the process
sometimes works but not always.  It would be great if this function would work
reliably as I don't want to spend $500 for Visio.
Conditions:
LibreOffice 3.5, only installed draw application not the whole suite.
Visio 2003 files
Windows 7 Pro
Comment 1 Julien Nabet 2012-05-21 13:14:35 UTC
Could you attach examples of Visio files which don't work ?
First to try to reproduce, then to try to debug.
Comment 2 Julien Nabet 2012-05-21 22:48:17 UTC
Created attachment 61937 [details]
a visio file which crashes

Reportee sent me this file. He was ok to put it in attachment.
Comment 3 Julien Nabet 2012-05-21 22:49:07 UTC
Created attachment 61938 [details]
console msgs + bt

On Pc Debian x86-64, with master sources updated yesterday, I reproduced the problem.
I attached console logs + bt.
Comment 4 Julien Nabet 2012-05-21 22:49:50 UTC
I update to all since it crashes on Windows and Linux. (someone to test on Mac ?)
Comment 5 Julien Nabet 2012-05-21 22:52:15 UTC
*** Bug 50180 has been marked as a duplicate of this bug. ***
Comment 6 Julien Nabet 2012-05-23 23:26:40 UTC
I proposed a patch here http://nabble.documentfoundation.org/PATCH-fix-proposed-for-fdo-50178-Visio-tp3985678.html. I'm waiting for the comments of devs.

Meanwhile, could you attach other Visio files which fail ? I'd like to test them to see if it was the same problem or if it's different.
Comment 7 Not Assigned 2012-05-24 11:45:56 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=03764e29978bcf0b59a3738166b5af31d0af582a

Resolves: fdo#50178 Reading Visio file causes crash
Comment 8 Tom 2012-05-24 12:16:07 UTC
Here is a file from Visio from an older Visio version.  Opens in 2003 Visio.  For draw does not crash but requests to know which graphics format.  Selecting Visio in list gives general error and unknown format.  Please use this for test but do not publish on bug zilla.  I could not find other files that draw could not open.

Thanks,

Tom S.

x6138

-----Original Message-----
From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Wednesday, May 23, 2012 11:27 PM
To: Tom Stanford
Subject: [Bug 50178] Reading Visio file causes crash

https://bugs.freedesktop.org/show_bug.cgi?id=50178

Julien Nabet <serval2412@yahoo.fr> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO

--- Comment #6 from Julien Nabet <serval2412@yahoo.fr> 2012-05-23 23:26:40 PDT ---
I proposed a patch here
http://nabble.documentfoundation.org/PATCH-fix-proposed-for-fdo-50178-Visio-tp3985678.html.
I'm waiting for the comments of devs.

Meanwhile, could you attach other Visio files which fail ? I'd like to test
them to see if it was the same problem or if it's different.
Comment 9 Julien Nabet 2012-05-24 12:59:09 UTC
Created attachment 62074 [details]
test.VSD

Must have missed something. You speak about which file ? If confidential as you said, don't hesitate to send it me.
Comment 10 Tom 2012-05-24 13:01:32 UTC
Attached.  Sorry forgot to attach!

Thanks,

Tom S.

x6138


-----Original Message-----
From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Thursday, May 24, 2012 12:59 PM
To: Tom Stanford
Subject: [Bug 50178] Reading Visio file causes crash

https://bugs.freedesktop.org/show_bug.cgi?id=50178

--- Comment #9 from Julien Nabet <serval2412@yahoo.fr> 2012-05-24 12:59:09 PDT ---
Must have missed something. You speak about which file ? If confidential as you
said, don't hesitate to send it me.
Comment 11 Julien Nabet 2012-05-24 13:33:57 UTC
You attached the file on bugtracker instead of having sent me directly. I can't do nothing about it since I'm not a bugzilla admin.
Comment 12 Julien Nabet 2012-05-24 13:50:03 UTC
About my last message, I just meant that I could retrieve your file since it's on bugtracker. But everyone can retrieve it too. So your file is not private at all now and I can't do anything about it :-(

About the file, I can't really open it.
I mean LO :
- asks which Ascii filter options to use (Character Set, Default fonts, Language and Paragraph break)
- opens it like a Writer file.
So it seems this older format is not recognized at all.

I think you should try to convert it on a newer version with Visio 2003 (and this time, you can send it to my email not on bugtracker)
Comment 13 Tom 2012-05-24 14:01:12 UTC
Once I open it and save it with Visio 2003 it works with Draw.  It is something to do with the older version of Visio.  I guess I don't have anything to add so if you fixed the other issue I would say THANKS!

Thanks,

Tom S.

x6138


-----Original Message-----
From: bugzilla-daemon@freedesktop.org [mailto:bugzilla-daemon@freedesktop.org] 
Sent: Thursday, May 24, 2012 1:50 PM
To: Tom Stanford
Subject: [Bug 50178] Reading Visio file causes crash

https://bugs.freedesktop.org/show_bug.cgi?id=50178

--- Comment #12 from Julien Nabet <serval2412@yahoo.fr> 2012-05-24 13:50:03 PDT ---
About my last message, I just meant that I could retrieve your file since it's
on bugtracker. But everyone can retrieve it too. So your file is not private at
all now and I can't do anything about it :-(

About the file, I can't really open it.
I mean LO :
- asks which Ascii filter options to use (Character Set, Default fonts,
Language and Paragraph break)
- opens it like a Writer file.
So it seems this older format is not recognized at all.

I think you should try to convert it on a newer version with Visio 2003 (and
this time, you can send it to my email not on bugtracker)
Comment 14 Not Assigned 2012-05-25 13:20:48 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=85fbe039a520f2ae42a3022af4269fa82cc4bf39&g=libreoffice-3-5

Resolves: fdo#50178 Reading Visio file causes crash


It will be available in LibreOffice 3.5.5.
Comment 15 Julien Nabet 2012-06-21 13:11:29 UTC
update the status since it's ok now with this file.
Comment 16 Tom 2012-06-21 13:27:00 UTC
Thanks for your email. I will be out of the office the week of June 18th and return on June 25th. I will have limited email access so I will answer your mail when I return.  My back up is Scott Weldner sweldner@hme.com, 858-535-6067.

Thanks,
Tom S.
x6138