Bug 50231 - FILEOPEN RTF: TABLE VIEWING destroyed
Summary: FILEOPEN RTF: TABLE VIEWING destroyed
Status: RESOLVED DUPLICATE of bug 49892
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.5.4 RC1
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Miklos Vajna
URL:
Whiteboard:
Keywords: filter:rtf, regression
Depends on:
Blocks:
 
Reported: 2012-05-22 12:51 UTC by Ivan
Modified: 2015-12-15 11:00 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
wrong original rtf (48.17 KB, application/rtf)
2012-05-22 12:51 UTC, Ivan
Details
wrong original rtf in pdf (47.45 KB, application/pdf)
2012-05-22 12:52 UTC, Ivan
Details
.doc for word 97-2003 convert in MO 2010 (42.00 KB, application/msword)
2012-05-22 12:52 UTC, Ivan
Details
.doc for word 97-2003 opened in LO in pdf (46.75 KB, application/pdf)
2012-05-22 12:53 UTC, Ivan
Details
original .rtf convert .doc in LO (58.50 KB, application/msword)
2012-05-22 12:54 UTC, Ivan
Details
original rtf convert .doc in LO in pdf (48.55 KB, application/pdf)
2012-05-22 12:54 UTC, Ivan
Details
normal .rtf opened in MO 2010 and saved .pdf (82.46 KB, application/pdf)
2012-05-23 13:30 UTC, Ivan
Details
How it looks like here with latest -3-6 (105.10 KB, image/png)
2012-12-22 15:36 UTC, Miklos Vajna
Details
Microsoft Office Word Viewer 2003 (114.42 KB, image/jpeg)
2012-12-23 21:29 UTC, Ivan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan 2012-05-22 12:51:38 UTC
Created attachment 61979 [details]
wrong original rtf

Problems in the attachment ...
1. Fileopen rtf
2. Сonversion .rtf -> .doc in LO
Comment 1 Ivan 2012-05-22 12:52:07 UTC
Created attachment 61980 [details]
wrong original rtf in pdf
Comment 2 Ivan 2012-05-22 12:52:38 UTC
Created attachment 61981 [details]
.doc for word 97-2003 convert in MO 2010
Comment 3 Ivan 2012-05-22 12:53:00 UTC
Created attachment 61982 [details]
.doc for word 97-2003 opened in LO in pdf
Comment 4 Ivan 2012-05-22 12:54:27 UTC
Created attachment 61983 [details]
original .rtf convert .doc in LO
Comment 5 Ivan 2012-05-22 12:54:49 UTC
Created attachment 61984 [details]
original rtf convert .doc in LO in pdf
Comment 6 s-joyemusequna 2012-05-23 10:52:52 UTC
Confirmed with LOdev 3.6 (master - 23-May-2012 03h12 x86@6-fast; Build ID: 7e65666) under Windows Vista 64 and Windows XP. File is a mess when saved as .doc.

Same problem with LibO 3.4.5 and Libo 3.3.4. 

LibO 3.3.4 and LibO 3.4.5 display the file correctly, LOdev 3.6 is not even able to display it correctly => this is partly a regression.

There are apparently no problems if the .rtf file is saved as .odt, not even with LOdev 3.6, the file looks OK when opened.
Comment 7 Ivan 2012-05-23 13:28:15 UTC
(In reply to comment #6)
> There are apparently no problems if the .rtf file is saved as .odt, not even
> with LOdev 3.6, the file looks OK when opened.

No, the normal form of RTF file is represented in the 7 attachment. You save an invalid file in .odt
Comment 8 Ivan 2012-05-23 13:30:00 UTC
Created attachment 62033 [details]
normal .rtf opened in MO 2010 and saved .pdf
Comment 9 Miklos Vajna 2012-12-22 11:11:13 UTC
The RTF ipmort part looks fine on even latest 3.6, closing as a duplicate. Sorry for not noticing this earlier.

*** This bug has been marked as a duplicate of bug 49892 ***
Comment 10 Ivan 2012-12-22 11:48:57 UTC
Miklos Vajna

LO 3.6.4.3 (ID сборки: 2ef5aff)

I'm sorry but you're wrong, bug not fixed until the end.
Please open the file (wrong original rtf.rtf) through Microsoft Office Word Viewer 2003 and you will see how the file should look in LO.

and I can not open (wrong original rtf.rtf) in LibreOffice 4.0.0 Beta1 (2012-12-07). File - open -> Overall IO error (Oбщая ошибка ввода-вывода)
Comment 11 Miklos Vajna 2012-12-22 15:36:46 UTC
Created attachment 71976 [details]
How it looks like here with latest -3-6
Comment 12 Miklos Vajna 2012-12-22 15:41:03 UTC
Hi Ivan,

Attached a screenshot how it looks like here with latest 3.6 (git hash: c796f58d6ea3999268333f6cff687ee517882717, 2012-12-19). In general it looks sane to me. If there is still some difference that wasn't there in an earlier version (this bug is tagged as a regression), please describe it.

You can find -3-6 daily builds at http://dev-builds.libreoffice.org/daily/libreoffice-3-6/

Thanks,

Miklos
Comment 13 Ivan 2012-12-23 21:29:14 UTC
Created attachment 72045 [details]
Microsoft Office Word Viewer 2003

This's how the file should look like in LO at this moment it is not.
Comment 14 Ivan 2012-12-23 21:38:43 UTC
And export to pdf from LO =(

Please see the screenshots:
normal - .doc for word 97-2003 opened in LO in pdf
bad - original rtf convert .doc in LO in pdf

I'm sorry for my English.
Comment 15 Robinson Tryon (qubit) 2015-12-15 11:00:13 UTC
Migrating Whiteboard tags to Keywords: (rtf_filter -> filter:rtf)
[NinjaEdit]