Bug Hunting Session
Bug 50294 - Spellcheck shouldn't trigger on case difference if first word of sentence/heading
Summary: Spellcheck shouldn't trigger on case difference if first word of sentence/hea...
Status: RESOLVED DUPLICATE of bug 37954
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Linguistic (show other bugs)
Version:
(earliest affected)
3.5.3 release
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2012-05-23 16:21 UTC by Jon Grossart
Modified: 2012-05-26 20:54 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jon Grossart 2012-05-23 16:21:34 UTC
I use a lot of custom dictionary entries for medical words.

However, for each word I use, I need to have a lower case and upper version of the word since they are often used as the first word in a heading or a sentence.

Currently, the spell checker triggers this as a spelling error. It should find the lower case version and apply some "intelligence" to decide it the capitalization is "correct" (or provide options to ignore certain capitalization errors like first character of sentence and headings as spelling errors).
Comment 1 Roman Eisele 2012-05-24 00:42:35 UTC
This is a spellcheck issue, therefore changed the Component field to 'Linguistic' (the component used "For problems with spell checking, hyphenation and thesaurus").
Comment 2 Jon Grossart 2012-05-24 09:26:04 UTC
I should perhaps add an example:

let's say I add "myofascia" to my custom dictionary.

The myofascia is tight. -> no spelling error.
Myofascia often develops restrictions. -> spelling error since I only added "myofascia" to the dictionary, not "Myofascia".

I can add both to the dictionary, but then the dictionary get potentially 2x as big, plus more of a chance to add a mispelled variant by accident since have to add it twice. Just increases the signal to noise ratio for the spell checker.
Comment 3 manj_k 2012-05-24 15:23:47 UTC
Similar to 'Bug 37954 - EDITING Writer AutoSpellcheck flags capitalized words as misspelled despite being added lowercase in the custom dictionary'.

@Jon Grossart:
Would you agree to mark your report as duplicate of bug 37954?
Comment 4 Jon Grossart 2012-05-26 20:53:36 UTC
Yes, it would seem to be a duplicate of the same issue.

However, it seems the other bug is being somewhat ignored/downplayed. I think this is an important flaw/bug/enhancement toward making the daily use of LibO to be better.

And, it would also bring another level of feature parity to MS Office (as you only need to have the lowercase variant in the custom dictionary for the spellcheck to pass).
Comment 5 Jon Grossart 2012-05-26 20:54:24 UTC

*** This bug has been marked as a duplicate of bug 37954 ***