Download it now!
Bug 50511 - Wide Calc table is not printed in landscape format
Summary: Wide Calc table is not printed in landscape format
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Printing and PDF export (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta2
Hardware: x86-64 (AMD64) Linux (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 66748 97079 (view as bug list)
Depends on:
Blocks:
 
Reported: 2012-05-30 12:08 UTC by BG
Modified: 2017-09-05 06:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
simple spreadsheet to test printing in landscape mode (7.05 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-08-18 14:23 UTC, D. Hugh Redelmeier
Details

Note You need to log in before you can comment on or make changes to this bug.
Description BG 2012-05-30 12:08:27 UTC
Using the LO 3.5.3 x64 Linux version running under openSuSE 12.1 x64 I've created a Calc table with wide columns which exceed the width of an A4 page in "portrait" orientation. Therefore, I've switched the document's page format (via menu item "Format/Page/Tab 'Page'/Alignment") from "Portrait" to "Landscape". Although the print preview shows me now a correctly aligned page, where my table fits in its total width on one "landscaped" page, the document itself is later printed always in portrait orientation split up in two pages (the first x columns printed on page 1, the remaining columns printed on page 2 etc.). However, first exporting the same document to a .pdf file and then printing the .pdf file contents to the same printer works fine (page is printed in landscape orientation). Moreover, using the same document with the LO 3.5.3 x86 Windows versions works absolutely perfect without any changes, that is, it is directly printed to my printer as expected (without a detour via a .pdf export).
Comment 1 BG 2012-05-31 11:27:26 UTC
I can confirm this bug for LO 3.5.4 x64 and 3.4.6 x64 (Linux versions) as well.
Comment 2 mournblade 2012-07-05 17:15:55 UTC
This problem still isn't fixed in Libreoffice 3.6 Beta 2.  I'm using openSUSE 12.1, and I can't print landscape on my HP CP2025DN printer in either Writer or Calc.  Page preview shows it as landscape, but it prints out in portrait on the printer.  Other non-Libreoffice programs print landscape just fine, so it's not a print driver issue (other then libreoffice not correctly signaling the driver to print in landscape).

This bug is a show-stopper for anyone working with landscape documents.
Comment 3 stuttgarter 2012-07-26 08:56:43 UTC Comment hidden (off-topic)
Comment 4 stuttgarter 2012-07-26 09:06:07 UTC
(In reply to comment #3)
> S
Sorry too fast

Same problem in impress LO 3.5.5.3 OpenSuse 11.1

I think is a high critical problem and a show stopper because presentations are always landscape
Comment 5 D. Hugh Redelmeier 2013-08-14 16:57:09 UTC
This may be related to https://bugs.freedesktop.org/show_bug.cgi?id=66748#c1

The setting in 4.1.0.4 is called Paper Format: Orientation.
Comment 6 retired 2013-08-15 09:51:17 UTC
*** Bug 66748 has been marked as a duplicate of this bug. ***
Comment 7 retired 2013-08-15 09:53:41 UTC
Can someone please attach a test document? I can not reproduce this problem in LO 4.1.1.1, OS X 10.8.4.

Also is this happening for anybody using LO 4.1.1.1? http://www.libreoffice.org/download/pre-releases/
Comment 8 D. Hugh Redelmeier 2013-08-18 14:21:50 UTC
Following up my comment #1 in https://bugs.freedesktop.org/show_bug.cgi?id=66748

I'm using libreoffice 4.1.0.4 on Fedora 19.

The printer is a Brother DCP-7065dn with Brother's proprietary printer drivers, connected by ethernet.  This might matter.

Nothing I tried, with the simplest spreadsheet created for this testing, could get it printed landscape.

However, printing from LibreOffice on my Fedora system, to a printer attached to a Windows box, through Samba, could print in landscape mode.

Gnumeric properly printed the spreadsheet in Landscape mode on the DCP-7065dn.

Calligra-Sheets mistakenly printed the spreadsheet in portrait mode on the DCP-7065dn, just like LibreOffice.

Perhaps this a printer driver problem, not a LibreOffice problem.  How can I tell?  I'd love a little test program to send Brother.
Comment 9 D. Hugh Redelmeier 2013-08-18 14:23:31 UTC
Created attachment 84196 [details]
simple spreadsheet to test printing in landscape mode
Comment 10 D. Hugh Redelmeier 2013-08-18 15:47:38 UTC
This message in the mailing list provides a work-around.  It doesn't seem to work for me, but it does work for others. http://listarchives.libreoffice.org/global/users/msg21365.html

There is a claim that this is a LibreOffice bug, not a printer driver bug.

It is worth reading the whole thread.
Comment 11 chuck.pobanz 2014-08-01 18:46:25 UTC
This (kind of) works for me, but not in the expected way. 
If I select print from the file menu, it doesn't matter whether I go to the printer "properties" and change to landscape or to portrait. The print preview and printing does not change and is the same as shown in the print preview on the left side of the print dialog box. 

However when going to the 'file' "page preview" and selecting the 'format page' and then 'page', and selecting portrait or landscape, it changes how it prints by changing the default page style  (I have not needed to change anything about pdf or postscript as noted in comment 10 and in fact changing these did not effect the printout). This works for a Brother MFC-8860DN and for a Dell 3100DN. I am not sure what driver is in use. I am using whatever ubuntu supplied. 

Ubuntu 14.04
Libreoffice 4.2.6.2 Build ID: 420m0(Build:2)
using sample spreadsheet as attached in comment 9
Comment 12 QA Administrators 2015-09-04 02:47:38 UTC Comment hidden (obsolete)
Comment 13 D. Hugh Redelmeier 2015-09-05 14:04:12 UTC
I just tested the example that I had uploaded as an attachment "simple spreadsheet to test printing in landscape mode".

With no fussing, it just worked.

I don't know if I left printer settings in a particularly useful way (someone else had just printed something else in landscape mode using the same network printer but a different host computer).

Setup:

- printer: Brother DCP7065DN via network (same as previous times)

- OS: Fedora 21 Linux

- proprietary drivers:
   cupswrapperDCP7065DN-2.0.4-2.i386.rpm
   dcp7065dnlpr-2.1.0-1.i386.rpm

- libreoffice version from Fedora 21 repository:
   libreoffice-*-4.3.7.2-9.fc21.x86_64
  I'm surprised that Fedora 21's version is no longer supported.
Comment 14 rodneykp1 2016-02-08 04:22:15 UTC
Bug is still present for some printers only, using currently supported LO  5.0.2.2 on up-to-date openSUSE Leap 42.1.

Brother MFC-J6nnnDW series are A3 capable and as for most such printers feed A4 as well as A3 short-edge first ie Portrait orientation in Print -> Properties -> Paper dialog.  Latest driver package ver 3.0.0-1 from Brother has PS parameter "*VariablePaperSize: False". I work around this by having separate queues for A3 & A4, but these factors create some weird outcomes with LO.

If a new landscape document is set to Format -> Page -> Format: A4, Orientation: Landscape then LO dialogs for Print -> Properties -> Paper differ depending on whether selected from File -> Print or File -> Printer Settings.  The latter shows (greyed-out) paper orientation Portrait (which according to https://en.opensuse.org/SDB:Landscape_Printing, is correct practice). The former shows (greyed-out) paper orientation Landscape.  Outcome on paper is equally incorrect, with part of the work only in centre of portrait oriented paper.

If same landscape document is then set to Format -> Page -> Format: A3, Orientation: Landscape, ie all that is changed is paper size, then LO  still shows A4 paper in  Print & Print Settings dialogs, although an A3 queue has been selected.  Job then prints out incorrectly in portrait page orientation but scaled up to A3 size.  I've checked /etc/cups/ppd and the PPD file for A3 queue definitely has page size set to A3.
Comment 15 Buovjaga 2016-04-12 12:06:14 UTC
*** Bug 97079 has been marked as a duplicate of this bug. ***
Comment 16 QA Administrators 2017-09-01 11:14:58 UTC Comment hidden (obsolete)
Comment 17 BG 2017-09-05 06:43:25 UTC
Seems to work now using LO 5.4.1.2 with
Linux 3.12.67-64-desktop, openSUSE 13.1 (Bottle) (x86_64), KDE 4.11.5, incl. all available OS updates